Post Reply

Car charger is not charging the device fast enough

OP amir77a

5th October 2012, 08:46 AM   |  #1  
OP Senior Member
Thanks Meter: 3
 
329 posts
Join Date:Joined: May 2004
More
Hi

While I'm driving I'm using Waze for navigation, and the device is also connected to my in car multimedia unit via BT as a phone.
I'm connecting the device to the car charger, and getting the charging icons, so it is actually charging the device.

BUT... it seems that the charging is too slow. The percentages of the battery is going down, instead of going up. Yesterday while driving & charging, the battery totally got drained, and device turned itself OFF.

The charger cable is Samsung OEM, purchased before for the Galaxy S2.

I wonder if any other charger will better charge the S3?

What do you think?

Thanks!
5th October 2012, 11:27 AM   |  #2  
Senior Member
Thanks Meter: 523
 
2,288 posts
Join Date:Joined: Jan 2011
Use a kernel where you can.change the charging rate (eg siyah) and switch.the screen off when not needed. Naigation will then be usable with constant battery level

Sent via TCP/IP
5th October 2012, 11:42 AM   |  #3  
OP Senior Member
Thanks Meter: 3
 
329 posts
Join Date:Joined: May 2004
More
Quote:
Originally Posted by gsw5700

Use a kernel where you can.change the charging rate (eg siyah) and switch.the screen off when not needed. Naigation will then be usable with constant battery level

Sent via TCP/IP

I'm currently using stock kernel, and prefer not to change kernel.

I wonder if there is a simple way...another charger maybe?
5th October 2012, 01:25 PM   |  #4  
Skander1998's Avatar
Senior Member
Flag Doha
Thanks Meter: 512
 
1,309 posts
Join Date:Joined: May 2012
Donate to Me
More
Yep, try a stronger charger (higher amps)
5th October 2012, 01:40 PM   |  #5  
OP Senior Member
Thanks Meter: 3
 
329 posts
Join Date:Joined: May 2004
More
Can anyone point me to such a charger?
5th October 2012, 02:02 PM   |  #6  
Skander1998's Avatar
Senior Member
Flag Doha
Thanks Meter: 512
 
1,309 posts
Join Date:Joined: May 2012
Donate to Me
More
http://www.ebay.com/itm/XENTRIS-31-1...item53eebe35bc
5th October 2012, 02:08 PM   |  #7  
iris_aim's Avatar
Senior Member
Flag Lahore
Thanks Meter: 9
 
339 posts
Join Date:Joined: Mar 2006
I was having similar problems,changed the USB wire that goes into wall charger and BOOM!it was charging all fine again,try changing to other USB cable,won't hurt in trying..
5th October 2012, 03:22 PM   |  #8  
OP Senior Member
Thanks Meter: 3
 
329 posts
Join Date:Joined: May 2004
More
Thanks for the link and the advice. I will try all
5th October 2012, 04:01 PM   |  #9  
Senior Member
Thanks Meter: 36
 
343 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by amir77a

I'm currently using stock kernel, and prefer not to change kernel.

I wonder if there is a simple way...another charger maybe?

I am also using the stock kernel but car charger is changing well when I am using the navigation. Maybe, change the car charger.

Sent from my GT-I9300T using xda premium
9th October 2012, 09:56 AM   |  #10  
OP Senior Member
Thanks Meter: 3
 
329 posts
Join Date:Joined: May 2004
More
Just to inform, I've changed to another Samsung charger.. now it's charging much better.

With 2 hours of driving, using navigation software and BT was connected to the car's multimedia unit: Started with battery at 2%, ended with battery at 15%. not the best but reasonable.

Post Reply Subscribe to Thread

Tags
car charging slow
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes