Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,194 Members 41,754 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Extremely wierd SGS3 Problem

Tip us?
 
Eibram
Old
#1  
Eibram's Avatar
Member - OP
Thanks Meter 12
Posts: 33
Join Date: Feb 2011
Location: Batangas City
Unhappy [Q] Extremely wierd SGS3 Problem

Okay first of all, I've scoured not only XDA but even Google for an answer to this problem to no avail. So if anyone has/knows of any thread that has the answer, please kindly reply or notify me so we can have this thread removed.

Here goes,

I'm experiencing a very unique (afaik) problem with my Galaxy S3. This started a few months back, when the phone started getting random reboots/ freezes and terrible battery life on ANY ROM/Kernel. I've tried CM, SlimBean/Kat, and even Stock and nothing worked. Finally I figured maybe the battery was shot. So a few days ago I went and got a new battery, and that's when it got weird.

I used the latest SlimKat after replacing the battery and after powering on the device, EVERYTHING seems perfect. It's really fast and responsive, battery drain while screen is on is extremely acceptable, things worked like new again. UNTIL I switched off the display, after 5 mins, I pulled out the phone and it was switched off. At first I thought maybe the initial charge wore down so I charged the phone to full, then powered it on. Again, everything went smoothly BUT, after switching off the display for more than 1 minute, the phone shuts off automatically.

I switched to the latest stock 4.3 ROM and restored everything to factory settings and it seems to have helped at first. As usual, everything is fast and battery doesn't drain so much BUT, after putting the phone to sleep, it takes 5-10 seconds for the screen to wake after pressing the power button, and even if it wakes up, it becomes EXTREMELY laggy and often freezes requiring a reboot. As usual, after a fresh reboot, everything becomes awesome again until I have to turn the display off for more than a minute.

I've tried everything, even installing an app that prevents deep sleep but the problem persists. It improved a little after flashing stock rom and reverting everything back so I'm really hoping this isn't a hardware issue. Is there maybe something else I can try, settings/software-wise? The phone is almost 2 years old and is already out of warranty.

I'm hoping it's not the sleep of death thing because the phone isn't exactly bricked. I can still use it for as long as it doesnt have to go into deep sleep (I turn it off before putting in my pocket and turn it on again when I need to browse/use the camera which is all it's good for in its current state.)

Also, the symptoms don't really fit the usual "Sleep of Death/Brickbug" Symptoms I've read about.
Phone History
Nokia 3210, Nokia 3310, Motorola V100, Nokia 3530, Nokia 6600, Motorola E1070, Sony Ericsson W710i, Sony Ericsson K800i, Sony Ericsson P1i, Samsung Galaxy 5 GT-I5500, Samsung Galaxy SII GT-I9100, Samsung Galaxy SIII GT-I9300
 
shadyr25
Old
#2  
shadyr25's Avatar
Senior Member
Thanks Meter 58
Posts: 220
Join Date: Aug 2010
Hey, I remember having a similar problem. I formatted both my internal sd and external sd. Haven't had any problems ever since. Hope this helps.

Sent from my SM-N9005 using XDA Free mobile app
MagicConfig UV Tweaks
Hyperdroid Rom Where Speed, Life and Performance Matters
Hope this helps someone, anyone and everyone
Sent from my GSII Xtreme Gingerbread ED
The Following User Says Thank You to shadyr25 For This Useful Post: [ Click to Expand ]
 
Eibram
Old
#3  
Eibram's Avatar
Member - OP
Thanks Meter 12
Posts: 33
Join Date: Feb 2011
Location: Batangas City
Already tried that. I did full wipes/formats on all my installs. I even tried not having an external SD inserted for the Odin installs. I tried not installing any app on the phone and it still gets messed up after going to sleep. As fresh installed AOSP or Pure Stock ROM. Odin flashes no problem so I'm really hoping nothing hardware-wise is messed up. I had to re-flash PIT after getting a new battery though, could I have messed something up there that would lead to this?
Phone History
Nokia 3210, Nokia 3310, Motorola V100, Nokia 3530, Nokia 6600, Motorola E1070, Sony Ericsson W710i, Sony Ericsson K800i, Sony Ericsson P1i, Samsung Galaxy 5 GT-I5500, Samsung Galaxy SII GT-I9100, Samsung Galaxy SIII GT-I9300
 
menda_3
Old
#4  
Junior Member
Thanks Meter 2
Posts: 26
Join Date: Oct 2013
There is an app for that deep sleep syndrome, it's on playstore its calles brick check or something like that, if you cant find just google it.
And I dont think that could be software problem, BUT depends on what apps you used, flashes you made.
Hope it hepls
 
monstersghost
Old
#5  
monstersghost's Avatar
Junior Member
Thanks Meter 12
Posts: 22
Join Date: Apr 2014
Location: Kuwait city
Well, i don't think its deith break, but i had the same essue with unofficial 4.3 and then at official 4.3 it worked well,
it may be a break in the motherboard or something.. as u tried every rome avilable it couldn't be softwear thing..
 
ra3or
Old
(Last edited by ra3or; 7th May 2014 at 12:48 PM.)
#6  
Member
Thanks Meter 9
Posts: 42
Join Date: Mar 2012
Location: Buzau

 
DONATE TO ME
the app for emmc firmware is called 'eMMC check', you can find it on playstore

edit: does your phone heat up? or battery? did your display ever turned blue when waking up from sleep?
it could be also a short with your display/motherboard or other connectors or battery connector... and the protection kicks in
if you're good with tools and phone is not under warranty, you could disassemble it and reassemble/reseat the connectors

or, could be the power button shorting, if you decide to open it, examine the power button
Phones/hardware fixer/enthusiast

[New toys to play with]
-- S IV i9505

Phones I Own
S IV i9505 black mist, S III i9300 amber brown, Sony-Ericsson W700i, Sony-Ericsson T250i

Phones I Owned
Sagem RC-912, Motorola v2288, Siemens A50, Siemens C60, Siemens C65, Siemens C72, Siemens CF62, Siemens M55, Siemens ST55, Sony-Ericsson Xperia X8
The Following User Says Thank You to ra3or For This Useful Post: [ Click to Expand ]
 
dxppxd
Old
#7  
Senior Member
Thanks Meter 183
Posts: 544
Join Date: Feb 2012
@Eibram did you ever undervolt or overclock when using custom kernels or roms? Because it could be hardware damage.

Also, do as they tell you above, check if you have the insane f01 emmc chip. I know it's a common missconception going around that since 4.1.2 the SDS got fixed, but it didn't really get fixed since it's a firmware problem in the emmc patched through software which just makes it highly unlikely to happen (but not impossible).
The Following User Says Thank You to dxppxd For This Useful Post: [ Click to Expand ]
 
Eibram
Old
(Last edited by Eibram; 7th May 2014 at 03:26 PM.)
#8  
Eibram's Avatar
Member - OP
Thanks Meter 12
Posts: 33
Join Date: Feb 2011
Location: Batangas City
I did some minor undervolting way back before JB came out but not since over half a year ago. I did the eMMc check and yes, I do have the inane chip.

Just an update, I re-flashed a PIT file and a rescue firmware and it seems to have helped a bit. It was running fine for over 12 hours aside from a random reboot just now.

I'm observing the phone right now to see wether the reboot was just coincidental. I really wish this is just a software thing.
Phone History
Nokia 3210, Nokia 3310, Motorola V100, Nokia 3530, Nokia 6600, Motorola E1070, Sony Ericsson W710i, Sony Ericsson K800i, Sony Ericsson P1i, Samsung Galaxy 5 GT-I5500, Samsung Galaxy SII GT-I9100, Samsung Galaxy SIII GT-I9300
 
Eibram
Old
#9  
Eibram's Avatar
Member - OP
Thanks Meter 12
Posts: 33
Join Date: Feb 2011
Location: Batangas City
Okay one more update, 2 days in and I've only experienced the one random reboot. It's still sometimes slow when waking up, but something around 2-5 secs sore not 5-15 seconds slow. I'm thinking that must be due to touchwiz bloat.
Phone History
Nokia 3210, Nokia 3310, Motorola V100, Nokia 3530, Nokia 6600, Motorola E1070, Sony Ericsson W710i, Sony Ericsson K800i, Sony Ericsson P1i, Samsung Galaxy 5 GT-I5500, Samsung Galaxy SII GT-I9100, Samsung Galaxy SIII GT-I9300

Tags
brickbug, freeze on sleep, sleep of death
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes