Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Flashing Stock Rom with Heimdall 1.3.2 on a Macbook 10.6.8

OP bobbybamboo

25th October 2012, 11:08 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Oct 2012
I'm trying to change the stock firmware on my unlocked unrooted international S3: I9300 to an official Samsung ROM downloaded from sammobile. The file I downloaded is called I9300XXDLJ4_I9300OXADLJ4_BTU. It's the UK unbranded firmware. The current firmware is on the phone is:

AP: I9300XXBLH3
CP: I9300XXLH1
CSC: I9300OPSBLH3

I have unzipped the file downloaded from Sammobile, which then gave me a tar.md5 file. So I change the file to just .tar, then unzipped that file. Inside that file I have:
boot.img
cache.img
hidden.img
modem.img
recovery.img
system.img

I then tried to use this tutorial on youtube called: How to Use Heimdall on Mac OSX to Install Kernels and ROMs!

When I open Heimdall on my MacBook, I plug my phone in (in download mode) and go to utilities, detect device, which it does. Then I save the PIT file on my desktop. I then go to the flash tab and browse for the PIT file, load that. Then when I go to add the files I don't have any files listed above called zimage or factoryfs etc, but also the Heimdell options doesn't have anything called kernal or the other ones anyway. My options in the partition name drop down box are:
Bootloader
Userdata
OTA
Hidden
System
Cache
Radio
Recovery
Boot
Param
EFS
BOTA1
BOTA0
MD5HDR
TZSW

The video says to match the files, but mine seems to have different names for things.

I have searched and read many forum posts on here and other sites. Can anyone tell me what I am doing wrong with either the unzipping or with Heimdall?

Thanks
25th October 2012, 01:12 PM   |  #2  
speedyjay's Avatar
Senior Member
Flag Guildford
Thanks Meter: 353
 
1,864 posts
Join Date:Joined: Oct 2011
More
Samsung hate apple....thats probably your problem

Sent from my GT-I9300 using xda premium
26th October 2012, 01:00 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Oct 2012
Thanks, but I only have access to a Mac. I did try my work computer, but it won't let me install any programs like Odin and drivers without Admin privileges.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes