Google Play Store Payments Available in China

Google has taken a big step to make its services accessible globally. Since the introduction of … more

How to Set a Video as Your Boot Animation

If you wish to make your phone truly unique, you may want to consider adding a nice boot animation. … more

TWRP for Nexus 6 and 9 Available, Unofficial CM12 Alpha for HTC Explorer! – XDA TV

Team Win Recovery Project for the Nexus 6 and Nexus … more

Jolla Tablet Announced: The Second Sailfish OS Device

A little over a year ago, Jolla released its first smartphone with the brand new Jolla … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Galaxy S III i9305 Wifi Problem

OP riunoob1

18th August 2014, 05:20 AM   |  #1  
OP Junior Member
Thanks Meter: 1
 
8 posts
Join Date:Joined: Nov 2012
Good day,

I have a samsung galaxy s3 i9305 LTE and I have been using this device without problems for around 2 years now. It runs on Jellybean 4.3 baseband version i9305zhucnb1. It has been running on this firmware for a couple months now ever since it has been rolled out. The problem is, the WIFI suddenly stopped working. Never had this problem before and I actually never had any problems with this device ever. Whenever I turn on WIFI, it detects my home networks and other networks wherever I go but whenever I try to connect, it just shows saved secured, and sometimes authentication error after a couple of attempts. I have other WIFI devices at home and all are working perfectly. I tried forgetting the networks and I am positive that the WIFI password is correct. I tried to restore the device to facroty settings hoping that it would work. I tried accessing my router and I'm sure my device isn;t blocked. I even configured my routers to only accept the mac address of my device and block all others but still wouldn't connect. I tried rooting my device via odin but my device blocks root access and shows the error message "an application attempted to access system on your device without authorization. this attempt has been blocked.". I tried rooting it to try flashing custom roms. I also tried dialling *#0011# to configure my wifi but it still does not work. I don't think that the problem is my firmware because I had it for months and it didn't update before the issue occured. I was also about to try downgrading it to an ICS stock rom since I can't root it to try custom ROMs. I've been trying to fix this for days now. Can you guys give me a step by step instruction on how to fix this if it is at all possible? And maybe give me a link where I can download ICS or lower stock ROM's for this device. I think I have to use a TGY firmware, though I don't have an idea what it means. Thanks!
18th August 2014, 11:53 AM   |  #2  
Justas A.'s Avatar
Junior Member
Thanks Meter: 2
 
16 posts
Join Date:Joined: Aug 2014
More
Wifi module
Maybe you've dropped your phone and the WIFI module loosened, and it can't work correctl?

Quote:
Originally Posted by riunoob1

Good day,

I have a samsung galaxy s3 i9305 LTE and I have been using this device without problems for around 2 years now. It runs on Jellybean 4.3 baseband version i9305zhucnb1. It has been running on this firmware for a couple months now ever since it has been rolled out. The problem is, the WIFI suddenly stopped working. Never had this problem before and I actually never had any problems with this device ever. Whenever I turn on WIFI, it detects my home networks and other networks wherever I go but whenever I try to connect, it just shows saved secured, and sometimes authentication error after a couple of attempts. I have other WIFI devices at home and all are working perfectly. I tried forgetting the networks and I am positive that the WIFI password is correct. I tried to restore the device to facroty settings hoping that it would work. I tried accessing my router and I'm sure my device isn;t blocked. I even configured my routers to only accept the mac address of my device and block all others but still wouldn't connect. I tried rooting my device via odin but my device blocks root access and shows the error message "an application attempted to access system on your device without authorization. this attempt has been blocked.". I tried rooting it to try flashing custom roms. I also tried dialling *#0011# to configure my wifi but it still does not work. I don't think that the problem is my firmware because I had it for months and it didn't update before the issue occured. I was also about to try downgrading it to an ICS stock rom since I can't root it to try custom ROMs. I've been trying to fix this for days now. Can you guys give me a step by step instruction on how to fix this if it is at all possible? And maybe give me a link where I can download ICS or lower stock ROM's for this device. I think I have to use a TGY firmware, though I don't have an idea what it means. Thanks!

19th August 2014, 10:35 AM   |  #3  
OP Junior Member
Thanks Meter: 1
 
8 posts
Join Date:Joined: Nov 2012
nope
I just charged it overnight and when i woke up, it just stopped working. where is the wifi module? the wifi does turn on and it detects wifi. it just doesnt connect. whenever i try to connect to a network, it shows saved, secured and sometimes authentication error.
19th August 2014, 10:46 AM   |  #4  
Account currently disabled
Flag Novi Sad
Thanks Meter: 161
 
311 posts
Join Date:Joined: Jul 2014
More
Quote:
Originally Posted by riunoob1

I just charged it overnight and when i woke up, it just stopped working. where is the wifi module? the wifi does turn on and it detects wifi. it just doesnt connect. whenever i try to connect to a network, it shows saved, secured and sometimes authentication error.

Maybe it's time for factory reset? I know that's the easy solution and most complicated but you should do it from time to time.

Sent from my GT-I9300 using XDA Free mobile app
19th August 2014, 11:29 AM   |  #5  
Member
Flag NewYork
Thanks Meter: 6
 
71 posts
Join Date:Joined: Jan 2014
Perform a complete factory reset
Quote:
Originally Posted by andjeomilosrdja

Maybe it's time for factory reset? I know that's the easy solution and most complicated but you should do it from time to time.

Sent from my GT-I9300 using XDA Free mobile app

Well, i think this may be the time to perform a complete factory reset ! try backing up your data and perform a complete factory reset.
19th August 2014, 02:16 PM   |  #6  
OP Junior Member
Thanks Meter: 1
 
8 posts
Join Date:Joined: Nov 2012
nope
already tried factory reset, already flashed stock rom. already reset wireless router and the router is a non-issue because i tried on several networks.
19th August 2014, 02:33 PM   |  #7  
Account currently disabled
Flag Novi Sad
Thanks Meter: 161
 
311 posts
Join Date:Joined: Jul 2014
More
Quote:
Originally Posted by riunoob1

already tried factory reset, already flashed stock rom. already reset wireless router and the router is a non-issue because i tried on several networks.

Then it's a hardware problem.

Sent from my GT-I9300 using XDA Free mobile app
23rd August 2014, 06:28 PM   |  #8  
OP Junior Member
Thanks Meter: 1
 
8 posts
Join Date:Joined: Nov 2012
help
i decided to have it checked by a local technician and according to them, this was still a software issue. i dont know what to do anymore. they insisted that i should just keep flashing stock roms to fix these. already tried flashing the 4.3 tgy jellybean stock rom so i was thinking of flashing other version stocks. can anyone give e a good link where i can download tgy stock roms 4.1.2 or even ICS stock roms. I also am having problems with rooting the device. it gives me error message "an application attempted to access system on your device without authorization. this attempt has been blocked." after flashing autoroot in odin. my knox is not installed. thanks.
23rd August 2014, 10:28 PM   |  #9  
Account currently disabled
Flag Novi Sad
Thanks Meter: 161
 
311 posts
Join Date:Joined: Jul 2014
More
Quote:
Originally Posted by riunoob1

i decided to have it checked by a local technician and according to them, this was still a software issue. i dont know what to do anymore. they insisted that i should just keep flashing stock roms to fix these. already tried flashing the 4.3 tgy jellybean stock rom so i was thinking of flashing other version stocks. can anyone give e a good link where i can download tgy stock roms 4.1.2 or even ICS stock roms. I also am having problems with rooting the device. it gives me error message "an application attempted to access system on your device without authorization. this attempt has been blocked." after flashing autoroot in odin. my knox is not installed. thanks.

If they think it's a software problem,why didn't they fix it?

Sent from my GT-I9300 using XDA Free mobile app
24th August 2014, 03:12 AM   |  #10  
OP Junior Member
Thanks Meter: 1
 
8 posts
Join Date:Joined: Nov 2012
dont know
the first time i brought this to them is when i attempted to flash an incompatible firmware. they also did not fix it. they said they dont have any available stock rom for i9305 and told me to download and flash one. mayba im just gonna have to look for a different technician when i have free time. so for the mean time, im trying to look for other fixes. btw, i tried downloading a tgy 4.1.2 stock rom and it does not flash successfully. for now i'm thinking of rooting and flashing custom roms. but whenever i flash auto root. it gives me the error message "an application attempted to access system on your device without authorization. this attempt has been blocked.". i tried updating supersu still the same thing. i manually installed root checker and says it does not have root access and it shows the said error message again. what should i do with that? Thanks

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes