FORUMS

Analysis & Opinion

Galaxy S3 accelerometer and magnetic sensor not working

34 posts
Thanks Meter: 3
 
By stavrov, Member on 8th January 2014, 10:29 AM
Post Reply Subscribe to Thread Email Thread
Hi, this two sensors just stopped working after update to 4.3. I've tried installing custom rom but still nothing. All my other sensors are working fine but theese two aren't giving me any data. Any help?
 
 
8th January 2014, 10:51 AM |#2  
boomboomer's Avatar
Senior Member
Thanks Meter: 822
 
More
Factory reset and flash full stock rom with odin. If still the same then you have a hardware fault.

Sent from my GT-I9300 using Tapatalk
8th January 2014, 11:01 AM |#3  
stavrov's Avatar
OP Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by boomboomer

Factory reset and flash full stock rom with odin. If still the same then you have a hardware fault.

Sent from my GT-I9300 using Tapatalk

I've tried that but still not working. Do I need to downgrade to 4.1.2?
8th January 2014, 12:39 PM |#4  
boomboomer's Avatar
Senior Member
Thanks Meter: 822
 
More
I don't think it will make any difference, but won't harm to check. Make sure you use an efs v2 4.1 firmware.

Sent from my GT-I9300 using Tapatalk
8th January 2014, 12:57 PM |#5  
stavrov's Avatar
OP Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by boomboomer

I don't think it will make any difference, but won't harm to check. Make sure you use an efs v2 4.1 firmware.

Sent from my GT-I9300 using Tapatalk

Now you lost me. What is efs v2 4.1 firmware?
8th January 2014, 01:29 PM |#6  
boomboomer's Avatar
Senior Member
Thanks Meter: 822
 
More
Firmware EMG4 and later all require efs v2 format for the IMEI number to be read, by updating to 4.3 you now have v2 and cannot use a firmware earlier than EMG4, otherwise your efs (and IMEI) will be corrupted.

Sent from my GT-I9300 using Tapatalk
8th January 2014, 01:39 PM |#7  
stavrov's Avatar
OP Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by boomboomer

Firmware EMG4 and later all require efs v2 format for the IMEI number to be read, by updating to 4.3 you now have v2 and cannot use a firmware earlier than EMG4, otherwise your efs (and IMEI) will be corrupted.

Sent from my GT-I9300 using Tapatalk

Is I9300XXEMG4_I9300OXFEMG2 good?
8th January 2014, 02:49 PM |#8  
Junior Member
Thanks Meter: 0
 
More
I'd be interested to know if this worked, I'm having similar problems.
28th July 2014, 11:33 PM |#9  
GT-I9000's Avatar
Member
Flag London, United Kingdom
Thanks Meter: 21
 
More
Having the same problem also.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes