FORUMS

OnePlus Addresses Reservation List Cheating

Jake Cooper figured out how to bump his place up on OnePlus’ reservation list and … more

OnePlus 2 Benchmark Scores Show Its Muscle

This video by FoneArena contains all the popular benchmarks being tested on the OnePlus 2, … more

Sony’s Emergence in The Middle: Is The Price Right?

Sony’s Electronics Division is not in its best days, and its smartphone … more

HTC Delivering Ads Straight to Sense Home

HTC’s 2015 has been a year marked by a desperate search for revenue.The HTC One M9 … more

My Galaxy s3 won't connect to wifi!!!

210 posts
Thanks Meter: 15
 
By valerio.tosti, Senior Member on 17th July 2012, 11:19 PM
Post Reply Subscribe to Thread Email Thread
Hello to all!!!! i have a strange problem, since i flashed omega 9 i have a big problem to connect to an wifi network! It regognizes the wifi but if i want connect to it he says authentification error!!!! i've tried everything!! i have tried to flash an other rom with factory reset but nothing he recognize my wifi but won't connect to it! i have tried different kernels too!
I have tried several wifi networks!!! it connects only if i am near the router(+-5meters)

please help me!!!
 
 
17th July 2012, 11:37 PM |#2  
mwatson's Avatar
Senior Member
Flag Basingstoke
Thanks Meter: 130
 
More
More info required..Is it a bt homehub?
17th July 2012, 11:42 PM |#3  
valerio.tosti's Avatar
OP Senior Member
Flag Bissen
Thanks Meter: 15
 
More
Quote:
Originally Posted by mwatson

More info required..Is it a bt homehub?

i live in luxembourg and my router is a fritzbox!!!!! but it happens not only on my wifi network!!! by other wifi access points too!!!
18th July 2012, 10:16 AM |#4  
Junior Member
Thanks Meter: 1
 
More
call this number to get into service mode

*#0011#

Press your menu button and select wifi at the bottom

turn off wifi powersaving mode

should fix it
18th July 2012, 12:19 PM |#5  
valerio.tosti's Avatar
OP Senior Member
Flag Bissen
Thanks Meter: 15
 
More
Quote:
Originally Posted by XBoUnCiNX

call this number to get into service mode

*#0011#

Press your menu button and select wifi at the bottom

turn off wifi powersaving mode

should fix it

nope it doesn't fix it
18th July 2012, 12:56 PM |#6  
Senior Member
Thanks Meter: 438
 
More
<delete>
Last edited by d4fseeker; 18th July 2012 at 12:59 PM.
18th July 2012, 01:01 PM |#7  
Senior Member
Flag Melbourne
Thanks Meter: 451
 
More
I had the same problem when I switched from a 16gb to a 32gb version.

I restored a backup but couldn't connect to wifi. A factory reset solved the problem for me but I see you've already tried that.

Sent from my GT-I9300 using xda premium
18th July 2012, 01:01 PM |#8  
Junior Member
Thanks Meter: 1
 
More
The password you entered is correct and the Fritzbox isn't using any MAC filter i assume?
18th July 2012, 01:12 PM |#9  
Senior Member
Thanks Meter: 438
 
More
Connect your phone to the computer and open adb shell
Kill any process named wpa_supplicant and type:

Code:
wpa_supplicant -dd -i wlan0 -f /sdcard/wifi.log -c /etc/wifi/wpa_supplicant.conf
Then attach the generated logfile after having tried connecting to a wifi network.

Alternatively you can run "wpa_cli" and show it's output.

Sent from my GT-I9300 using xda premium
18th July 2012, 04:57 PM |#10  
valerio.tosti's Avatar
OP Senior Member
Flag Bissen
Thanks Meter: 15
 
More
No i tried everything now but still not working! So i explain my router is down stairs, i am on the second floor! He sees my network but can't connect saying authentication error! When i go near the router about 3-4meters it connects to my network and i can access the net without problems! Now i am at my friends home and my galaxy s3 connects near the router but when i go in an other room it remains connected to the wifi but no internet connection an after a while he disconnects automatically!

I suppose if it where an hardware problem it wouldn't find the network at all or am i wrong with that?

Sent from my GT-I9300 using xda app-developers app
18th July 2012, 06:02 PM |#11  
Senior Member
Thanks Meter: 438
 
More
Well it sounds like Wifi power management fails.
But please, respond to my last post by executing:
su
wpa_cli

And then connect to the wifi network.
(Wifi must aleady be enabeld but not connected for it to work)

Then post the output

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes