FORUMS

[Q] GPS performance after 4.3 upgrade

36 posts
Thanks Meter: 3
 
By rschalie, Member on 17th February 2014, 09:39 AM
Post Reply Subscribe to Thread Email Thread
The GPS performance of my S3 has markedly deteriorated after the 4.3 upgrade. When driving, my route planners frequently report loss of GPS signal, or inaccurate positions. Interestingly though, not alle route planners are equally affected. Before the upgrade, when on 4.1.2 this issue didn't exist.
Does anyone have similar experiences (and better yet, a solution)?

T.i.a.
 
 
17th February 2014, 12:11 PM |#2  
Senior Member
Thanks Meter: 4,492
 
More
Backup data factory reset .
Use one of the AGPS fixes .
18th February 2014, 08:05 AM |#3  
OP Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by JJEgan

Backup data factory reset .
Use one of the AGPS fixes .

Thanx.
Not happy with the "factory reset" bit . Will try to find an appropiate AGPS fix (unless anyone can point me to one )
18th February 2014, 12:02 PM |#4  
boomboomer's Avatar
Senior Member
Thanks Meter: 822
 
More
GPS working perfectly on 4.3, fixes in less than 10 second and doesn't drop. Sounds like your rom or data is corrupt, factory reset and reflash a fresh stock 4.3.

I've never needed an AGPS fix for this phone, but search in general or development forums -I did see one a while ago.

Sent from my GT-I9300 using Tapatalk
Post Reply Subscribe to Thread

Tags
gps 4.3
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes