5,594,748 Members 36,105 Now Online
XDA Developers Android and Mobile Development Forum

[Q] [Help Needed] Galaxy S3 GT-I9300 Massive problem

Tip us?
 
Evanidus
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jul 2011
Exclamation [Q] [Help Needed] Galaxy S3 GT-I9300 Massive problem

I would need some help with my Galaxy S3 GT-I9300

From the top, i had it rooted a few days ago with the HD Revolution 21.0 installed, i upgraded to the 40.0 version (which was JB 4.3) and then everything went to ****.
My battery was draining, my cell was crashing from time to time and in short i tried to fix it.

First i tried to downgrade to the HD Revolution 32.0 which has the JB 4.1.2 (if i remember correctly)
When i did that, my IMEI went to 0049*** and was unable to go onto the internet nor call anyone.
this made me panic, because (yes you can call me an idiot) i didnt do a backup of my IMEI or stock EFS.

I tried to do a restore of my EFS but it didnt work for some reason (i had a backup through Aroma that came with HD Revolution and i had no way for it to be read again and restored)
I still have all my EFS Backups, but dont know how to get the phone to read em (they are .tar.gz)

This brought me to the "solution" of going back to Stock ROM and factory reset/wipe it.

So i flashed a swedish version (seeing as i am from sweden) and currently im on STOCK ROM JB 4.1.2, my IMEI is still 0049***, i cant connect to the internet nor make calls.
I cant go into Recovery because when i do, the "SAMSUNG GALAXY SIII" screen shows with a tiny red "!" shows up in the corner.

Im able to go into Download mode.

Ive tried to re-root it by following this guide: http://forum.xda-developers.com/show....php?t=2046439
But when i try to follow "Step 2 - Flashing VRALEC Bootchain to allow Custom Recovery" Odin 3.07 gets stuck at "Starting NAND Write!!" and will not continue.

As the idiot i am i tried to flash CWM directly instead, with no success.

My question now is, What do i do?!

Ive tried anything i can think of, is there anything else i can do?
 
Ayleo
Old
#2  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Feb 2013
Well, the thing is that the newer ROMs and basebands (from July 2013 (XXEMG4) onwards) changed the EFS format from v1 to v2, so when you flashed Android 4.3, you kinda "updated" the EFS format to v2.

But when you rolled back to 4.1.2, you flashed a ROM which is working only with the old EFS format (v1), so your system complains because it can't read your EFS partition anymore (thus your IMEI which is stored there). That is why your IMEI changed to some random one (IMEI's starting with 0049** are the "default" ones, showing that your real one is corrupted or not readable).

That's why flashing to stock ROM 4.1.2 didn't change a thing, because it's still working on the v1 format.

So my advice would be to flash a stock ROM from Android 4.3 (or with a baseband that was released after July 2013) and see if it works, or directly flash a custom ROM (still 4.3, or at least one released after July 2013).
That would be the easiest way to check if your EFS isn't corrupted. But if you really want to roll back to an older version of Android, then you have to restore your EFS backup (which is still the old format hopefully).

I got this information from there : http://forum.xda-developers.com/show....php?t=2393289

Happy flashing !
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes