Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] [[help]] phone wont charge after using fastcharge

OP lazyfool

4th May 2014, 04:16 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: May 2014
I had finally installed a custom kernel for my us cellular galaxy s3 (sch-r530u)
ran fast charge on it...
it charged fine but later when it had died now it wont charge at all
I have tried several AC adaptors, car charger, and my computer
all that happens is the phone tries to turn on and then dies before the OS can start
if I plug it in I do not see the charge light turn on
I do not have a warranty as I bought this phone used from a friend that upgraded to the s5.
I am assuming this could just be the battery (maybe somehow fast charge messed up my battery?)
I just wanted to check here before I went and bought anything.

Thanks for any advice.
Last edited by lazyfool; 4th May 2014 at 04:24 AM.
4th May 2014, 07:36 AM   |  #2  
AssassinGEO's Avatar
Senior Member
Flag Tbilisi
Thanks Meter: 250
 
1,004 posts
Join Date:Joined: Sep 2013
More
Quote:
Originally Posted by lazyfool

I had finally installed a custom kernel for my us cellular galaxy s3 (sch-r530u)
ran fast charge on it...
it charged fine but later when it had died now it wont charge at all
I have tried several AC adaptors, car charger, and my computer
all that happens is the phone tries to turn on and then dies before the OS can start
if I plug it in I do not see the charge light turn on
I do not have a warranty as I bought this phone used from a friend that upgraded to the s5.
I am assuming this could just be the battery (maybe somehow fast charge messed up my battery?)
I just wanted to check here before I went and bought anything.

Thanks for any advice.

Seems like USB cable was not capable of that bigger numbers or you just used too big amount for fast charge overall,and that was bad for the battery.

Replacing battery will do the job.
The Following User Says Thank You to AssassinGEO For This Useful Post: [ View ]
4th May 2014, 06:23 PM   |  #3  
boomboomer's Avatar
Senior Member
Thanks Meter: 752
 
3,415 posts
Join Date:Joined: Jun 2010
You may also have blown the charging circuit inside the phone, but try changing the battery first.

You have posted in the wrong forum and wrong section, this is for i9300 only.

Sent from my GT-I9300 using Tapatalk
The Following User Says Thank You to boomboomer For This Useful Post: [ View ]
5th May 2014, 12:33 AM   |  #4  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: May 2014
Thanks, I will try to change the battery. I hope it works
also i couldn't find a sch-r530u forum.
5th May 2014, 01:08 PM   |  #5  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Jun 2013
happend to my freind to.
he changes the battary
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes