FORUMS

What Do You Think About Fingerprint Scanners?

More and more phones are featuring fingerprint scanners, and with many promising … more

What’s Next for Samsung and Its Flagships?

If we were to say that the Galaxy S6 was a leap of faith made by Samsung, we … more

The Ultimate Showcase of dBrand Skins

In the search for ways to protect, accessorize, and personalize; a user has many options. One … more

Huawei’s Rapid Rise to Third Place in the Smartphone Race

Huawei has quickly grown to become one of the world’s biggest … more

I9300 ON 4.3 Official - Slow, Laggy and Screen Flicker when swiping

33 posts
Thanks Meter: 2
 
By adam7862, Member on 17th March 2014, 08:12 PM
Post Reply Subscribe to Thread Email Thread
Hi guys ive got a Samsung s3 which is on 4.3 official stock rom, however im having some problems. Firstly is the problem of lagging, for example i could be using the browser and when i go back to the home screen there is nothing there and it takes a few seconds for all the icons to load back.

Second problem which is intermittent and usually goes away when i reboot the phone is when swiping through the homescreen i get these weird screen flickers (Not sure if screen flicker is the right word) but basically i can see my other app icons in the background which become enlarged. I have included some picures to better explain. Do you think this is a hardware or software fault and what should i do?

Any helps appreciated, Thanks.
Attached Thumbnails
Click image for larger version

Name:	2014-03-17 15.41.26.jpg
Views:	254
Size:	94.0 KB
ID:	2635773   Click image for larger version

Name:	2014-03-17 15.58.20.jpg
Views:	292
Size:	106.5 KB
ID:	2635774  
 
 
17th March 2014, 08:31 PM |#2  
tallman43's Avatar
Senior Member
Flag The Land of Android
Thanks Meter: 433
 
More
Quote:
Originally Posted by adam7862

Hi guys ive got a Samsung s3 which is on 4.3 official stock rom, however im having some problems. Firstly is the problem of lagging, for example i could be using the browser and when i go back to the home screen there is nothing there and it takes a few seconds for all the icons to load back.

Second problem which is intermittent and usually goes away when i reboot the phone is when swiping through the homescreen i get these weird screen flickers (Not sure if screen flicker is the right word) but basically i can see my other app icons in the background which become enlarged. I have included some picures to better explain. Do you think this is a hardware or software fault and what should i do?

Any helps appreciated, Thanks.

(1) Backup any files photos then factory reset

If problem still there

(2) Flash another stock rom with Odin

If problem still there probably hardware related
The Following User Says Thank You to tallman43 For This Useful Post: [ View ]
18th March 2014, 10:56 PM |#3  
Junior Member
Thanks Meter: 0
 
More
I have the same problem. The flicker of the screen I think is touchwizz because when I use another launcher dissappears.
Normally with a reboot I fix it, but it happens again from time to time.

Sent from my GT-I9300 using xda app-developers app
24th March 2014, 02:18 AM |#4  
Member
Thanks Meter: 0
 
More
this happens on my s3 after update to 4.3 how to fix this
25th March 2014, 05:49 AM |#5  
Member
Thanks Meter: 0
 
More
Up for this thread.
25th March 2014, 10:42 AM |#6  
Andr3y29's Avatar
Senior Member
Flag Buzau
Thanks Meter: 156
 
More
I also got that flickering on TW launchers (even on an S5 themed one). And actually, it's not a flickering, it is a stretched app icon (in the screenshot you atached it is Camera). I observed (at least in my case) that this happens when the RAM usage is above 700-750MB. try a custom ROM (after backing up, recommended) like SmartDroid Simple v7, NxTGen 13.1, ehich both have really good RAM usage (on Smartdroid v7 I got as low as 280, if i remember well. I posted the screenshot in that thread.
The Following User Says Thank You to Andr3y29 For This Useful Post: [ View ]
25th March 2014, 02:57 PM |#7  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Andr3y29

I also got that flickering on TW launchers (even on an S5 themed one). And actually, it's not a flickering, it is a stretched app icon (in the screenshot you atached it is Camera). I observed (at least in my case) that this happens when the RAM usage is above 700-750MB. try a custom ROM (after backing up, recommended) like SmartDroid Simple v7, NxTGen 13.1, ehich both have really good RAM usage (on Smartdroid v7 I got as low as 280, if i remember well. I posted the screenshot in that thread.

what did you do yo remove this weird issue?
25th March 2014, 06:12 PM |#8  
Member
Flag Hailsham
Thanks Meter: 38
 
More
I had similar problems after updating from official 4.1.2 to official 4.3 (MJ9 ROM, November 2013). Problems were extremely widespread. I got sick of waiting for Samsung to even acknowledge the problem and eventually moved to NeatROM, and I'm happy to say I haven't looked back. I will probably never return to stock now.
25th March 2014, 07:47 PM |#9  
Andr3y29's Avatar
Senior Member
Flag Buzau
Thanks Meter: 156
 
More
Quote:
Originally Posted by hitback

what did you do yo remove this weird issue?

Usually clearing the RAM solved the problem for me.
The Following User Says Thank You to Andr3y29 For This Useful Post: [ View ]
25th March 2014, 10:17 PM |#10  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Andr3y29

Usually clearing the RAM solved the problem for me.

How to clear ram? Thanks.
26th March 2014, 11:51 AM |#11  
Member
Thanks Meter: 0
 
More
update for this thread

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes