Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,073 Members 40,698 Now Online
XDA Developers Android and Mobile Development Forum

[i9305] Every rom below 4.4= Camera fails (speaker noise)

Tip us?
 
ycon
Old
#1  
Senior Member - OP
Thanks Meter 6
Posts: 195
Join Date: Apr 2013
Default [i9305] Every rom below 4.4= Camera fails (speaker noise)

Hi,

Aside from the stock Samsung rom- every other rom built on 4.3 results in a broken camera.

I've tried several (rXtreme, Aroma etc) and in every one, the same thing happens. When I open up the camera, I can hear a faint sound/clicking from the camera area/speaker. Then it says "Camera Failed"

Dumb thing to say, but it's like the rom makes it think the speaker is the camera, and is sending power to it to launch the camera.

On stock Samsung roms (ie 4.3), and any roms on 4.4+, the camera DOES work. However, I need HDMI support so I cannot use 4.4.

I've tried all the solutions suggested eg SlimISP's files, different mods/roms/fixes etc. It's been happening for 6 months- so I had to switch back to Apple

Please give me any ideas here- I really want to get back on Android
Samsung Galaxy SIII 4G (i9305) international (EU) Resurrection Remix® 4.4.2 KitKat v5.0.9
 
boomboomer
Old
#2  
boomboomer's Avatar
Senior Member
Thanks Meter 672
Posts: 2,995
Join Date: Jun 2010
Probably some files left over from previous firmware, do a full wipe before flashing.
Note: This quote doesn't automatically apply to everyone, decide for yourself if it might apply to you.

Quote:
Originally Posted by justruss View Post

What has this place become?

It's essentially a few people graciously answering the same repeating of immature, lazy, demanding questions from the masses.

Nobody searches. Nobody reads the first posts or titles of threads. Nobody even looks at posts a couple above their own.

 
daedric
Old
(Last edited by daedric; 5th July 2014 at 05:13 PM.) Reason: Choices
#3  
daedric's Avatar
Senior Member
Thanks Meter 337
Posts: 1,674
Join Date: Dec 2006
Location: Porto
Do this:

1. Flash stock, open camera, test that it works.
2. Use your favorite file browser with root access (Samsung MyFiles or whatitsname doesn't work) and go to to /data/cfw
3. Find .bin file there, that's your Camera FirmWare, copy it to a safe location.
4. Flash favorite 4.3 mod with favorite 4.3 custom kernel with SE permessive. (Agni or Boeffla, or use stock, but be aware that certain themes make WiFi not work)
5. Open camera, confirm it doesn't work.
6. Copy .bin file into /data/cfw, re-open camera.

I know you tested SlimISP files, but this method works ALWAYS for me, at least on AMCHA 5.x and TGP

Also, the alternative is to flash custom rom with stock kernel. Open camera to generate SlimISP bin. Flash custom kernel

HTC Kaiser . CM6 ......... OC@530mHz - Kitchen Watch with NTP .
HTC Leo .... CMX OC@1.19gHz, Jellybean
HTC Ace .... CMX OC@1.5gHz, ICS + Sense 4.0
 
ycon
Old
#4  
Senior Member - OP
Thanks Meter 6
Posts: 195
Join Date: Apr 2013
Quote:
Originally Posted by daedric View Post
Do this:
2. Use your favorite file browser with root access (Samsung MyFiles or whatitsname doesn't work) and go to to /data/cfw
Thanks so much for the reply.

So, I've written the stock rom onto my device (un-rooted). Problem is, because of Knox, I cannot root the stock software. I've tried removing Knox and a few methods, but I just can't root it. I'm using Odin 3.09. Am I missing something?
Samsung Galaxy SIII 4G (i9305) international (EU) Resurrection Remix® 4.4.2 KitKat v5.0.9
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes