TWRP 2.8.3.0 Available for Supported Devices

The TeamWin Recovery Project (or TWRP, for short) has quickly become one of the most popular … more

Easily Generate and Export Material Design Palletes

For many people, it can be pretty difficult to create a palette of complementary colors. … more

Android One Expanding to Bangladesh, Nepal, and Sri Lanka

At Google I/O 2013, Google proudly announced that the Android operating system was … more

Android 5.0.2 Fixes 2012 Nexus 7! Sony’s Making a Google Glass Competitor? – XDA TV

Android 5.0.2 Lollipop is available for the … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Llama Root Access

OP Warthog01

22nd April 2014, 09:03 PM   |  #11  
Junior Member
Thanks Meter: 3
 
27 posts
Join Date:Joined: Aug 2013
Was this issue ever resolved? I'm getting the same problem.
24th April 2014, 12:33 AM   |  #12  
OP Member
Flag Bristol
Thanks Meter: 1
 
40 posts
Join Date:Joined: Feb 2012
LLama Root access
No, never resolved and I'm still getting the message.
24th April 2014, 12:58 AM   |  #13  
Junior Member
Thanks Meter: 3
 
27 posts
Join Date:Joined: Aug 2013
Quote:
Originally Posted by Warthog01

No, never resolved and I'm still getting the message.

I ran Llama fine on 4.2.2 stock for a year or so. When I switched to 4.4.2 WanamLite (stock less Knox) I started getting the message. I got SuperSU pro to enable logging.

My morning action turns airplane mode off, turns sync on, turns wifi on, then runs a bunch of things like facebook, email, etc to sync. I get the exclamation mark and the message at the top of the thread when this runs, or when the similar evening action runs. I'm getting the following log entries when it goes out of airplane mode (in approx these colors). Nothing in supersu says anything about delays.

1.
settings put global airplane_mode_on 0
exit

Warning: App_process has text relocations. This is wasting memory and is a security risk. Please fix.

2.
am broadcast
a android.intent.action.AIRPLANE_MODE -e llama.sender llama -e state false
exit

Warning: App_process has text relocations. This is wasting memory and is a security risk. Please fix.
Boradcasting: Intent (etc).
Broadcast completed: result=0
Last edited by commandonz; 24th April 2014 at 01:06 AM.
25th April 2014, 10:35 PM   |  #14  
Junior Member
Thanks Meter: 3
 
27 posts
Join Date:Joined: Aug 2013
Ok, I have a solution or workaround, but not a full explanation.

It seems permissions and such have changed between 4.2.2 and 4.4.2 and Llama isn't compatible, or maybe it's just not possible. The trick is to use the secure settings app, and enable the System+ Module inside it. I think I also made Secure Settings a device admin, just in case, but unsure if that's required. Then go to the compatible apps tab and click llama help for instructions.

Basically, in Llama, instead of using the built in airplane mode commands you add an action "locale plugin", then choose "secure settings", "root actions", then "airplane mode". That lets you turn it on, off, or toggle.

If you purchase secure settings pro (about $1.50, in-app purchase via google play) you get access to a shutdown and reboot command. I can't find any other way to do this - even via a shell where you can usually do it the shutdown/reboot commands don't seem to be there.

Sorted!
The Following 2 Users Say Thank You to commandonz For This Useful Post: [ View ]
1st May 2014, 06:01 PM   |  #15  
Senior Member
Flag Denver
Thanks Meter: 27
 
237 posts
Join Date:Joined: Apr 2010
More
Same problem here with a Moto X with root and it shows up as having root access in SuperSu.
1st May 2014, 08:55 PM   |  #16  
Junior Member
Thanks Meter: 3
 
27 posts
Join Date:Joined: Aug 2013
Quote:
Originally Posted by atomb

Same problem here with a Moto X with root and it shows up as having root access in SuperSu.

Did you read the solution, one post up from yours on page 2?
13th May 2014, 04:02 PM   |  #17  
Senior Member
Belgique
Thanks Meter: 23
 
175 posts
Join Date:Joined: Nov 2005
Quote:
Originally Posted by commandonz

Ok, I have a solution or workaround, but not a full explanation.

It seems permissions and such have changed between 4.2.2 and 4.4.2 and Llama isn't compatible, or maybe it's just not possible. The trick is to use the secure settings app, and enable the System+ Module inside it. I think I also made Secure Settings a device admin, just in case, but unsure if that's required. Then go to the compatible apps tab and click llama help for instructions.

Basically, in Llama, instead of using the built in airplane mode commands you add an action "locale plugin", then choose "secure settings", "root actions", then "airplane mode". That lets you turn it on, off, or toggle.

If you purchase secure settings pro (about $1.50, in-app purchase via google play) you get access to a shutdown and reboot command. I can't find any other way to do this - even via a shell where you can usually do it the shutdown/reboot commands don't seem to be there.

Sorted!

Thanks for this solution. Works perfect !
$1.50 is really cheap for that nice app
Last edited by burnout; 13th May 2014 at 11:57 PM.
13th May 2014, 08:45 PM   |  #18  
Junior Member
Thanks Meter: 3
 
27 posts
Join Date:Joined: Aug 2013
Quote:
Originally Posted by burnout

Thanks for this solution. Works perfect !

Hit thanks if it helped

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes