Default No longer able to connect USB devices (such as a mouse or keyboard etc..) via OTG cab

For some reason I am no longer able to connect any USB devices to my Samsung Galaxy S3 via OTG cable. I get the notification at the top which says it recognises what I am plugging in so if I plug in a mouse it pops up with the "USB Inserted" notification and next to it it says "Mouse". The problem is though everything I try doesn't work anymore and it does nothing. I've seen on YouTube other people using Keyboards, Xbox360/Playstation 3 controllers and Mouse's all they do is plug in there device via OTG cable and away they go it instantly recognises whatever they plug in and works straight away without root or installing anything. The first time I tried connecting a mouse a few weeks ago it worked perfectly but I tried other devices that day and a mouse is all i could get to work, and now the mouse doesn't work along with everything else I've tried. Does anyone know any reason why I cant get anything to work?

Sent from my GT-I9300 using XDA Premium 4 mobile app