Post Reply

Can't mount any partitions at all! - PIT/Bricked/Re-partition/Rescue Galaxy S3 I9300

OP DRSDavidSoft

29th June 2014, 01:27 AM   |  #1  
DRSDavidSoft's Avatar
OP Junior Member
Flag United States, California, Los Angles
Thanks Meter: 0
 
3 posts
Join Date:Joined: Sep 2013
More
COMPLETE/ULTIMATE GUIDE TO FIX A BRICKED/DEAD GALAXY S III

Hi all.
If you are reading this, you probably have a bricked/dead Galaxy S 3 which you want to fix yourself.
Please note that a phone can be Soft-bricked and Hard-bricked. Google them up if you don't understand them.
Also, the brick could be software or hardware related.

Through this guide, I'll help you do anything software related to fix your S3 phone. I hope you succeed, otherwise you need to fix the hardware which you probably can't do by yourself at home.

CAUTION: If you don't know about flashing, Odin, ADB, or haven't installed USB Drivers, or if you are a noob, please read other topics first. I'm not responsible for any damage you might do to your phone.

If your phone is soft-bricked, you can flash it with a full firmware.
Please check out "What I had tried" if you are not interested in what ROM, Kernel and Recovery my phone was using.

Thanks for everyone's help.

My phone was:
I had a Galaxy S3 19300 International. I hadn't done any flashing/rooting/upgrading in a while.
And I was running a DeltaROM III with android 4.3 (and heavily modified by myself in many parts), Googy Max Kernel, plus PhilZ Touch Recovery, when the accident happened. A very nice pack of ROM, Kernel and Recovery indeed.
I really loved that phone, and have tested any ROMs (from latest Stock to CyanogenMod) and any recovery (CWM, TWRP, ...) on it.

What had happened:
One day my battery went down and my phone turned off.
When I turned it on, it stuck on the kernel boot-screen so I turned off my phone and went to the Android Recovery using Vol Up+Home+Power.

The Problem:
My phone couldn't mount any partitions at all.
boomboomer said that letting battery die has a high chance of destroying the emmc chip (which is an "insane" chip Samsung uses for internal memory).

This is the exact log that I was getting after flashing on TWRP (TeamWin Recovery):
Code:
E:Unable to find partition size for '/boot'
E:Unable to find partition size for '/recovery'
E:Primary block device '/dev/block/mmcblk0p12' for mount point '/data' is not present!
E:Unable to mount '/data'
E:Unable to recreate /data/media folder.
E:Unable to mount '/efs'
E:Unable to mount '/cache'
E:Unable to mount '/system'
E:Unable to mount '/data'
E:Unable to mount '/preload'
E:Unable to mount internal storage.
E:Unable to mount /data/media during GUI startup.
E:Unable to mount '/cache'
Full SELinux support is present.
E:Unable to mount /data/media/TWRP/.twrp when trying to read settings file.
Android Stock Recovery says:
(The following happens for /cache, /data, /system and all other partitions)
Code:
E:failed to mount /data (no such file or directory)
E:Can't mount /data
E:Can't open /data
As you can see, it seems that the internal structure has been corrupted.
Or maybe the mounting script has been corrupted I guess.

What worked:
  • Phone turns on.
  • Recovery mode.
  • Download Mode.
  • Flashing with Odin or other software.
  • Custom Recovery (via Odin)
  • ADB in Recovery
  • Installing ZIP files if I push it to /tmp/ directory via Odin and installing from TWRP.

What didn't work:
  • Mounting any partitions at all.
  • Mounting USB in the recovery mode.
  • Booting to Android.
(Which all makes sense according to this not mounting problem.)


What I had tried / You should try too:
I usually Google these problems, and try to fix them myself. This usually works if the internal memory is not damaged, otherwise I can't do anything.
- Flashing PDA with Odin 3.09.
- Re-partitioning my S3.
- I tried re-partitioning using a PIT file + an older version of android via Odin 3.07.
- I tried flashing TWRP. (to upload Aroma File Manager and see what can I do.)
And not slightest bit of luck. It seems nothing could mount any partitions at all.
I've sent my phone 2 times to the Warranty service and 3 times to a phone-repair shops, and they could fix my phone, but I don't want to pay them anymore (warranty was free) - and they also tend to delete my files every time (Not wiping, I know this because once I had set a PIN before my phone was damaged, and they couldn't delete my files! )

I wanted to try doing a JTag, but I couldn't do it at home.

UPDATE #1: I tried [RESCUE FIRMWARE SGSIII I9300], with GT-I9300XXUGMJ9_KOR_MULTI_FACTORY + a PIT file. It didn't helped me either, because as I said my problem was with my emmc chip - not software. (Please try it.)
My device couldn't mount or find any partitions at all.

UPDATE #2: I gave up fixing my phone myself and brought it to some phone-repair shops. They tried restoring the efs partition, flashing a bootloader, wiping partitions, and using something called a 'box'. These didn't work either - the emmc chip really needed to be changed.
They said they will try JTAGging my phone, see if it works. I am currently waiting to see if this works. If this work, they will charge me about $22. If JTAG doesn't work... This WAS a hardware issue and the emmc chip needed to be changed. It cost between $75 here.
(By the way, oddly they call the emmc chip a "hard" here, although it has nothing to do with a H.D.D.) :|
However, when they changed the emmc chip, my signal went off, and my phone showed "Not registered on network". Oddly though, My IMEI wasn't null and I had a baseband version.
I took my phone to another place, they used a 'box' - which turned out to be a z3x box - and it really worked, and restored my signal (they only used ADB to restore it in less than 5 mins or so.)
Many said that using this method, my signal would likely die again if I flash my phone again, but he guaranteed that it would not, using his own method.
So, I decided to flash a Googy Max Kernel (mostly for fading LED), and my signal died again. This time, my IMEI was showing null, and my baseband was unknown. WTF.

F**CKING Silly Samsung with their policy of not receiving signal if the efs partition is changed, haven't they thought that maybe a thief could simply format EFS partition and use the phone like an iPod?! I mean does iPods have simcard or ability to call / send text? Idiots!! >
And I really hate those bastards who want to charge me whenever a single small problem happens.
I'm going to buy a Galaxy S 5 and get rid of this phone for good. :| (or maybe keep it as a iPod/Game Device.)

Anyways, I'd really appreciate if you awesome guys can help me. It appears that it can not be fixed by software.
I want to boot my phone normally, and I my /data partition is important for me, I prefer to save it! (I'm not a back-up kind guy unfortunately.) :|

By the way, I can speak English very well and I can read any tutorials if you give me a link.
I am a programmer, so I'm not a noob (as you can see!)
I want to learn how to fix my phone - so I don't have to bother you guys or spend my money on those phone-repairing shops whenever something like this happens.


I haven't found any good articles about how to unbrick a Galaxy S3 when this problem happens, so other people can use this topic to fix their S3 phones if you help solving this problem. As I said, the hardware part needs to be fixed. That's why no articles are found.

Thank you all, and have a great day.
P.S: I will remove unnecessary details from this post once this problem is solved.
Last edited by DRSDavidSoft; 18th July 2014 at 09:00 AM. Reason: Update on what I've tried recently.
29th June 2014, 09:24 AM   |  #2  
boomboomer's Avatar
Senior Member
Thanks Meter: 710
 
3,218 posts
Join Date:Joined: Jun 2010
Your partition structure is reliant on the insane emmc chip Samsung fitted, letting the battery die is like playing Russian roulette with it. If just corrupt then try flashing the rescue firmware & pit from the general forum. If that fails then the chip is damaged and you'll need a new motherboard/phone.

There are hundreds of identical threads posted.
The Following User Says Thank You to boomboomer For This Useful Post: [ View ]
29th June 2014, 12:27 PM   |  #3  
DRSDavidSoft's Avatar
OP Junior Member
Flag United States, California, Los Angles
Thanks Meter: 0
 
3 posts
Join Date:Joined: Sep 2013
More
eMMC chip
Thanks. I've seen some messages mentioning this chip before too. I'll try the rescue firmware.

By the way, since I assume this is a common problem, I wonder if Samsung have fixed it or not. I want to sell my phone and buy a new one.
Does all Galaxy S3s suffer from this problem? Or can I find a S3 which wouldn't break if its battery dies? If I can, how can I tell the difference?
I may consider buying a Galaxy S4. Do S4s use similar eMMC chips or not? Can I let a S4 battery die and the partitions structure won't be corrupted?

In general, does Galaxy S4 have any disadvantages (other than not having radio) in comparison to S3?
(I'm not sure whether to post this on Galaxy S4 section or not.)
29th June 2014, 02:37 PM   |  #4  
boomboomer's Avatar
Senior Member
Thanks Meter: 710
 
3,218 posts
Join Date:Joined: Jun 2010
S4 main weakness is the screen, very easy to bend the phone and break the oled without breaking the glass.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes