Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,731,757 Members 48,440 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Moving Apps to External SD with Android 4.3

Tip us?
 
henninkn
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Jan 2013
Question [Q] Moving Apps to External SD with Android 4.3

Hey!

I'm having trouble using the Android OS to move apps to the external SD card.
I know this is a fairly common problem, and I've Googled it quite a bit, but haven't found a proper answer yet.

I am on a stock, unrooted Samsung Galaxy S3 running Android 4.3.
My phone recently updated from 4.1.2 to 4.3, and with it came the option to move apps to external SD.

I tried moving many apps, upon which my phone states they were transferred successfully, and it reflected the change in the individual app's storage overview.
Observing that my free memory had not increased for the phone's internal memory however, i used ES File Explorer to investigate.
I found that not a single byte had been written to the external SD (with one possible exception, see below), and all files remained on sdCard0, ie. the phone's internal memory.

I also noticed a new "partition" that I haven't seen before the last update, named "emulated", which contained two folders with identical content and size, one named "legacy" and one named "0". They, in turn, are both identical to the sdCard0 "partition", meaning that for some reason, "emulated" displays the exact content of the phone's internal memory in two different folders.

Finally, I noticed that my LOST.dir folder on the external SD card seemed unusually large (9.1 GB!).
I am not positive those files weren't there before the move, but I believe they weren't.
Seing as that folder is for corrupted data, I deleted its content.

Now when I try and launch any of the moved apps I get an error saying it has stopped working.
Allthewhile, the amount stored on the internal and external cards (except for LOST) haven't changed, respectively.

I read this is because the phone mistakes the internal, emulated SD card for the external one, and believes it has moved the files to the external card when it in reality has moved it on the emulated card.

Is this correct?
Does anyone else have this issue?
And most importantly, does anyone know of a way to solve the issue without having to root?

Thanks!
 
iovaniorgovan
Old
#2  
iovaniorgovan's Avatar
Senior Member
Thanks Meter 40
Posts: 288
Join Date: May 2011
henninkn, have you found the answer yet?
wakelock hunter
 
hollowcaste
Old
#3  
Junior Member
Thanks Meter 0
Posts: 21
Join Date: Sep 2011
deto here .... i9300 running 4.3 stock

doesn't move apps to SD in one click ( button itself doesn't show up on "moveable app" page ) .. tried all possible apps
in app mgr , it works , app by app ... but no reduction in int memory ... god knows where the app goes

really frustrated !!

anyone found the answer / solution yet ??

---------- Post added at 11:34 PM ---------- Previous post was at 11:18 PM ----------

http://forum.xda-developers.com/gala...1672507/page32

Directory Bind ?
That's the solution ?? WTF !!
Tags
app, external, internal, move, sd card
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes