FORUMS

Index Project For XDA Device Subforums

Another ambitious project from the collaborative efforts of Recognized Contributors and Forum … more

The Atlas of XDA

A few weeks ago, we asked you “How Does Your Location Affect Your Life As A Power User?”. In the days that … more

New Snapdragons: Some Context & Contrast

It hasn’t been a good year for Qualcomm so far. Every device featuring the Snapdragon 810 … more

Google To Launch Next Gen Android One On July 14

The first gen of Android One devices to be launched in India in September 2014 were … more

Newly installed ROM won't recognize SIM Card

37 posts
Thanks Meter: 2
 
By idowolf, Member on 5th May 2014, 12:16 PM
Post Reply Subscribe to Thread Email Thread
Hi there!

I'm a proud owner of a Samsung Galaxy S3 I9300 (bought in Israel) running 4.1.2 stock.
I've installed "Revolutionary S5 ROM V3" on it, but after a successful installation, the phone failed to recognize my SIM card, thinking there's no SIM card inside. I panicked and restored my NANDroid backup, and everything worked well, but how can I get Revolutionary S5 ROM (or any ROM for that matter) other than my stock ROM to recognize my SIM card?

By the way, I'm sorry I have to make a new thread about it rather than ask my question in the ROM's page, unfortunately it prevents me from doing so because of my low post count.

Thanks for your support!
 
 
5th May 2014, 01:21 PM |#2  
jojohnson250's Avatar
Senior Member
Thanks Meter: 249
 
More
Maybe an idea to search the threads before posting but since you asked nicely, http://forum.xda-developers.com/devd...ct/dl/?id=5942 here is the link to the updated modem, flash revolutionary s5 then flash this file in recovery and there shouldn't be any issues!

Sent from my GT-I9300 using XDA Premium 4 mobile app
The Following User Says Thank You to jojohnson250 For This Useful Post: [ View ]
5th May 2014, 01:27 PM |#3  
OP Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by jojohnson250

Maybe an idea to search the threads before posting but since you asked nicely, http://forum.xda-developers.com/devd...ct/dl/?id=5942 here is the link to the updated modem, flash revolutionary s5 then flash this file in recovery and there shouldn't be any issues!

Sent from my GT-I9300 using XDA Premium 4 mobile app

Thank you for your support! I swear I've been searching and haven't found an answer before though. Can you tell me about this file? What does it do? Is it reversible if I flash back to stock again?
5th May 2014, 01:43 PM |#4  
jojohnson250's Avatar
Senior Member
Thanks Meter: 249
 
More
OK what it does is it changes your EFS to V2 (anything before Android 4.3 used EFS v1 that's why you get no signal) http://forum.xda-developers.com/devd...ct/dl/?id=5557 download this app on to your phone (credits to Ricky) and then backup your current EFS.... And then flash the new one to use with all Roms that are Android 4.3 or higher but if you choose to revert to 4.1.2 for instance you will need your EFS V1 backup to get signal back, so basically backup, then flash rom (it's amazing) and then the file I posted earlier and stick with it!

Sent from my GT-I9300 using XDA Premium 4 mobile app
The Following 2 Users Say Thank You to jojohnson250 For This Useful Post: [ View ]
9th December 2014, 02:23 AM |#5  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by jojohnson250

OK what it does is it changes your EFS to V2 (anything before Android 4.3 used EFS v1 that's why you get no signal) http://forum.xda-developers.com/devd...ct/dl/?id=5557 download this app on to your phone (credits to Ricky) and then backup your current EFS.... And then flash the new one to use with all Roms that are Android 4.3 or higher but if you choose to revert to 4.1.2 for instance you will need your EFS V1 backup to get signal back, so basically backup, then flash rom (it's amazing) and then the file I posted earlier and stick with it!

Sent from my GT-I9300 using XDA Premium 4 mobile app


Thanks a lot! I have the same issue and it help me! ^___^
27th May 2015, 07:31 AM |#6  
Junior Member
Thanks Meter: 0
 
More
Thanks
Quote:
Originally Posted by jojohnson250

OK what it does is it changes your EFS to V2 (anything before Android 4.3 used EFS v1 that's why you get no signal) http://forum.xda-developers.com/devd...ct/dl/?id=5557 download this app on to your phone (credits to Ricky) and then backup your current EFS.... And then flash the new one to use with all Roms that are Android 4.3 or higher but if you choose to revert to 4.1.2 for instance you will need your EFS V1 backup to get signal back, so basically backup, then flash rom (it's amazing) and then the file I posted earlier and stick with it!

Sent from my GT-I9300 using XDA Premium 4 mobile app

Thank you, gonna try this as soon as i get home. I have the same issues, after flashing phone just keeps working as no sim card is inserted.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes