Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,781,962 Members 50,243 Now Online
XDA Developers Android and Mobile Development Forum

[Q] OTA Jelly Bean 4.1.2 WiFi Network disabled. Poor connection

Tip us?
 
alehardware
Old
(Last edited by alehardware; 28th February 2013 at 11:10 AM.) Reason: [Solved]
#1  
Member - OP
Thanks Meter 1
Posts: 37
Join Date: Jun 2006
Unhappy [Q] OTA Jelly Bean 4.1.2 WiFi Network disabled. Poor connection

I bought unbranded Galaxy S3. It came with ICS, the I got OTA update to Jelly Bean v.4.1.2 I9300UBELL1 Kernel 3.0.31-783635 se.infra@SEP-92 ·1 SMP PREEMPT Fri Jan 4 19:59:29 KST 2013.
After that it was imposible to connect to any WiFi router (tried different ones that were working OK with other devices). I did a factory reset and still no WIFI connection possible. I always got "Network disabled. Poor connection" even with full signal and right by the router. So, I flashed the original ICS stock ROM and every was OK again, WiFi worked perfectly. I tried one more time the JB OTA update and again and ended up with NO WiFi.

I have also tried every trick Iīve found on Internet (like disabling wifi power saving, etc, etc) nothing worked.

Anyone knows how to solve it? I will go back to ICS but thatīs not the idea when buying a top smartphone, is it?

Thanks

[Solved]
Rooted, and flashed with stock ROM I9300UBELL1 = Kernel 3.0.31-767276 se.infra@SEI-75#1 SMP PREEMPT Mon Dec 31 13:32:27 KST 2012 ... it seems it is an older ROM but Sammobile.com listed it as a more recently released named as I9300UBELL6_I9300ANCELL1_ANC while the previous one was named I9300UBELL1 ... the last digit is the revision number, isnīt it?
Its not the RIL/modem becuase before that I tried flashing a different RIL firmware and WiFi didnīt work either.

Hope it helps for those left without WIFI.
Alejandro
 
bigmo7
Old
#2  
bigmo7's Avatar
Senior Member
Thanks Meter 216
Posts: 940
Join Date: Nov 2010
Location: London

 
DONATE TO ME
Is it an N enabled router? Some people reported problems with routers which just use N enabled routers...
HTC One - ARHD 10.0 - Stock Kernel
Nexus 7 - SmoothROM 5.1 - Stock Kernel

History
ZTE Blade II
SGS3
SGS2
SGS
Nokia E71
Nokia 5800
Nokia N82
T-mobile G1
Motoroloa L7
Nokia 7600
Can't remember past this point :/


My (geeky) Android blog
&
Twitter

If someone has helped you out, use the thanks button!
 
alehardware
Old
#3  
Member - OP
Thanks Meter 1
Posts: 37
Join Date: Jun 2006
Quote:
Originally Posted by bigmo7 View Post
Is it an N enabled router? Some people reported problems with routers which just use N enabled routers...
Thanks for your prompt answer!!!
Actually, I tried with many routers ... I think they might been all N enabled routers ... but why there is a problem with JB and not with ICS??? Besides Iīm currently abroad and I need to use whatever router I find in hotels, restaurants, etc, and cannot ask them to change the configuration of their routers for me ...

When I paid what I paid for this phone the least I would had expected was that Samsung would realease an OTA update that would mess up my WiFi connection!!!

I have already sent them and email, but for what I have found on the net, it is something that many people had experienced ... maybe more those who bought and unbranded SIII, like I did.

Thanks again, lets hope someone gets a solution.
Alejandro
 
m15chief
Old
#4  
m15chief's Avatar
Senior Member
Thanks Meter 3
Posts: 116
Join Date: Jan 2005
Location: Newcastle
Anyone found a way to fix this without Rooting yet? n I need stock for Sky Go.

---------- Post added at 01:02 PM ---------- Previous post was at 12:54 PM ----------

OK, think I might have a fix for anyone who doesn't want to root.. I installed the EE WiFi app, which has its own drivers and it connected immediately.
[Enter Signature Here]
 
m15chief
Old
#5  
m15chief's Avatar
Senior Member
Thanks Meter 3
Posts: 116
Join Date: Jan 2005
Location: Newcastle
Default Re: [Q] OTA Jelly Bean 4.1.2 WiFi Network disabled. Poor connection

Ok, back to square one. Installing the EE wifi app worked at first but then crapped out.

Still looking for a non-root sokution to this wifi bug

Sent from my GT-I9305 using Tapatalk 2
[Enter Signature Here]
 
Reddly
Old
#6  
Junior Member
Thanks Meter 0
Posts: 8
Join Date: Jan 2013
also looking for non rooted solution. posted in a similar thread but its basically lost on me why this is happening.
my and my GFs S3 connect to open networks and private networks (including our home network) without any trouble.
we go to her cafe and neither of our phones can connect. other people with laptops, phones, tablets etc can connect.
a week ago we could connect and it was no problem. nothing has changed and now neither of us can connect. we can see the network, its strong signal (we're 5 ft from the router sitting behind the counter) and everytime we try to connect it says the same thing, network disabled. poor connection.

why will it work for other devices and not the S3? why would it work previously and not now? Why do our S3s work on other networks and not this one?

I was really happy with this phone and so was my gf but this has put a bit of a downer on them.
 
m15chief
Old
#7  
m15chief's Avatar
Senior Member
Thanks Meter 3
Posts: 116
Join Date: Jan 2005
Location: Newcastle
Default Re: [Q] OTA Jelly Bean 4.1.2 WiFi Network disabled. Poor connection

I just called the EE store. I only upgraded to the i9305 on saturday and already on to my second replacement (accelerometer went in the first one)

Seriously considering a different model replacement like an iphone 5. Thats how p*ssed off I am with this phone.

Never had a single issue with my i9300

Sent from my GT-I9305 using Tapatalk 2
[Enter Signature Here]
 
Bensmom
Old
#8  
Bensmom's Avatar
Junior Member
Thanks Meter 0
Posts: 13
Join Date: Oct 2012
I had this exact problem today. Came to post on the forum and found your question.

This problem came out of nowhere for me, my phone found and connected to my wifi as usual, but suddenly the connection I had been using said 'Disabled'.

I found this video and it worked for me.
http://www.youtube.com/watch?v=cVT73SBDlzQ
Steps are:

Wifi Settings --> Advanced --> "Keep wi-fi on during sleep" --> Select "Never" (Third option)

BUT later on it seemed to 'disable' again, so I went back in to the settings again, and selected "Always", and now my phone is connected again.

Hope that helps :/
 
hitecator
Old
#9  
Junior Member
Thanks Meter 1
Posts: 3
Join Date: Mar 2009
Default Fix for poor Internet connection

I just figured this, go to Advanced option and UNCHECK Check for Internet Service. Once you done this, OS will not check for the Connection quality. I tested this on my S4 and it works. Hope you all get through these
The Following User Says Thank You to hitecator For This Useful Post: [ Click to Expand ]
 
amansehdev
Old
#10  
Junior Member
Thanks Meter 1
Posts: 1
Join Date: Sep 2013
There's actually a very simple way to solve this issue. It doesn't identify the reason why it occurs, however it does solve the problem. If you manually add the wifi connection, the one you are having the problem with. It will solve the problem, make sure everything is case sensitive and the security is set to wpapsk. I hope it helps.

The Following User Says Thank You to amansehdev For This Useful Post: [ Click to Expand ]
Tags
galaxy s3, jelly bean 4.1.2, no wifi, siii
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes