5,599,677 Members 45,000 Now Online
XDA Developers Android and Mobile Development Forum

Phone is bricked - pit file issue

Tip us?
 
idanohh
Old
#1  
Member - OP
Thanks Meter 2
Posts: 41
Join Date: Oct 2011
Question Phone is bricked - pit file issue

Hi All,
My phone is GT I9300 International Version,
ROM Installed before incident: one of the latest (past month) CM 10.1 nightly builds.

Woke up this morning and my phone was in download mode and my screen was like this and it kept rebooting:

Tried taking out the battery / reboot / connecting to usb problem persists the rom is not loading and bring you back to download mode with the white screen.
Tried to enter the following modes:
Recovery Mode: NO RECOVERY MODE, it enters back to the download mode.
Download Mode: when entering download mode the phone screen is black as it should be

Conclusion: DOWNLOAD MODE IS THE ONLY AVAILABLE MODE I HAVE !

So, i figured something probably have gone bad in the phone but it's fixable since i can still go into the download mode.
So i downloaded one of the stock roms from samsmobile and tried with odin
Odin 1.85/3.04/3.07 - Getting error messages:
every time i tried reflashing it has lost the driver connection and even though it showed "Added" in the ODIN sometimes it wouldn't pass the setup connection step, so everytime i had to reboot the phone in order for the connection to be properly initialized.

PDA file to flash -
<ID:0/003> Added!!
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> I9300XXUFME3_I9300OJKFME1_HOME.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Get PIT for mapping..
<ID:0/003>
<ID:0/003> There is no PIT partition.
<OSM> All threads completed. (succeed 0 / failed 1)

No Pit ? So i downloaded a PIT:
SGS3\GT-I9300_mx_20120220.pit - this one fits the i9300 with 16gb according to what i searched and off course the model i own.

here is the odin output
<ID:0/003> Added!!
<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Set PIT file..
<ID:0/003> DO NOT TURN OFF TARGET!!
<ID:0/003> Get PIT for mapping..


and that's it it was just stuck like this forever...
I should mention that i tried different USB ports or even computers (all win7 64 bit) also tried runnning it(odin) with windows xp sp3 compatibility
usually when you start download mode and odin has started already you would see some kind of a progress bar on the actual phone,
that was missing as well...meaning the phone didnt seem to respond so far to the odin although it did shows sign of connectivity.

does anyone have a solution for this issue ???
 
JJEgan
Old
#2  
Senior Member
Thanks Meter 4406
Posts: 23,036
Join Date: Oct 2010
Flashing Pit can kill your phone ..
But looks like your PIT was damaged anyway .

Solution is a service centre repair or buy a new motherboard .

jje
 
idanohh
Old
#3  
Member - OP
Thanks Meter 2
Posts: 41
Join Date: Oct 2011
Quote:
Originally Posted by JJEgan View Post
Flashing Pit can kill your phone ..
But looks like your PIT was damaged anyway .

Solution is a service centre repair or buy a new motherboard .

jje
Is this the famous MotherBoard Bug ? My version was 1.1

Anyhow, the download mode works its just you can't do anything with it because the its missing a pit file and can't upload one apparently ...
Anyone has a better suggestion about how to forcibly re-partition the drive ? and set the pit file ?
to me it sounds like a SD CARD issue and not a motherboard issue...
 
dxppxd
Old
#4  
Senior Member
Thanks Meter 173
Posts: 513
Join Date: Feb 2012
Does it show product name while in download mode? Or is it blank?
 
JJEgan
Old
#5  
Senior Member
Thanks Meter 4406
Posts: 23,036
Join Date: Oct 2010
No its not SDS.
If you think its sd card then you are confused as NAND is part of the motherboard .

As you have no warranty then its certainly worth trying to repartition .

Sorry i don't know where the relevant post is .

jje
 
idanohh
Old
#6  
Member - OP
Thanks Meter 2
Posts: 41
Join Date: Oct 2011
Quote:
Originally Posted by dxppxd View Post
Does it show product name while in download mode? Or is it blank?
Hi,
Nope it doesn't say the product name in that field, what does it mean ?
here is the out of that...

ODIN MODE
PRODUCT NAME:
CUSTOME BINARY DOWNLOAD: No
CUSTOME BINARY: Samsung Official
SYSTEM STATUS: Custom
 
idanohh
Old
#7  
Member - OP
Thanks Meter 2
Posts: 41
Join Date: Oct 2011
Quote:
Originally Posted by JJEgan View Post
No its not SDS.
If you think its sd card then you are confused as NAND is part of the motherboard .

As you have no warranty then its certainly worth trying to repartition .

Sorry i don't know where the relevant post is .

jje
its ok, thanks for the patience,
i thought the re-partitioning is related to the space allocation between the partitions.
but you right since its just a few kb file it can sit on the nand, and be flashed.
 
Factionwars
Old
#8  
Factionwars's Avatar
Member
Thanks Meter 4
Posts: 34
Join Date: Jul 2009
Just got the exact same problem, used cyanogenmod 10.1 for a long time. Last days it has been freezing all the time so i put MIUI on it and after an hour it died.
Web Developer - Security freak - Overal Media Developer
I9300 Galaxy SIII
 
boomboomer
Old
#9  
boomboomer's Avatar
Senior Member
Thanks Meter 556
Posts: 2,440
Join Date: Jun 2010
If your product name is blank in download then you have SDS, return to Samsung for warranty repair.
 
majidshahab091
Old
#10  
Senior Member
Thanks Meter 8
Posts: 254
Join Date: Mar 2011
Try flashing any kernel in odin and than check result

Sent from my GT-I9300 using xda app-developers app

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes