What Do You Do with All of Your Old Photos?

Smartphone cameras have advanced so tremendously over the past few years that they have … more

Diving into the April 2015 Material Design Update

Before the release of Android 5.0 Lollipop, the Holo Design guidelines served as the … more

New Cyanogen Partnerships Bring Privacy Concerns

New Privacy concerns have emerged regarding Cyanogen’s latest announcements, … more

PSA: Google Play Services Wakelock Affects Many 5.x ROMs

Wakelocks are the bane of the battery conscious, and this wakelock bug has been … more
Post Reply Subscribe to Thread Email Thread

My S3 has black dots and lines on screen

12th February 2014, 04:57 PM |#1  
RaideN250's Avatar
OP Senior Member
Thanks Meter: 5
 
229 posts
Join Date:Joined: Dec 2011
More
Hello. I noticed this problem last week when turning the phone on. There was a black line on screen that was visible on the S3 logo and boot animation. Today I noticed It's getting bigger and several black ' balls ' or dots appeared but again they are only visible on boot or the TWRP recovery stand-by mode. I don't know what this is, I never had this problem before with any phone. Please help me. Also I have the international version, the GT- I9300. And the lines and dots aren't visible normally, the phone works just fine You can't even see those 'things' normally when the phone is on.

Sent from my GT-I9300 using xda app-developers app
 
 
12th February 2014, 06:16 PM |#2  
Senior Member
Thanks Meter: 4,450
 
23,117 posts
Join Date:Joined: Oct 2010
Restore to stock return to vendor .
12th February 2014, 08:20 PM |#3  
RaideN250's Avatar
OP Senior Member
Thanks Meter: 5
 
229 posts
Join Date:Joined: Dec 2011
More
It is on stock rom, it's rooted and it has TWRP recovery and I can't return it because it was purchased online and it can only be returned within the first 3 days. I might think those lines are dead or stuck pixels

Sent from my GT-I9300 using xda app-developers app
17th February 2014, 05:13 PM |#4  
RaideN250's Avatar
OP Senior Member
Thanks Meter: 5
 
229 posts
Join Date:Joined: Dec 2011
More
Bump.

Sent from my GT-I9300 using xda app-developers app
17th February 2014, 05:33 PM |#5  
Senior Member
Flag Iasi-Cotnari
Thanks Meter: 6
 
127 posts
Join Date:Joined: Mar 2010
More
Quote:
Originally Posted by RaideN250

Hello. I noticed this problem last week when turning the phone on. There was a black line on screen that was visible on the S3 logo and boot animation. Today I noticed It's getting bigger and several black ' balls ' or dots appeared but again they are only visible on boot or the TWRP recovery stand-by mode. I don't know what this is, I never had this problem before with any phone. Please help me. Also I have the international version, the GT- I9300. And the lines and dots aren't visible normally, the phone works just fine You can't even see those 'things' normally when the phone is on.

Sent from my GT-I9300 using xda app-developers app

try flashing another rom and another recovery, like phil'z recovery. if the problem persists, it's probably the screen.
18th February 2014, 10:41 AM |#6  
Member
Thanks Meter: 10
 
54 posts
Join Date:Joined: Feb 2014
It looks like the known issue of AMOLED screens on dark screen+ low brightness.

Refer this thread for more details:
http://forum.xda-developers.com/show....php?t=1701528
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes