Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,814,319 Members 51,134 Now Online
XDA Developers Android and Mobile Development Forum

My S3 has black dots and lines on screen

Tip us?
 
RaideN250
Old
#1  
RaideN250's Avatar
Senior Member - OP
Thanks Meter 5
Posts: 225
Join Date: Dec 2011
Location: Satu Mare
Default My S3 has black dots and lines on screen

Hello. I noticed this problem last week when turning the phone on. There was a black line on screen that was visible on the S3 logo and boot animation. Today I noticed It's getting bigger and several black ' balls ' or dots appeared but again they are only visible on boot or the TWRP recovery stand-by mode. I don't know what this is, I never had this problem before with any phone. Please help me. Also I have the international version, the GT- I9300. And the lines and dots aren't visible normally, the phone works just fine You can't even see those 'things' normally when the phone is on.

Sent from my GT-I9300 using xda app-developers app
 
JJEgan
Old
#2  
Senior Member
Thanks Meter 4,421
Posts: 23,044
Join Date: Oct 2010
Restore to stock return to vendor .
 
RaideN250
Old
#3  
RaideN250's Avatar
Senior Member - OP
Thanks Meter 5
Posts: 225
Join Date: Dec 2011
Location: Satu Mare
It is on stock rom, it's rooted and it has TWRP recovery and I can't return it because it was purchased online and it can only be returned within the first 3 days. I might think those lines are dead or stuck pixels

Sent from my GT-I9300 using xda app-developers app
 
RaideN250
Old
#4  
RaideN250's Avatar
Senior Member - OP
Thanks Meter 5
Posts: 225
Join Date: Dec 2011
Location: Satu Mare
Bump.

Sent from my GT-I9300 using xda app-developers app
 
darkmage93
Old
#5  
Senior Member
Thanks Meter 6
Posts: 124
Join Date: Mar 2010
Location: Iasi-Cotnari
Quote:
Originally Posted by RaideN250 View Post
Hello. I noticed this problem last week when turning the phone on. There was a black line on screen that was visible on the S3 logo and boot animation. Today I noticed It's getting bigger and several black ' balls ' or dots appeared but again they are only visible on boot or the TWRP recovery stand-by mode. I don't know what this is, I never had this problem before with any phone. Please help me. Also I have the international version, the GT- I9300. And the lines and dots aren't visible normally, the phone works just fine You can't even see those 'things' normally when the phone is on.

Sent from my GT-I9300 using xda app-developers app
try flashing another rom and another recovery, like phil'z recovery. if the problem persists, it's probably the screen.
Don't forget to press the "Thanks" button if i helped you!

Phone: SONY Xperia Z2
Android ROM: Stock+Root 4.4.2
 
mankidavu
Old
#6  
Junior Member
Thanks Meter 4
Posts: 22
Join Date: Feb 2014
It looks like the known issue of AMOLED screens on dark screen+ low brightness.

Refer this thread for more details:
http://forum.xda-developers.com/show....php?t=1701528
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA Xposed Tuesday: How to Shut Up Your Phone – XDA Developer TV

So many different applications want to send us notifications that … more

Add Some Power to First Generation Snapdragon CPUs

Some older devices still remain very popular. Phones like theHTC Desire, Sony Ericsson … more

Android M Mentions Spotted in Android Code Review

While we are still waiting for Android L to be officially released, the first mentions of … more

Create a Simple Custom Launcher from Scratch

When you are starting your journey intoany sort of development, it’s never easy at the … more