Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

S3 Wont Turn on Charging boot loop

OP projectaero

19th June 2014, 07:46 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jun 2014
Hi,
My I9305 S3 Wont Turn on via the power button.
I connect it via USB and it loads the following in this order:

*Connect USB
1. Need to charge logo
[split second]
2. Battery charging logo
[1 second]
3. Reset
[repeat 1 2 3]

*photo of the battery icons displayed*
s2.postimg.org/iz6xu6ry1/phone.png

You cant get to the Android Settings

I got a phone tech to try another battery.
That didnt work.

He then took it apart and it said it isnt the power button.
He is unsure why.

It was flashed back to stock after using SentinelROM and every now and again it would restart by itself, now it wont turn on.
Any ideas?
Last edited by projectaero; 19th June 2014 at 07:58 AM.
19th June 2014, 11:49 AM   |  #2  
Senior Member
Thanks Meter: 108
 
580 posts
Join Date:Joined: Dec 2010
More
Quote:
Originally Posted by projectaero

Hi,
My I9305 S3 Wont Turn on via the power button.
I connect it via USB and it loads the following in this order:

*Connect USB
1. Need to charge logo
[split second]
2. Battery charging logo
[1 second]
3. Reset
[repeat 1 2 3]

*photo of the battery icons displayed*
s2.postimg.org/iz6xu6ry1/phone.png

You cant get to the Android Settings

I got a phone tech to try another battery.
That didnt work.

He then took it apart and it said it isnt the power button.
He is unsure why.

It was flashed back to stock after using SentinelROM and every now and again it would restart by itself, now it wont turn on.
Any ideas?

happened to me also. try change different cable or charger & try to connect to PC. and check if your micro usb port clean or not.

and if it work, let the battery charged for a while before turn it on.
19th June 2014, 01:25 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by syamsoul

happened to me also. try change different cable or charger & try to connect to PC. and check if your micro usb port clean or not.

and if it work, let the battery charged for a while before turn it on.

I tried 3 different cables connected to PC, a different battery and it didnt work.
It wont turn on unless you have the charger in so im assuming its picking it up fine.
I made sure the micro USB port was clean.
I kept it on there for an hour once, boot looping, and yeah still didnt turn on.
Its got me stumped.
26th June 2014, 01:37 AM   |  #4  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by projectaero

I tried 3 different cables connected to PC, a different battery and it didnt work.
It wont turn on unless you have the charger in so im assuming its picking it up fine.
I made sure the micro USB port was clean.
I kept it on there for an hour once, boot looping, and yeah still didnt turn on.
Its got me stumped.


anyone else have any ideas?
26th June 2014, 07:44 AM   |  #5  
boomboomer's Avatar
Senior Member
Thanks Meter: 749
 
3,400 posts
Join Date:Joined: Jun 2010
Report your own post and ask a moderator to move it for you, the i9305 has a separate q&a forum.

If it won't boot into download mode then try a usb jig, but sounds like you need a new motherboard -take it to a different phone tech.

Sent from my GT-I9300 using Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes