Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,296 Members 52,274 Now Online
XDA Developers Android and Mobile Development Forum

[Q] S3 i9300 Camera Failed

Tip us?
 
Tweetix
Old
#1  
Junior Member - OP
Thanks Meter 2
Posts: 20
Join Date: Jun 2013
Default [Q] S3 i9300 Camera Failed

Hi everyone,
I'm posting here because I think that XDA is the place where I will get most usefull answers.
Few days ago, I tried to take a picture (as all days) but the camera app crashed.
I tried another one, but it crashed too : could not connect to camera, or anything like this...

I tried everything : full wipe, kernel change, rom change, stock rom, nothing worked...
A friend gave me the permission to disassembly his S3 :
I plugged his camera module on my motherboard : didn't worked
I plugged my camera module on his motherboard : worked...

When i'm on a stock rom and i want to launch the tool that give us informations about the firmware of the camera it crash too...

I'm going to become crazy with that...

Does anyone see anything that I forgot ?...
Thanks in advance, and sorry for my bad english...
 
kunal1540
Old
#2  
kunal1540's Avatar
Senior Member
Thanks Meter 348
Posts: 749
Join Date: Jun 2013
Location: City of oranges
You are by any chance using stock 4.3 ROM..
If you are using then I think you should flash a stock kernel then open camera and take a pic and then flash kernel of your choice..
You mentioned that you changed kernels but did you flash any stock kernels if not you should try this...

Sent from my GT-I9300
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes