Post Reply Subscribe to Thread Email Thread

Selected Network Unavailable after battery drain

18th June 2014, 11:12 AM |#1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jun 2014
Hi

Yesterday, my phone was working fine. The battery was on 1% so I plugged it in to charge. I taken it off charge and turned it on, and was greeted by the no signal icon. Then, signal came back but read "emergency calls only." Now, I can't connect to my network. I tried a Vodafone sim in it and it worked OK, but two Three sims failed to work. I tried my dad's and mine. The funny thing is, my sim works in my dads phone, as does his. So by all accounts it looks as though three had blocked my phone from their network, even though it's pay as you go. I phoned them but they told me they haven't blocked it and it should work OK. I haven't touched anything on it, I just charged it.

Do any of you guys have any idea what could be wrong? I thought maybe the hardware had failed, but like I say it connected to vodafone so this seems impossible.

I'm seriously puzzled. I've tried recovering the firmware through Kies to no avail.

I'm at my wits end. Thanks! (:
 
 
18th June 2014, 11:53 AM |#2  
boomboomer's Avatar
Senior Member
Thanks Meter: 801
 
3,741 posts
Join Date:Joined: Jun 2010
Might be sim lock, was the phone originally locked to vodaphone?

Sent from my GT-I9300 using Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes