Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,164 Members 50,103 Now Online
XDA Developers Android and Mobile Development Forum

I9300 soft brick (messy) - please help

Tip us?
 
Bananafische
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jul 2011
Default I9300 soft brick (messy) - please help

Hi - I tried posting this in Development where I thought it should go but I haven't posted at all before so it won't let me.

I've gotten myself into a very messy (and probably stupid) situation with firmware with my I9300 - there's a very real chance I think that it is non-recoverable, but if anyone could give me some advice on what else to try I would be extremely grateful!

My problem:

Galaxy S3 I9300 16gb international won't boot - stuck at Device Name screen.
  • Won't boot into recovery
  • Will boot into download mode
  • Odin connects to device, but trying to flash stock ROM freezes at 'NAND Write Start!' or just FCs ("Odin has stopped working" reported by Windows
  • Heimdall won't recognise my device (does it even work with the s3? I don't know) so I can't print a PIT or anything

How I got here (over about 4 weeks):
  • Started with I9300 16gb international version (Grey import from Hong Kong to Australia, booted in French but let me change to English)
  • Gained root access through CWM touch kernel and Odin
  • Flashed AOKP Milestone 6 ROM
  • Used 'Secure Settings' (app) and 'Locale' (app) to set up a lockscreen PIN that enabled and disabled dynamically according to location rules (worked pretty well!)
  • Decided I wanted to encrypt my device
  • Clicked through all warnings, followed instructions to set PIN (didn't disable Secure Settings, the app that allowed the lockscreen changes outlined above)
  • Encryption successful, booted successfully using the PIN set
  • Lockscreen goes funny - 'quick PIN' option in AOKP (where you don't have to press OK after entering the PIN correctly) stops working
  • Any PIN at all at this point will unlock my device
  • Reboot to discover that my original encryption PIN has stopped working
  • Seriously, I tried it like 20 times including slight variations in case I mistyped, and other PINs that I use in case I misremembered
  • Rebooted into CWM to try to flash a new ROM
  • Can't access internal SD due to encryption
  • Use Galaxy S3 Toolkit to 'download and flash new stock rom, kernel using Odin'
  • Didn't know which firmware to download so i went with option 5 (GT-I9300_BTU_I9300XXALF2_I9300OXAALF2_I9300XXLF2)
  • Odin connects sucessfully, flashes device
  • Device reboots into 'Trouble with firmware upgrade - connect to samsung kies to fix' (or whatever it says)
  • Download and install Kies (i had the USB drivers for the phone installed previously)
  • Kies won't recognise my phone on any level for emergency recovery
  • Decide that the internal SD card encryption is causing the problems, and that maybe I need to repartition
  • Don't notice all the warnings about repartitioning
  • Download PIT files for I9300 from somewhere
  • Try reflashing ROM using one of these PITs (I didn't know any better so I just used GT-I9300_mx_20120329.pit, which in retrospect is probably for a device with different internal storage size)
  • Phone stopped giving me 'Firmware update problem' screen and started going to the 'GT I9300' booting screen, but never got past that point
  • Repeat ad infinitum - I've tried flashing several different stock ROMs, using several PITs and am now at the point mentioned above.

Only other information I have really is that on the back cover behind the battery it says 'Model GT-I9300' and 'SSN-I9300GSMH' if those are important.

Other forums seem to indicate that I have a NAND read/write issue, but trying to flash a stock kernel (which was the advice given) results in... 'NAND write start!' freeze :\

Like I said, I have no idea if this is recoverable in any way at this point, but if anyone has any ideas I'd love to hear them!

Thanks
 
dingo dog
Old
#2  
dingo dog's Avatar
Member
Thanks Meter 4
Posts: 35
Join Date: Dec 2011
Location: Manchester

 
DONATE TO ME
Hi. This probably wont help, but try to use fresh odin download and other pc with new drivers installed without Sam Kies. older versions of odin did not worked with mine s3 and I had green screen while flashing problems when I used my old laptop to flash. Fresh pc with fresh drivers did the trick
 
Bananafische
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jul 2011
Quote:
Originally Posted by dingo dog View Post
Hi. This probably wont help, but try to use fresh odin download and other pc with new drivers installed without Sam Kies. older versions of odin did not worked with mine s3 and I had green screen while flashing problems when I used my old laptop to flash. Fresh pc with fresh drivers did the trick
Hi - Thanks for the tip, but I already tried with my wife's laptop. Should have mentioned in the original post.

Thanks again.
 
JJEgan
Old
#4  
Senior Member
Thanks Meter 4,418
Posts: 23,038
Join Date: Oct 2010
Older versions of Odin do work on SGS3 .

evelopment where I thought it should go but I haven't posted at all before so it won't let me.

Development only posts not Q&A nothing to do with 10 posts .


Two thoughts could be the usual flashed multiple stuff and phone is confused plus wrong PIT file flashed .
Thats just firmware not hardware problem .
Or indeed at some stage Nand is corrupt .

Solution would be
Try correct PIT file first before a repair centre .

jje
 
burton6666
Old
#5  
Junior Member
Thanks Meter 0
Posts: 25
Join Date: Aug 2010
Just wanted to say that I have the same problem, but mine is even more strange. I can boot into the system but I have to disable wifi and mobile data right away otherwise the phone will reboot after a couple of seconds. I see the phone if I connect it to the computer but I can not write or read the files on the phone. But I tried the toolbox and could push an apk to the phone.

CWM works but if I try to wipe or flash another rom it reboots, some stuff works and other just reboots the phone.

Download-mode works and Odin finds the phone but everything I have tried fails. I have tried standard stock firmware, 3 part firmware and PIT but it always hangs on NAND Write.

If anyone has some solution I would be thrilled.
 
theonlyanil
Old
#6  
theonlyanil's Avatar
Senior Member
Thanks Meter 31
Posts: 113
Join Date: May 2012
Location: Jaipur
Quote:
Originally Posted by Bananafische View Post
I've gotten myself into a very messy (and probably stupid) situation with firmware with my I9300 - there's a very real chance I think that it is non-recoverable

My problem:
[*]Won't boot into recovery[*]Will boot into download mode[*]Odin connects to device, but trying to flash stock ROM freezes at 'NAND Write Start!' or just FCs ("Odin has stopped working" reported by Windows[*]Heimdall won't recognise my device (does it even work with the s3? I don't know) so I can't print a PIT or anything

Thanks
It can be solved using Odin if you get the official and correct Stock ROM for your SGS3. And/Or you might have been using the Wrong PIT.
And finally, No idea about heimdall ;p

Try this process: Samsung Galaxy S3 Not Booting? Here’s The Solution You can get detailed instructions here and that .PIT file too.
Mobiles: Nexus 5, Xiaomi Mi3, Samsung Galaxy S3, Xperia X10 and BB Curve 8520
----------------------------------------------------
Blogger at WideFide
The Following 6 Users Say Thank You to theonlyanil For This Useful Post: [ Click to Expand ]
 
Bananafische
Old
#7  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Jul 2011
Quote:
Originally Posted by theonlyanil View Post
It can be solved using Odin if you get the official and correct Stock ROM for your SGS3. And/Or you might have been using the Wrong PIT.
And finally, No idea about heimdall ;p

Try this process: Samsung Galaxy S3 Not Booting? Here’s The Solution You can get detailed instructions here and that .PIT file too.
It worked!

PIT flash successful, then stock rom restored

I still needed to go in to stock recovery and do a factory reset from there to undo the encryption.

Thanks so much for everyone's help.
 
theonlyanil
Old
#8  
theonlyanil's Avatar
Senior Member
Thanks Meter 31
Posts: 113
Join Date: May 2012
Location: Jaipur
I am glad that It worked for you
Mobiles: Nexus 5, Xiaomi Mi3, Samsung Galaxy S3, Xperia X10 and BB Curve 8520
----------------------------------------------------
Blogger at WideFide
The Following User Says Thank You to theonlyanil For This Useful Post: [ Click to Expand ]
 
burton6666
Old
#9  
Junior Member
Thanks Meter 0
Posts: 25
Join Date: Aug 2010
I am still stuck, I am guessing that if none of the PIT´s work then it is officially bricked?
 
theonlyanil
Old
#10  
theonlyanil's Avatar
Senior Member
Thanks Meter 31
Posts: 113
Join Date: May 2012
Location: Jaipur
u didn't try the link posted by me?
Mobiles: Nexus 5, Xiaomi Mi3, Samsung Galaxy S3, Xperia X10 and BB Curve 8520
----------------------------------------------------
Blogger at WideFide

The Following User Says Thank You to theonlyanil For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes