Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

S3 root problem

OP zkab

4th September 2012, 07:37 PM   |  #1  
OP Member
Thanks Meter: 0
 
31 posts
Join Date:Joined: Jun 2012
I have Samsung S3 (GT-I9300)
Followed the guide in http://forum.xda-developers.com/show....php?t=1684535
After that when I reboot in recovery it tells me:

Custom Binary Downloads: Yes (2 counts)
Current Binary: Custom
System Status: Custom

The reason I have 2 counts is that I installed 'CF-SGS3-CWM-v5.5-v1.5.tar' with Odin3 v.1.85 and discovered after that there was a later version Odin3 v.3.04. Then I reinstalled the tar-file with the later version ... I guess no harm done. Odin installed successfully both times.

But where is SuperSU & ClockWorkMod ???
I thought the were installed with the tar-file.

When I boot in recovery there is no option 'install from zip' ... so I can't install the downloaded 'CWM-SuperSU-v0.96.zip' either.
Tried to install SuperSU from Play (both free & pro) but when clickin on SuperSu error message 'there is no SU binary installed, and SuperSU cannot install it'

So where did the simple rooting go wrong ???
Appreciate help.
4th September 2012, 07:42 PM   |  #2  
theq86's Avatar
Senior Member
Flag Nuremberg
Thanks Meter: 736
 
918 posts
Join Date:Joined: Jan 2009
Donate to Me
More
The device restores stock recovery on boot unless you
* rename the etc/install_recovery.sh
* or take the x-flag from it.

Sent from my GT-I9300 using xda app-developers app
4th September 2012, 07:45 PM   |  #3  
Tectas's Avatar
Senior Member
Thanks Meter: 2,732
 
3,244 posts
Join Date:Joined: Jul 2011
Donate to Me
More
Had something similar some time ago, but it only sended me to stock recovery while using adb to reboot.
Download cf root from chainfire and flash it with Odin.
Afterwards install cwm touch with rommanager.
Worked for me back then.

Edit: btw, the thread you are referring to is for cwm touch only, got nothing to with root.

Sent from my GT-I9300 using Tapatalk 2
Last edited by Tectas; 4th September 2012 at 08:10 PM.
4th September 2012, 07:52 PM   |  #4  
Senior Member
Thanks Meter: 4,428
 
23,044 posts
Join Date:Joined: Oct 2010
Simple rooting are you sure you followed the instructions ???

After that when I reboot in recovery it tells me:

Custom Binary Downloads: Yes (2 counts)
Current Binary: Custom
System Status: Custom


NOPE not shown in recovery but in DOWNLOAD/ Odin Mode .

Confirmed working as of 30 seconds ago .

http://forum.xda-developers.com/show....php?t=1695238


jje
4th September 2012, 09:36 PM   |  #5  
OP Member
Thanks Meter: 0
 
31 posts
Join Date:Joined: Jun 2012
You are right ... it is shown in download mode ... my mistake

As mentioned I downloaded CF Root 'CF-SGS3-CWM-v5.5-v1.5.tar' from chainfire and flash it with Odin.
I got this from Odin:
<ID:0/003> Added!!
<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Get PIT for mapping..
<ID:0/003> Firmware update start..
<ID:0/003> recovery.img
<ID:0/003> NAND Write Start!!
<ID:0/003> RQT_CLOSE !!
<ID:0/003> RES OK !!
<ID:0/003> Completed..
<ID:0/003> Added!!
<OSM> All threads completed. (succeed 1 / failed 0)
<ID:1/004> Added!!

Then I downloaded/installed 'rommanager' from Play but when running it there is an error message that I am not root.
Don't understand howto get root privilidges ... thought flashing CF Root took care of that.
4th September 2012, 09:43 PM   |  #6  
nodstuff's Avatar
Senior Member
Flag Cork
Thanks Meter: 1,734
 
3,073 posts
Join Date:Joined: Apr 2010
More
Quote:
Originally Posted by zkab

You are right ... it is shown in download mode ... my mistake

As mentioned I downloaded CF Root 'CF-SGS3-CWM-v5.5-v1.5.tar' from chainfire and flash it with Odin.
I got this from Odin:
Added!!
Odin v.3 engine (ID:3)..
File analysis..
SetupConnection..
Initialzation..
Get PIT for mapping..
Firmware update start..
recovery.img
NAND Write Start!!
RQT_CLOSE !!
RES OK !!
Completed..
Added!!
All threads completed. (succeed 1 / failed 0)
Added!!

Then I downloaded/installed 'rommanager' from Play but when running it there is an error message that I am not root.
Don't understand howto get root privilidges ... thought flashing CF Root took care of that.

That's just cwm, you need to flash cf-root.
Gimme a sec and I'll link you.

http://forum.xda-developers.com/show....php?t=1695238

Sent from my GT-I9300 using xda premium
The Following User Says Thank You to nodstuff For This Useful Post: [ View ]
4th September 2012, 09:43 PM   |  #7  
Tectas's Avatar
Senior Member
Thanks Meter: 2,732
 
3,244 posts
Join Date:Joined: Jul 2011
Donate to Me
More
As the name tells it is cwm not root.
Go here: http://forum.xda-developers.com/show....php?t=1695238
download cf root from the third post and flash it with Odin, afterwards you have root and cwm installed. If you want cwm touch do like told before with rommanager.

Edit: beaten^^

Sent from my GT-I9300 using Tapatalk 2
Last edited by Tectas; 4th September 2012 at 09:55 PM.
The Following User Says Thank You to Tectas For This Useful Post: [ View ]
5th September 2012, 01:28 PM   |  #8  
OP Member
Thanks Meter: 0
 
31 posts
Join Date:Joined: Jun 2012
Thank you nodstuff & Tectas ... now I am airborne and much wiser
5th September 2012, 05:08 PM   |  #9  
OP Member
Thanks Meter: 0
 
31 posts
Join Date:Joined: Jun 2012
Well ... it seems that I am not 100% airborne.

After I installed 'CF-Root-SGS3-v6.4.zip' with Odin I maid a backup.
Then I flashed 'RR_JB_V3.0.6_AOKP_4.1.1_I9300.zip' & configured & rebooted ---> S3 is dead after the 'Samsung S3 GT-I9300' is displayed.
Now I have to boot into recovery and restored my backup to get S3 alive again.
What is wrong with 'RR_JB_V3.0.6_AOKP_4.1.1_I9300.zip' ?
I have used RR before on my old S2 and had never experienced any problem ?
Is it a S3 issue ?
5th September 2012, 05:16 PM   |  #10  
Mopral's Avatar
Senior Member
Flag Saint-Brieuc
Thanks Meter: 341
 
1,506 posts
Join Date:Joined: Jan 2009
More
Quote:
Originally Posted by zkab

Well ... it seems that I am not 100% airborne.

After I installed 'CF-Root-SGS3-v6.4.zip' with Odin I maid a backup.
Then I flashed 'RR_JB_V3.0.6_AOKP_4.1.1_I9300.zip' & configured & rebooted ---> S3 is dead after the 'Samsung S3 GT-I9300' is displayed.
Now I have to boot into recovery and restored my backup to get S3 alive again.
What is wrong with 'RR_JB_V3.0.6_AOKP_4.1.1_I9300.zip' ?
I have used RR before on my old S2 and had never experienced any problem ?
Is it a S3 issue ?

Have you follow the installation guide from RR thread (specially the wipe things...) ?

The Following User Says Thank You to Mopral For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes