Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,988 Members 55,566 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Usb connector

Tip us?
 
antros48
Old
#1  
Member - OP
Thanks Meter 0
Posts: 54
Join Date: Feb 2011
Default [Q] Usb connector

Hi
I have bought a usb connector to connect my flash drives with my phone. Every time i connect the connector i get the message USB connector connected but right after connecting the usb i get SD Card is Damaged. Try Reformatting it.
I used to have Omega rom and it was working fine for a couble of weeks but suddenly the message came up again so i flashed the official 4.3 android for S3. The problem still persists... FYI the phone is rooted and with stock rom and kernel.
Any help?
Thank you
 
verny94
Old
#2  
verny94's Avatar
Senior Member
Thanks Meter 72
Posts: 383
Join Date: May 2014
Location: Kladno
I donīt have the problem with USB flash disk. Format: Fat32
Samsung Galaxy SIII
Omega ROM (4.3) v59; Boeffla kernel 5.3; TWRP recovery; Nova launcher Prime; S5 theme; Xposed
Hit a thanks button, when I helped you
 
antros48
Old
#3  
Member - OP
Thanks Meter 0
Posts: 54
Join Date: Feb 2011
I have tried all kind of format disk but still the message Damaged SD Card shows up..
 
verny94
Old
#4  
verny94's Avatar
Senior Member
Thanks Meter 72
Posts: 383
Join Date: May 2014
Location: Kladno
And did you try another USB OTG or another Flash disk?
Samsung Galaxy SIII
Omega ROM (4.3) v59; Boeffla kernel 5.3; TWRP recovery; Nova launcher Prime; S5 theme; Xposed
Hit a thanks button, when I helped you
 
antros48
Old
#5  
Member - OP
Thanks Meter 0
Posts: 54
Join Date: Feb 2011
Yes i tried 3 usb flash drives and also USB OTG Checker app that gave me positive results about the cable..
 
dfire86
Old
#6  
Junior Member
Thanks Meter 0
Posts: 13
Join Date: Mar 2013
I think the problem is with your otg cable. Go to a accessories shop and check it there before you buy it. If it's not with the otg cable then may be it must be with the port

Sent from my GT-N7105 using XDA Free mobile app
 
antros48
Old
#7  
Member - OP
Thanks Meter 0
Posts: 54
Join Date: Feb 2011
I even have two cables and none of them makes the difference
Thanks anw for your responses
 
antros48
Old
#8  
Member - OP
Thanks Meter 0
Posts: 54
Join Date: Feb 2011
Ok i finally figured it out. After a a lot of formatting of my usb drives on windows i tried to format those in my Puppy Linux OS with the same format as before (FAT 32). After that everything worked. Seems like linux can when Windows can't
Thanks for your help hope i helped other facing the same prob.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA Xposed Tuesday: How to Control Google Play Wake Locks – XDA Developer TV

Xposed Modules are usually pretty simple. There are a few … more

Make Text Entry More Efficient with Macro Text Expansion

One of the best things about the modern day smartphone is its ability to save us … more

Fix KitKat WiFi Drops on Your Own

Despite introducing many useful features and overall great performance and enhancements,Android 4.4 KitKat … more

Bring Back Tablet UI on KitKat

Google presented their brand new UI for tablets alongsidethe release of Android 3.0 Honeycomb back in early … more