Question [Q] What's wrong with my SGS3 and Google Play services

For last couple of days, Google play services has been throwing up an error dialogue on my phone that it has stopped with OK and Report Button Although there doesn't seem any downside for it, except for its annoyance that I have to click OK , the error comes up randomly. For hours it might not come but it can also come up many times in an hour. Screenshot of what is contained in crash report is attached

Anyway, first I thought my ROM had corrupted. So, I wiped everything and re-installed a new ROM. However, the error didn't go away, again it will come up randomly. So I thought it was due to f2fs format since I had formatted /data, /data/media and /cache partitions to f2fs using arter97's recovery (I was using his kernel also). So I formatted them back to ext4, also changed my recovery back to philz's and installed stock CM rom. But again the error started coming

So I thought maybe it was due to I had been restoring apps via Titanium Backup which is causing the issue. So I stopped restoring apps, however It didn't work either, I was still getting the error. I started flashing many different ROMs (CM, omni, aosp, custom touchwiz) , gapps combination's (banks, 0day PA, others), factory resetting 10s of times, using MegaWipe script to format everything, removing the memory card permanently, however the error is still coming.

So in the end, I flashed stock samsung 4.3 ROM via ODIN and did a factory reset, however the error is still coming

I don't know what else to do ? Is my phone NAND corrupted ? Is there any test I can do to make sure ?

Please suggest..
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-06-28-02-49-41.png
Views:	14
Size:	99.3 KB
ID:	2821167  

 
Scan my Avatar to reveal the secret message