Post Reply

[Q] Something wrong with my device/battery

OP nikctsh

22nd July 2014, 09:50 AM   |  #1  
nikctsh's Avatar
OP Senior Member
Thanks Meter: 32
 
358 posts
Join Date:Joined: Jan 2011
More
This is not happening for the first time...
Ever since I rooted my device and flashed Android Revolutionary Rom on it, I noticed some weird behavior with my device/battery.
Last night I drained my battery to 6% and I turned it off. This morning I charged my phone with the phone stayed off and when the battery indicator screen lighted up it was showing that 50% juice remains. Since this is not happening for the first time, this time I would like to test on it to see whether there's really this much juice remains. So I turned my phone on and as expected, the battery indicator shows 50++% left. So I play around with it and I noticed the screen flashing terribly after some time. Not long after that the phone hang there and I had to do a hard reset by pulling out the battery. Before that, I can see that the battery is drained to around 20%. I was unable to power it on after pulling out the battery and when I connected my device to the charger, nothing happens (no display, no LED). So I left it there charging and after some time, finally the LED is lighting up (So, I assume that I drained the battery COMPLETELY just now). I can switch on the device afterwards and it shows 6% battery remains. I wonder why is this happening as this only happens when I charge my device with it turning off. Something wrong with the battery? Device? Or I have to do battery calibration?
22nd July 2014, 10:47 PM   |  #2  
RazorMC's Avatar
Senior Member
Flag SiN CiTY
Thanks Meter: 58
 
264 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by nikctsh

This is not happening for the first time...
Ever since I rooted my device and flashed Android Revolutionary Rom on it, I noticed some weird behavior with my device/battery.
Last night I drained my battery to 6% and I turned it off. This morning I charged my phone with the phone stayed off and when the battery indicator screen lighted up it was showing that 50% juice remains. Since this is not happening for the first time, this time I would like to test on it to see whether there's really this much juice remains. So I turned my phone on and as expected, the battery indicator shows 50++% left. So I play around with it and I noticed the screen flashing terribly after some time. Not long after that the phone hang there and I had to do a hard reset by pulling out the battery. Before that, I can see that the battery is drained to around 20%. I was unable to power it on after pulling out the battery and when I connected my device to the charger, nothing happens (no display, no LED). So I left it there charging and after some time, finally the LED is lighting up (So, I assume that I drained the battery COMPLETELY just now). I can switch on the device afterwards and it shows 6% battery remains. I wonder why is this happening as this only happens when I charge my device with it turning off. Something wrong with the battery? Device? Or I have to do battery calibration?

Let it charge to 100% first before using. Then check how is the battery usage.
There might be an issue with the battery also. If it is swollen then it's time to get a new one.
Try using another battery and see. If it works fine on other battery then your battery needs to change,

The problem could also be in the ROM. Something could have gone wrong during installation even though it may look fine. If this is the case then reflash the ROM with a full wipe. If the problem still remains, return to stock rom and see.
The Following User Says Thank You to RazorMC For This Useful Post: [ View ]
23rd July 2014, 12:26 AM   |  #3  
lsalamun's Avatar
Senior Member
Flag Varaždin
Thanks Meter: 174
 
568 posts
Join Date:Joined: Mar 2011
More
I had the exact same problems, the screen flashes and stutters, network signal is lost and the phone turns off, it is due to uncalibrated battery.
There's a simple fix, download battery calibration from play stor (green android icon with percentage), charge your phone to 100% without using it, then click battery calibr. inside that app, then doscharge it till 0% (do your normal usage as ussual) and then charge it back to 100%

For healthy battery life don't let it drain lower than 10% it's the li-ion physics and always charge it fully, don't charge from 0 to 30-50-60% because the ions in the battery will not have a good flow.
Everything has it's lifespan but if it's configured and used properly it can have a long lifespan

Also to mention, if my recommendation doesn't work, your battery could be swolen due to inproper charging / heavy oc-ing or your charger is messed up.
Also to say, that flickering occured to me when i flashed a new rom and when i do lot of reboots, then the batterystats freak out, the voltages also and also your phone.

Charhe and use it properly, try to stay with a rom at least a couple of days to see how it'll go.

Sent from my pebble blue scoobie doo using Tapatalk.
Last edited by lsalamun; 23rd July 2014 at 12:30 AM.
The Following User Says Thank You to lsalamun For This Useful Post: [ View ]
23rd July 2014, 03:30 AM   |  #4  
nikctsh's Avatar
OP Senior Member
Thanks Meter: 32
 
358 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by RazorMC

Let it charge to 100% first before using. Then check how is the battery usage.
There might be an issue with the battery also. If it is swollen then it's time to get a new one.
Try using another battery and see. If it works fine on other battery then your battery needs to change,

The problem could also be in the ROM. Something could have gone wrong during installation even though it may look fine. If this is the case then reflash the ROM with a full wipe. If the problem still remains, return to stock rom and see.

The battery usage is normal, and its not swollen. I guess I will try to calibrate the battery or reflash the ROM again.
23rd July 2014, 03:30 AM   |  #5  
nikctsh's Avatar
OP Senior Member
Thanks Meter: 32
 
358 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by lsalamun

I had the exact same problems, the screen flashes and stutters, network signal is lost and the phone turns off, it is due to uncalibrated battery.
There's a simple fix, download battery calibration from play stor (green android icon with percentage), charge your phone to 100% without using it, then click battery calibr. inside that app, then doscharge it till 0% (do your normal usage as ussual) and then charge it back to 100%

For healthy battery life don't let it drain lower than 10% it's the li-ion physics and always charge it fully, don't charge from 0 to 30-50-60% because the ions in the battery will not have a good flow.
Everything has it's lifespan but if it's configured and used properly it can have a long lifespan

Also to mention, if my recommendation doesn't work, your battery could be swolen due to inproper charging / heavy oc-ing or your charger is messed up.
Also to say, that flickering occured to me when i flashed a new rom and when i do lot of reboots, then the batterystats freak out, the voltages also and also your phone.

Charhe and use it properly, try to stay with a rom at least a couple of days to see how it'll go.

Sent from my pebble blue scoobie doo using Tapatalk.

Yea, I will try to calibrate my battery to see if it helps
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes