Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,801 Members 39,936 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Speaker is making a loud hiss [AOSP 4.4.4 v0.8]

Tip us?
 
adrielrsilva
Old
(Last edited by adrielrsilva; 30th July 2014 at 06:26 PM.) Reason: Add more information
#1  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jul 2014
Default [Q] Speaker is making a loud hiss [AOSP 4.4.4 v0.8]

I'm using AOSP 4.4.4 v0.8 ROM in my i9295 and I'm having trouble during calls. The speaker is making a loud hiss. Please, anyone know how to solve?

Thanks.

-------------------------------------------

I tested other ROMs CM based and all have the same problem.
 
adrielrsilva
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jul 2014
Please, does anyone have any idea? I tested several ROMs and all have the same problem.

I installed the update for recording calls. After that the speaker is permanently muted, and i can't make calls.
 
Code4U
Old
#3  
Code4U's Avatar
Member
Thanks Meter 81
Posts: 77
Join Date: Aug 2014
You may need to move sound files from stock over to your cm rom. Not sure how different they are. Sounds exactly like the problem lies in there.
 
6783
Old
#4  
6783's Avatar
Senior Member
Thanks Meter 35
Posts: 154
Join Date: May 2011
Location: Uzhgorod
I had same situation. Woth baseband ne5 the troble is gone. if i use another baseband the problem appears.

Sent from my GT-I9295 using XDA Premium 4 mobile app

---------- Post added at 07:52 PM ---------- Previous post was at 07:51 PM ----------

So flash ne5 stock via odin, then install recovery and flash custom rom. It helped for me.

Sent from my GT-I9295 using XDA Premium 4 mobile app
 
adrielrsilva
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jul 2014
Quote:
Originally Posted by 6783 View Post
I had same situation. Woth baseband ne5 the troble is gone. if i use another baseband the problem appears.

Sent from my GT-I9295 using XDA Premium 4 mobile app

---------- Post added at 07:52 PM ---------- Previous post was at 07:51 PM ----------

So flash ne5 stock via odin, then install recovery and flash custom rom. It helped for me.

Sent from my GT-I9295 using XDA Premium 4 mobile app
Thanks for the response. Please post the link to download the NE5 stock ROM you used. I'm not sure I found the correct ROM.

Thanks for your help.
 
adrielrsilva
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jul 2014
Quote:
Originally Posted by Code4U View Post
You may need to move sound files from stock over to your cm rom. Not sure how different they are. Sounds exactly like the problem lies in there.
Thanks for the response. I do not know how to do this. Have some post on forum about it?
 
adrielrsilva
Old
#7  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Jul 2014
Please, don't forget me...
 
Code4U
Old
#8  
Code4U's Avatar
Member
Thanks Meter 81
Posts: 77
Join Date: Aug 2014
Quote:
Originally Posted by adrielrsilva View Post
Please, don't forget me...
My bad bro. Try this! Take snd_soc_msm folder from etc on a stock rom. Drop that whole folder in your rom. That should fix it.
Also replace whatever file you used for call record.
The Following User Says Thank You to Code4U For This Useful Post: [ Click to Expand ]
 
setjlle
Old
#9  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Aug 2011
Quote:
Originally Posted by adrielrsilva View Post
I'm using AOSP 4.4.4 v0.8 ROM in my i9295 and I'm having trouble during calls. The speaker is making a loud hiss. Please, anyone know how to solve?

Thanks.

-------------------------------------------

I tested other ROMs CM based and all have the same problem.
Same issue here with my I9295
Testing "Google Edition for SGS4A (int'l) 0.9.6" and "Carbon Rom 4.4.4"
Both runs great but it's impossible to make calls due to a loud hiss
I tried to flash stock modem back... no change
Restoring Stock 4.4.2 now

Any ideas?
 
setjlle
Old
#10  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Aug 2011
Quote:
Originally Posted by Code4U View Post
My bad bro. Try this! Take snd_soc_msm folder from etc on a stock rom. Drop that whole folder in your rom. That should fix it.
Also replace whatever file you used for call record.
I tried this and it gave me a bootloop. Tried again changing the permitions from all files inside this folder to rw- r-- r-- and it worked!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes