Welcome to the New XDA-Developers Portal!

You may recall that a few weeks ago, we opened up the XDA-2015 forum themesto intrepid users … more

An Android Enthusiast’s Apple iPhone 6 Challenge

The media has gone batty again over Apple “revolutionizing” smartphones. … more

Sony to Extend its AOSP Program to Other Devices

Sony will be offering its users the possibility to use AOSP ROMs as an alternative to the … more

Project Ara: Modified Android L and Hot Swapping

Project Ara is a very exciting topic–both for hardware and software enthusiasts. The … more
Post Reply

[Q] Speaker is making a loud hiss [AOSP 4.4.4 v0.8]

30th July 2014, 01:42 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jul 2014
I'm using AOSP 4.4.4 v0.8 ROM in my i9295 and I'm having trouble during calls. The speaker is making a loud hiss. Please, anyone know how to solve?

Thanks.

-------------------------------------------

I tested other ROMs CM based and all have the same problem.
Last edited by adrielrsilva; 30th July 2014 at 06:26 PM. Reason: Add more information
1st August 2014, 07:01 PM   |  #2  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jul 2014
Please, does anyone have any idea? I tested several ROMs and all have the same problem.

I installed the update for recording calls. After that the speaker is permanently muted, and i can't make calls.
9th August 2014, 05:28 PM   |  #3  
Code4U's Avatar
Member
Thanks Meter: 89
 
93 posts
Join Date:Joined: Aug 2014
You may need to move sound files from stock over to your cm rom. Not sure how different they are. Sounds exactly like the problem lies in there.
9th August 2014, 07:52 PM   |  #4  
6783's Avatar
Senior Member
Flag Uzhgorod
Thanks Meter: 37
 
160 posts
Join Date:Joined: May 2011
I had same situation. Woth baseband ne5 the troble is gone. if i use another baseband the problem appears.

Sent from my GT-I9295 using XDA Premium 4 mobile app

---------- Post added at 07:52 PM ---------- Previous post was at 07:51 PM ----------

So flash ne5 stock via odin, then install recovery and flash custom rom. It helped for me.

Sent from my GT-I9295 using XDA Premium 4 mobile app
10th August 2014, 03:19 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by 6783

I had same situation. Woth baseband ne5 the troble is gone. if i use another baseband the problem appears.

Sent from my GT-I9295 using XDA Premium 4 mobile app

---------- Post added at 07:52 PM ---------- Previous post was at 07:51 PM ----------

So flash ne5 stock via odin, then install recovery and flash custom rom. It helped for me.

Sent from my GT-I9295 using XDA Premium 4 mobile app

Thanks for the response. Please post the link to download the NE5 stock ROM you used. I'm not sure I found the correct ROM.

Thanks for your help.
10th August 2014, 03:26 PM   |  #6  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by Code4U

You may need to move sound files from stock over to your cm rom. Not sure how different they are. Sounds exactly like the problem lies in there.

Thanks for the response. I do not know how to do this. Have some post on forum about it?
19th August 2014, 12:10 AM   |  #7  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jul 2014
Please, don't forget me...
19th August 2014, 04:18 PM   |  #8  
Code4U's Avatar
Member
Thanks Meter: 89
 
93 posts
Join Date:Joined: Aug 2014
Quote:
Originally Posted by adrielrsilva

Please, don't forget me...

My bad bro. Try this! Take snd_soc_msm folder from etc on a stock rom. Drop that whole folder in your rom. That should fix it.
Also replace whatever file you used for call record.
The Following User Says Thank You to Code4U For This Useful Post: [ View ]
4th September 2014, 04:30 PM   |  #9  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Aug 2011
More
Quote:
Originally Posted by adrielrsilva

I'm using AOSP 4.4.4 v0.8 ROM in my i9295 and I'm having trouble during calls. The speaker is making a loud hiss. Please, anyone know how to solve?

Thanks.

-------------------------------------------

I tested other ROMs CM based and all have the same problem.

Same issue here with my I9295
Testing "Google Edition for SGS4A (int'l) 0.9.6" and "Carbon Rom 4.4.4"
Both runs great but it's impossible to make calls due to a loud hiss
I tried to flash stock modem back... no change
Restoring Stock 4.4.2 now

Any ideas?
5th September 2014, 06:27 PM   |  #10  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Aug 2011
More
Thumbs up
Quote:
Originally Posted by Code4U

My bad bro. Try this! Take snd_soc_msm folder from etc on a stock rom. Drop that whole folder in your rom. That should fix it.
Also replace whatever file you used for call record.

I tried this and it gave me a bootloop. Tried again changing the permitions from all files inside this folder to rw- r-- r-- and it worked!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes