Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,809,862 Members 45,076 Now Online
XDA Developers Android and Mobile Development Forum

Can't charge with OEM Adaptor, Only with USB to PC

Tip us?
 
crazy_dr0id
Old
#1  
crazy_dr0id's Avatar
Senior Member - OP
Thanks Meter 24
Posts: 105
Join Date: Nov 2012
Default Can't charge with OEM Adaptor, Only with USB to PC

I'm having a charging issue and am lost on what else to try to fix this. I can't charge using my OEM adaptor and cable, only when connected to PC with USB. The USB cable that works with my PC is the same one I use with the adaptor.

The USB port is on my phone is good, charges fine when connected to PC (although much slower because of different mVS). Read a suggestion to make sure the tab part of the USB connector isn't bent, it doesn't look damaged at all and like I said, has zero problems connecting to my laptop.

Have tried almost everything except going back to stock, and nothing fixes it. I've turned debugging mode off and back on, restored a backup from before the issue began, completely wiped and reinstalled 2 different build of ROMs with and without apps, fixed permissions, tried different kernels, different USB cables...

The adaptor is in good condition. But when plugged in while my phone is on, it doesn't recognize that's it's connected. Previously it would give a false charging reading. If my device is off, sometimes I would get the grey bar battery, but now it's just vibrating every few seconds. Idk what to do...
 
crazy_dr0id
Old
#2  
crazy_dr0id's Avatar
Senior Member - OP
Thanks Meter 24
Posts: 105
Join Date: Nov 2012
I have an i337m and am currently running slimkat weekly 6.2 but tried official 6.0 and restored a weekly 5.9 from before the issue began
 
crazy_dr0id
Old
#3  
crazy_dr0id's Avatar
Senior Member - OP
Thanks Meter 24
Posts: 105
Join Date: Nov 2012
I did format /data and /data/media (internal sdcard) I think right before the issue began in order to remove some old folded that would appear during cwm installations of zips from internal storage (e.g., hyperdrive for ex, which I haven't had installed since December) but that shouldn't screw up charging at all
 
jd1639
Old
#4  
jd1639's Avatar
Recognized Contributor
Thanks Meter 3,349
Posts: 9,831
Join Date: Sep 2012
Location: Minnetonka, MN
Dude, you're trying way to hard. You're charger is messed up

Sent from my Nexus 5 using XDA Free mobile app
 
crazy_dr0id
Old
#5  
crazy_dr0id's Avatar
Senior Member - OP
Thanks Meter 24
Posts: 105
Join Date: Nov 2012
I hope that's the case lol it worked for a bit last night until I unplugged it, then when I plugged it back in nothing happened... seems to only work if power cycled after being connected to my PC
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes