Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Thought I fixed a bad flash, still having trouble

OP remedee

27th August 2014, 05:33 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Aug 2012
Sorry if this belongs in the stupid question thread, I just have no idea what went wrong, or why I'm still having problems. I've had my S4 for a while now, and it's been rooted pretty much the entire time. I wasn't aware of the auto update when I first got the phone, so before I had a chance to root it, I was updated from MLD to MK2. This wasn't a problem because SafeRoot had recently been released. I was never really concerned with voiding my warranty, and up until recently, never had. I later upgraded to NB1/NC1 to test out some of the KitKat ROMs.

I've flashed dozens of different ROMs, and several different recovery apps. The worst thing to come from my tinkering was the "Custom" logo on boot. Never tripped Knox, never soft-bricked, etc... Until recently.

I was browsing around the
[INDEX]All things AT&T MK2, NB1, and NC1 (including ROMs)
thread and found a few ROMs I hadn't tried before. I don't remember specifically which ROM it was, but it definitely had an Aroma installer. During the installation there was a warning that my warranty would be void. Having been warned about voiding my warranty in virtually every ROM thread, I didn't really think much of it. I did my usual flashing of the ROM, flashed the NC1 modules, then SuperSU 2.0 just in case. I've performed the same steps numerous times. Unfortunately this time when I rebooted, everything went haywire.

I got the unauthorized software message, Knox had been tripped, and I'm pretty sure I had the yellow triangle, along with everything else that comes with a semi-brick.

I don't remember all of the details because it's been a couple of weeks now, but I used Odin to get back to NB1 stock, and since then I've had trouble with sending/receiving texts, and sometimes calls. It's really strange because there is no indication that it's stopped sending or receiving. I have to reboot the phone several times per day in order to get the signal back. I know that when I originally restored to stock, I used the NB1 stock file for Odin, then flashed the NC1 update, rooted and installed ShoStock. I kept having data/mms connectivity problems, but wifi was never an issue, so I thought it may have been the NC1 modules or something. I've tried several different variations of ROMs, modules, APN settings, etc. but even with a full return to stock, I'm still losing the ability to send/receive texts at seemingly random times.

I guess my question is, could I have flashed a modem or something in Aroma that is still sticking around somehow, even after using Odin to get back to stock? One of the ROMs I flashed was for the i9505, and it seemed to run fine, the phone was identified as an i9505, but adjusting the APN settings allowed it to work properly on AT&T. IIRC, that was the ROM I was using prior to the issues (Echoe).

I'm currently on the stock NB1 ROM and haven't taken the OTA update yet because it didn't seem to help the last time. I have no idea if anyone here has any insight into why this is so sporadic, but it's driving me nuts so I'm asking for help before I toss it out the window My apologies if I've left out some info. I'll be happy to provide any details I can. I'm just at work and having to type this up in a bit of a hurry. Thanks for reading, and any suggestions you all may have.
Last edited by remedee; 27th August 2014 at 05:46 PM. Reason: Edit to include Safestrap 3.72 is the primary recovery I've been using.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes