FORUMS

Index Project For XDA Device Subforums

Another ambitious project from the collaborative efforts of Recognized Contributors and Forum … more

The Atlas of XDA

A few weeks ago, we asked you “How Does Your Location Affect Your Life As A Power User?”. In the days that … more

New Snapdragons: Some Context & Contrast

It hasn’t been a good year for Qualcomm so far. Every device featuring the Snapdragon 810 … more

Google To Launch Next Gen Android One On July 14

The first gen of Android One devices to be launched in India in September 2014 were … more

[Q] Galaxy S4 - No Audio during calls, other person receives white noise.

3 posts
Thanks Meter: 0
 
By jade77angel, Junior Member on 20th August 2014, 01:09 PM
Post Reply Subscribe to Thread Email Thread
Hello,

I have a galaxy S4 (canadian version) and have only been having troubles with it within the last couple days. I do develop so I'm not new when it comes to phones but this issue has me at a lose.

Problem:
When I make or receive a phone call there is absolutely no audio on my end, I cannot hear the dial tones or the other person's voice. The only thing I can here is the call connect and disconnect beeps. The person on the other end hears a very loud buzzing/white noise. This noise becomes intermittent slightly when I speak into the problematic device.
It is only when making/receiving a phone call that the audio does not work. All speakers are functioning in all other apps (music player/skype etc.) the mic is also working without a problem when used for other apps.

When the problem first started I was running 4.2.2 firmware. I was making a phone call when the audio cut out unexpectedly having assumed it was a dropped call I made an other attempt but there was no sound at all. I restarted the device and that very briefly fixed the issue. However every time since restarting the phone has done nothing.

WiFi is working fine as well.


Attempts at Solutions:

Restarting the device (with headphone connected and without)
Factory resetting the device (with headphone connected and without)
Flashing updated (and older) stock firmware on to the device
Flashing custom ROMs on to the device
Dialer apps
SoundAbout app
Making calls with headphone connected / speaker phone
All settings have been checked to ensure in call volume has not been disabled

About Device:Currently running: Gummy version M1.02-25-14-NIGHTLY (Please note that when the phone first started messing up I was running stock 4.2.2 and there was no audio during a call between either phone. The Gummy ROM has made some improvement)
Current android version: 4.4.2
Phone Model #: SGH-I337M (Canadian S4)
Baseband version: I337MVLUAMDJ



Any help is appreciated!
Thank-you
 
 
27th August 2014, 03:02 AM |#2  
Senior Member
Thanks Meter: 71
 
More
I'm having a similar issue with my ATT SGS4. It started happening randomly...the person on the other end hears beeps and I hear nothing. Speaker/headset with mic don't work either. Only thing that works is Bluetooth oddly enough...but as soon as I switch to speaker, it goes back to not working.

A reboot fixes it temporarily, but then it comes back randomly..either right away or later on in the day.
27th August 2014, 08:21 PM |#3  
saj222's Avatar
Senior Member
Flag Greater Vancouver Area, British Columbia
Thanks Meter: 150
 
More
If Bluetooth works fine for voice calls then I would guess that it's a physical hardware issue. Perhaps the ADC / DAC for onboard mic and headset is malfunctioning?

For Bluetooth I would also guess that A to D conversion happens within the Bluetooth chip which seems to be working fine.

It would be nice to see a schematic.

Edit: I found a block diagram of the circuit. and this link https://www.ifixit.com/Teardown/Sams...Teardown/13947

So it looks like the audio codec goes straight into the modem but the Bluetooth goes through the Snapdragon CPU before going to the modem. Based on this my original assumption seems to be correct and your mic codec is malfunctioning or there is a physical connection problem.

Hope this helps in any way.
Attached Images
File Type: jpg I9505 block diagram.JPG - [Click for QR Code] (153.7 KB, 117 views)
Last edited by saj222; 27th August 2014 at 09:35 PM. Reason: added picture
29th September 2014, 11:22 PM |#4  
Senior Member
Thanks Meter: 71
 
More
Does this explain why a restart fixes the issue though? If it were solely a connection/hardware issue, a restart wouldn't do crap (unless it re-initializes the circuit and then something causes it to go derp again).

Quote:
Originally Posted by saj222

If Bluetooth works fine for voice calls then I would guess that it's a physical hardware issue. Perhaps the ADC / DAC for onboard mic and headset is malfunctioning?

For Bluetooth I would also guess that A to D conversion happens within the Bluetooth chip which seems to be working fine.

It would be nice to see a schematic.

Edit: I found a block diagram of the circuit. and this link https://www.ifixit.com/Teardown/Sams...Teardown/13947

So it looks like the audio codec goes straight into the modem but the Bluetooth goes through the Snapdragon CPU before going to the modem. Based on this my original assumption seems to be correct and your mic codec is malfunctioning or there is a physical connection problem.

Hope this helps in any way.

10th October 2014, 03:37 PM |#5  
Junior Member
Thanks Meter: 0
 
More
Same thing happened to me, the incall audio chip as gone bad. I had to buy a S4 with a cracked screen off craigslist and swap mother boards and the phone works perfectly now.
1st March 2015, 09:15 PM |#6  
Junior Member
Thanks Meter: 2
 
More
SOLUTION: Samsung Galaxy S4 I337 no audio sound during phone call.
SOLUTION: Samsung Galaxy S4 I337 no audio sound during phone call.

For me it was a bad SIM Card Reader or Module IF. But it could be a bad SIM card so try a new SIM before doing this repair or at least take it out and in.

My Service Repair Statement said it replaced two things:
Part Number Description
GH59-13279A Unit-SIM SD SOCKET; SGH-I377, 10-0013-0278
GH59-13111A MODULE-IF SUB FPCB(SGH-I337);SGH-I337,10

Called 800-726-7864 told them what the symptoms were and that the support line said it was the SIM Card Reader and they gave me a quote of $70.36 and seemed confident that the phone would be fixed. Sent to Samsung Repair Facility in Texas, total cost $70.36, and was without it for 9 days. Itís been working for 2 weeks now with no problems.

First I took it to an AT&T Service Center and all they really did was try a new SIM Card, next called Samsung Service 888-987-4357 and went thru a series of tests and they said it was a bad SIM card reader and gave me the repair center number.

Symptoms:
No audio / sound during a phone call on either side (caller or receiver)
Call connects everything is working, just no sound.
Sound for all other functions and apps works (music, voice recording, video audio).
You can tell it is going to happen when you make a call and you donít hear any ringing just a click sound then nothing. If you hear ringing then the call will work.
Rebooting usual works for a call or two. Messing with some settings may get it to work for a period of time. But for me none of any of the other suggested fixes worked except rebooting and turning airplane mode on and off but it only fixed it for awhile.

I have used the phone for 1.5 years and never had a single hardware problem, didnít have it heavily loaded (RAM or Memory). It just started one day out of the blue and drove me crazy.

Quote:
Originally Posted by jade77angel

Hello,

I have a galaxy S4 (canadian version) and have only been having troubles with it within the last couple days. I do develop so I'm not new when it comes to phones but this issue has me at a lose.

Problem:
When I make or receive a phone call there is absolutely no audio on my end, I cannot hear the dial tones or the other person's voice. The only thing I can here is the call connect and disconnect beeps. The person on the other end hears a very loud buzzing/white noise. This noise becomes intermittent slightly when I speak into the problematic device.
It is only when making/receiving a phone call that the audio does not work. All speakers are functioning in all other apps (music player/skype etc.) the mic is also working without a problem when used for other apps.

When the problem first started I was running 4.2.2 firmware. I was making a phone call when the audio cut out unexpectedly having assumed it was a dropped call I made an other attempt but there was no sound at all. I restarted the device and that very briefly fixed the issue. However every time since restarting the phone has done nothing.

WiFi is working fine as well.


Attempts at Solutions:

Restarting the device (with headphone connected and without)
Factory resetting the device (with headphone connected and without)
Flashing updated (and older) stock firmware on to the device
Flashing custom ROMs on to the device
Dialer apps
SoundAbout app
Making calls with headphone connected / speaker phone
All settings have been checked to ensure in call volume has not been disabled

About Device:Currently running: Gummy version M1.02-25-14-NIGHTLY (Please note that when the phone first started messing up I was running stock 4.2.2 and there was no audio during a call between either phone. The Gummy ROM has made some improvement)
Current android version: 4.4.2
Phone Model #: SGH-I337M (Canadian S4)
Baseband version: I337MVLUAMDJ



Any help is appreciated!
Thank-you

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes