Exclamation [Q] CM11 WiFi doesn't connect

Hi there, my first post.

I've used arco68's guide to root my S4 mini LTE (serranoltexx) and flashed the CyanogenMod 11 M9 snapshot (cm-11-20140804-SNAPSHOT-M9-serranoltexx.zip), but the WiFi isn't working properly. Sometimes it connects (very rarely), but most of the time it just says "Connecting", "Authenticating..." and then goes back to say "Saved, secued with WPA" and the process repeats again.

I've tried flashing the following ROMs, but the WiFi isn't working properly on either of them:
  • cm-11-20140804-SNAPSHOT-M9-serranoltexx.zip (current)
  • cm-11-20140708-SNAPSHOT-M8-serranoltexx.zip
  • cm-11-20140813-NIGHTLY-serranoltexx.zip

Other things I've tried so far:
  • Using CM File Manager to delete contents of /data/misc/wifi and rebooting, as described here, but it didn't help.
  • Installed SQLite Debugger, went to Settings Storage > setttings.db > Global, where I wanted to change the value of wifi_display_on to 0 as described here, but it was already set to 0, so no luck here.
  • Changed the Region Code in WiFi settings (as described here) to United States, then to Europe, but this didn't help either.
  • Installed the latest nightly update, but still nothing.

Basically, I've tried everything I could find, but the WiFi still doesn't work, and I have no idea why. I don't want to downgrade to CM 10.2, since later when I decide to upgrade to CM 11, I'd need to wipe all the data and make a clean CM11 install. Also, I don't want to flash any other ROM except CM, so telling me to install Paranoid Android or anything else wouldn't help.

If you have any ideas how to solve this, that would be great! Also, feel free to ask for any additional details.

Update: I've just discovered that it connects to open WiFi networks without any problems (though I've only tried it on 2 so far), so probably WPA encryption or my old home router can be the cause of the problem. I can only change my home router to WPA (it doesn't work with WPA2), so I've yet to try it on another router supporting WPA2. If that works, it would solve the whole problem! I'm ashamed to say I haven't thought of this earlier...

Update 2: I just tested it on a WPA2-protected WiFi network and it connects without problems. The most likely conclusion seems that CM11 has some problem with WPA, so for the time being I'll switch to another router with WPA2. Hopefully gets fixed with the next snapshot!