HTC Delivering Ads Straight to Sense Home

HTC’s 2015 has been a year marked by a desperate search for revenue.The HTC One M9 … more

Galaxy S6 & Edge get €100 Price Cut—New Models Incoming

Samsung has dropped the price of both the Galaxy S6 and S6 Edge by … more

How To Port Fully Featured Sony Xperia Z4 Camera

Xperia Z4’s hardware may not impress, but its software is definitely … more

Experimental TWRP Available For Moto G 2015

XDA Senior Member squid2 has posted experimental builds of TWRP for the Moto G … more

GT-I9195 compass not working properly, possibly magnetometer issue

135 posts
Thanks Meter: 20
By marchrius, Senior Member on 28th August 2014, 11:37 PM
Post Reply Subscribe to Thread Email Thread
Hi everyone. Compass is stuck in my s4 mini. From sensor test (*#0*# then sensors) I can see this (see attachment). It seems like magnetometer is not calibrated. Any way to calibrate it (apart from usual methods like 8 figure or rotate phone around tre axis since I already tried them and they didnt worked) or reset it to stock values? Tried factory reset too.

thanks a lot guys.. I really need help, It may be an hardware issue but I want to try everything via software before send it to sammy
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-08-28-23-01-07.png
Views:	141
Size:	80.4 KB
ID:	2916085   Click image for larger version

Name:	Screenshot_2014-08-28-23-00-06.png
Views:	142
Size:	27.9 KB
ID:	2916086  
29th August 2014, 10:02 AM |#2  
OP Senior Member
Thanks Meter: 20
Please help guys, tried wipe cache and dalvik cache too. Send phone to samsung is the last thing I want to do due to my knox 0x1.
30th August 2014, 11:30 AM |#3  
Ruwy's Avatar
Junior Member
Thanks Meter: 2
I have the same problem. I have tried to rotate phone along his three axis, while in sensor screen. Phone vibrate and light green during this operation and "need calibration " disappeared... Now only number "3" is displayed.
30th August 2014, 02:23 PM |#4  
OP Senior Member
Thanks Meter: 20
Unfortunately, I tried calibration in sensor screen too but nothing happens. Always "need for calibration 0".
2nd September 2014, 11:44 AM |#5  
OP Senior Member
Thanks Meter: 20
Solved reflashing the whole firmware with odin... calibration now works.
5th September 2014, 04:35 PM |#6  
OP Senior Member
Thanks Meter: 20
Found out that the problem was the kernel. As soon as I flash a kernel different from the stock one, compass get stuck. On stock rom and JB at least... be careful.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes