Updated Android Lollipop Preview Images – XDA TV

The Android Lollipop Preview Images are now available! That and much more news is … more

Get a Complete Set of Logs with Andy Log

The importance of proper logging is undeniable. No, we’re not talking about lumberjack work. … more

Try Some Android Lollipop Applications on Your Device

Android 5.0 Lollipop has been officially announced and lucky users of Google Nexus 5 … more

AutoCon Manages Your Connections to Perserve Battery Life

As we’ve talked about in the past, battery life is still somewhat of a sore … more
Post Reply

[Q] S4 mini 9192 not switching data between sims correctly

OP fmohiy

19th October 2013, 05:12 PM   |  #1  
OP Junior Member
Thanks Meter: 6
 
29 posts
Join Date:Joined: Aug 2007
i have been experiencing several problems with S4 mini 9192 since i bought it one month back and one of these is that the phone does not switch data between the 2 sims correctly.

to have the data work correctly on any sim, all the below must be done
1-select the sim you want to use for data in sim card manager/data service network
2-have the same sim configured as gsm/wcdma (auto connect) on connections/more networks/mobile networks/network mode

when you select option one, the phone tries to perform task 2 too, but fails, thus the data sim is left in "GSM only mode" and will only have edge data, never connecting to HSPA/ 3G.

here is what i have to do each time to switch data from Sim-1 to Sim-2 (screenshots attached)Screenshots.zip


Screenshot 1- you will notice data is set for sim 1 and HSPA is active
Screenshot 2- select sim 2 for data
Screenshot 3- the phone will disconnect data on sim 1 to switch
Screenshot 4-phone will try to set sim 2 as "gsm/wcdma (auto connect)"
Screenshot 5- but gives alert message and fails
Screenshot 6- sim 1 is still on "gsm/wcdma (auto connect)" and the data connection for sim 2 is only edge
Screenshot 7- Sim 2 is still on "gsm only" and does not connect on hspa no matter how long you wait
Screenshot 8- for data on sim 2 to work properly, first change sim 1 to gsm only
Screenshot 9- then change sim 2 to "gsm/wcdma (auto connect)" and wait for 5 seconds, the phone will connect on HSPA .. success

now my big question is, does this happen to everyone with s4 mini 9192, or is it just me??

by the way, this occurs on both my Egypt stock firmware and the j2 india firmware i just flashed.
The Following 2 Users Say Thank You to fmohiy For This Useful Post: [ View ]
22nd October 2013, 05:55 AM   |  #2  
OP Junior Member
Thanks Meter: 6
 
29 posts
Join Date:Joined: Aug 2007
i tested a friend's Galaxy Mega 5.8 Duos, and the phone performs both steps by itself, with no need to perform the 2nd step manually.
10th December 2013, 10:28 AM   |  #3  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Dec 2013
Quote:
Originally Posted by fmohiy

now my big question is, does this happen to everyone with s4 mini 9192, or is it just me??

by the way, this occurs on both my Egypt stock firmware and the j2 india firmware i just flashed.

I have had the same problem with my model that I bought in Australia. Your solution worked well for me as this is one frustration that I've been blaming on the network rather than the phone for the past week (because I was ignoring the error messages). I would hope a software update is in the works to fix this issue as it will get quite annoying in time.
1st January 2014, 04:01 PM   |  #4  
Kiwyxda's Avatar
Member
Flag Around Paris
Thanks Meter: 16
 
98 posts
Join Date:Joined: May 2011
I have the very same issue, plus the second sim slot only work in GPRS, and I try 4 rom before getting block by ****ing knox problem.
2nd March 2014, 09:02 AM   |  #5  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Feb 2010
Sorry to dig this out but i havent found any answer to this yet.

is there any way to get a widget or a script or anything so that one can easily switch data connection from one sim to the other by one click? Or even automatically depending on which sim is in its home network?
This would be awesome as i'm hopping across the border twice a day and switching data connection all the time is a pain in the a**.

Thanks a lot for any answers!
20th May 2014, 01:04 PM   |  #6  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: May 2014
I am also looking for answers for this.
Out on the site I work at they only have 3G towers but I have no data access on my work phone so I need to use my personal sim for checking email, then switch back so I can use work phone again.
20th May 2014, 05:30 PM   |  #7  
Senior Member
Thanks Meter: 161
 
685 posts
Join Date:Joined: Sep 2012
More
Known issue on the phone it sucks

Sent from my GT-I9192 using Tapatalk
8th July 2014, 02:30 AM   |  #8  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Mar 2012
Quote:
Originally Posted by fmohiy

i have been experiencing several problems with S4 mini 9192 since i bought it one month back and one of these is that the phone does not switch data between the 2 sims correctly.

to have the data work correctly on any sim, all the below must be done
1-select the sim you want to use for data in sim card manager/data service network
2-have the same sim configured as gsm/wcdma (auto connect) on connections/more networks/mobile networks/network mode

when you select option one, the phone tries to perform task 2 too, but fails, thus the data sim is left in "GSM only mode" and will only have edge data, never connecting to HSPA/ 3G.

here is what i have to do each time to switch data from Sim-1 to Sim-2 (screenshots attached)Attachment 2336218


Screenshot 1- you will notice data is set for sim 1 and HSPA is active
Screenshot 2- select sim 2 for data
Screenshot 3- the phone will disconnect data on sim 1 to switch
Screenshot 4-phone will try to set sim 2 as "gsm/wcdma (auto connect)"
Screenshot 5- but gives alert message and fails
Screenshot 6- sim 1 is still on "gsm/wcdma (auto connect)" and the data connection for sim 2 is only edge
Screenshot 7- Sim 2 is still on "gsm only" and does not connect on hspa no matter how long you wait
Screenshot 8- for data on sim 2 to work properly, first change sim 1 to gsm only
Screenshot 9- then change sim 2 to "gsm/wcdma (auto connect)" and wait for 5 seconds, the phone will connect on HSPA .. success

now my big question is, does this happen to everyone with s4 mini 9192, or is it just me??

by the way, this occurs on both my Egypt stock firmware and the j2 india firmware i just flashed.

Thanks for posting this, finally i can have 3g on sim2!

Post Reply Subscribe to Thread

Tags
9192, duos, s4 mini
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes