Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

I9195 Rooted device, but unable to get root access using adb shell su

OP starwars74

20th July 2014, 05:19 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jul 2014
Hi All,

I did root my device following this procedure by arco68: http://forum.xda-developers.com/show....php?t=2364980

Worked perfectly and naming few applications they are ok, like Terminal Emulator, BusyBox, ES File exploree, etc, and ran different root verifiers program which confirmed root status.

But when using adb shell su, I'm unable to get root access as you can see here

Code:
C:\Users\marco\Downloads\Android\adt-bundle-windows-x86_64-20140702\sdk\platform
-tools>adb devices
List of devices attached
08985214        device


C:\Users\marco\Downloads\Android\adt-bundle-windows-x86_64-20140702\sdk\platform
-tools>adb shell
shell@android:/ $ su
su
1|shell@android:/ $

1|shell@android:/ $

1|shell@android:/ $ id
id
uid=2000(shell) gid=2000(shell) groups=1003(graphics),1004(input),1007(log),1009
(mount),1011(adb),1015(sdcard_rw),1028(sdcard_r),3001(net_bt_admin),3002(net_bt)
,3003(inet),3006(net_bw_stats) context=u:r:shell:s0
shell@android:/ $
It does generate a new prompt adding "1|", and as soon as you execute a comand it returns to the original prompt, but never you have root access

I've been researching across, but unable to find something similar.
All the procedures for permission denied that I have found point to rooting the device which is why I already did.

I have redone the procedure in case something was wrong, but no changes.

Hope somebody knows what is happening

Thanks in advance
23rd July 2014, 07:39 PM   |  #2  
Junior Member
Thanks Meter: 0
 
23 posts
Join Date:Joined: Jul 2014
Hi,

I had this problem on terminal emulator (same when typing su) on the s4 mini rooted the same way yours is.
It occurred after I installed some apps including some google updates I installed manually - I don't know which of them caused that. But after I had this problem I realised that all apps don't have the root access anymore - SuperSU, RootChecker... And SuperSU didn't gave apps like TerminalEmulator and RootExplorer anymore root access.
This problem has been solved itself after I restarted my phone (because of another reason). And I had my rooted phone again.

So after your problem occurred - did you try another app that needs root access again? Does it have still root access? If no, try restarting too (if you haven't done that already) - maybe it helps you too...
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes