Battery Full Charging issues (solved)

purchased a new Galaxy S4, from sprint.
rooted using auto-root and installed teamwin recovery. all good. kept using the phone flawlessly for three days.
was going to flash CM10.2 through the recovery when i noticed the big button in the CyanogenMod home advertising the installer.
since this phone is compatible, then decided to try that.
CM11 installed right away and worked great, charged the phone, took a couple pictures, great.
then an update was requested to the ROM, so i installed it.
that update resets all my settings, so i started downloading all my apps and applying the settings again.
when the phone was around 18% of charge, i plugged the phone and nothing happened.
tried another phone with stock android in the same charger and everything went well fine so, i turned off the
SGS4 and plugged it again.
it vibrated once, (like it was about to start charging) but nothing happened. a few seconds later, it vibrated again, and that went on and on...
turned back on the phone in recovery, i noticed that TeamWin was replaced by ClockWorkMod recovery.
wiped Dalvik, cache and did a factory reset. turned phone back off and plugged the charger.
now it vibrates once, the screen lights up, a drained battery shows up and nothing happens, (just like it froze there).
the phone is not taking charge and its dead jim. doesn't have enough charge to power on.
havent tried anything else.

any clues or workarounds?
please and thanks.


EDIT: downgraded to CM10.2.1 and installed chronic kernel for CM10.2, problem solved.