Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,806,815 Members 39,955 Now Online
XDA Developers Android and Mobile Development Forum

[Q] NAE started loosing mobile connection & GPS?

Tip us?
 
rsngfrce
Old
#1  
rsngfrce's Avatar
Senior Member - OP
Thanks Meter 103
Posts: 368
Join Date: May 2012
Location: NorCal
Unhappy [Q] NAE started loosing mobile connection & GPS?

RELEVANT DATA: Sprint Samsung Galaxy S4, Software version: NAE, Android version: 4.4.2, Baseband version: NAE, Kernel: KT-SGS4 4.4, Recovery: PhilZ Touch 6.48.4, SuperSU. Stock Rooted. Upgraded to NAE from MF9 with the method in this link: [HOW TO]Update to 4.4.2 NAE w/Root while Keeping MF9 Bootloader w/ Lock Screen Fix, so no Knox.

Upgrade went great, it was actually the most stable phone I have ever had. Then, all of a sudden, I started loosing my mobile connection and GPS a while after booting the phone.If I reboot the phone, they start working fine again, but after an unknown amount of time, they both stop working again. WIFI never stops working. I have no idea what caused this to start happening and it REALLY SUCKS!

I did edit my APN, trying to fix an issue I was having with sending MMS's, but I'm pretty sure I restored the NAE stock version, which didn't help.

I have attach a logcat filtered at warn and higher and I tried to make a call during this logcat and was told I had no mobile connection. I really can't read these things, so I don't know if there is anything useful in there.

If anyone has any idea what might be causing my problem, I would be eternally grateful for some assistance!
Attached Files
File Type: txt no mobile connection.txt - [Click for QR Code] (51.0 KB, 8 views)
 
rsngfrce
Old
#2  
rsngfrce's Avatar
Senior Member - OP
Thanks Meter 103
Posts: 368
Join Date: May 2012
Location: NorCal
I'm becoming convincinced that I must hold some sort of record on XDA for having the greatest number of issues that nobody else has ever experienced...
*** Sprint Samsung Galaxy S4, Stock rooted Touchwiz rom, Android 4.4.2 NAE (MF9 bootloader, no Knox), SuperSU V2.01, Busybox v1.20.2-cm9, KT-SGS4 4.4 kernel, PhilZ Touch 6.48.4 recovery ***

Leave me alone, I know what I'm doing!

(except when I'm totally lost...)
 
wilzard
Old
#3  
wilzard's Avatar
Senior Member
Thanks Meter 101
Posts: 189
Join Date: Mar 2011
Location: Portland
Quote:
Originally Posted by rsngfrce View Post
I'm becoming convincinced that I must hold some sort of record on XDA for having the greatest number of issues that nobody else has ever experienced...
Sound odd. Sorry I can't help you directly.

I would suggest using Odin to flash NAE firmware only tar again.

I'm assuming you've updated PRL and Profile?
GS4 - Sacs Custom 4.3 ROM v5 / MK2 Baseband / TWRP 2.7 / MF9 bootloader
Nexus 7 2012 - SlimKat / TWRP 2.7 / m-kernel a67
The Following User Says Thank You to wilzard For This Useful Post: [ Click to Expand ]
 
cruise350
Old
#4  
cruise350's Avatar
Senior Member
Thanks Meter 588
Posts: 1,862
Join Date: Dec 2007
Location: Memphis, TN
I think you need to go full NAE tar file to fix your problems. When you do partial upgrades like you did they result in nothing but problems. If you want your phone to work everytime you use it. Flash the full NAE tar to bring your phone up to date, root it with cf autoroot, install your mods and enjoy a trouble free phone. There is nothing to worry about knox. It doesn't hamper your phone at all. Your warranty is already expired if you have a phone that has MF9 on it so update your phone and you won't have any of these problems.
Phones & Tablets: Galaxy S4, Galaxy Note 8", Evo 4g LTE, Evo 3D, Acer Iconia A500, Samsung Galaxy Tab 2 10.1, Ipad 2, Nabi 2,


Rom: Rooted Stock Odexed, Hotspot Mod, Xposed, Wanum, several other xposed tweaks
Firmware: NAE
Kernel: Stock
TWRP: 2.7.1.0

The Following 2 Users Say Thank You to cruise350 For This Useful Post: [ Click to Expand ]
 
rsngfrce
Old
#5  
rsngfrce's Avatar
Senior Member - OP
Thanks Meter 103
Posts: 368
Join Date: May 2012
Location: NorCal
I appreciate both your suggestions and will consider them. What I don't understand though would be why it would be working perfectly for a month or two and then suddenly develop the issues out of the blue? Also, I haven't seen anyone else who upgraded with this method mentioning this problem. This tends to make me think the problem lies elsewhere... possibly related, but elsewhere.

(By the way, I raised the question of why I would care about Knox if I was out of warranty and it was pointed out that once you have Knox, you can never go back to MF9... and who knows if I might decide I need to do that for some reason... I prefer to have the option at least.)
*** Sprint Samsung Galaxy S4, Stock rooted Touchwiz rom, Android 4.4.2 NAE (MF9 bootloader, no Knox), SuperSU V2.01, Busybox v1.20.2-cm9, KT-SGS4 4.4 kernel, PhilZ Touch 6.48.4 recovery ***

Leave me alone, I know what I'm doing!

(except when I'm totally lost...)
The Following User Says Thank You to rsngfrce For This Useful Post: [ Click to Expand ]
 
rsngfrce
Old
#6  
rsngfrce's Avatar
Senior Member - OP
Thanks Meter 103
Posts: 368
Join Date: May 2012
Location: NorCal
I'll tell you what is really STRANGE... right now my phone has been 17 hours since boot and both the mobile data and GPS are working... I can't remember the last time it has gone that long! Maybe my random twiddling finally fixed it...
*** Sprint Samsung Galaxy S4, Stock rooted Touchwiz rom, Android 4.4.2 NAE (MF9 bootloader, no Knox), SuperSU V2.01, Busybox v1.20.2-cm9, KT-SGS4 4.4 kernel, PhilZ Touch 6.48.4 recovery ***

Leave me alone, I know what I'm doing!

(except when I'm totally lost...)
 
rsngfrce
Old
#7  
rsngfrce's Avatar
Senior Member - OP
Thanks Meter 103
Posts: 368
Join Date: May 2012
Location: NorCal
WELL... of course, I spoke too soon, the issue has now returned. I'm at 22 hours after boot, but I don't know when it started and I did reboot since I said it was working after 17 hours...:banghead:
*** Sprint Samsung Galaxy S4, Stock rooted Touchwiz rom, Android 4.4.2 NAE (MF9 bootloader, no Knox), SuperSU V2.01, Busybox v1.20.2-cm9, KT-SGS4 4.4 kernel, PhilZ Touch 6.48.4 recovery ***

Leave me alone, I know what I'm doing!

(except when I'm totally lost...)

Tags
failure, gps, mobile data, nae, reboot
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes