Post Reply

[Q] CyanogenMod file manager not able to switch to root access.

OP RogueSly

14th June 2013, 02:27 AM   |  #1  
OP Member
Thanks Meter: 16
 
60 posts
Join Date:Joined: May 2013
More
CyanogenMod's file manager seems to be stuck in safe mode, even though I have a rooted device and even have a modified kernel. I've not been able to figure out exactly what's happening. It says that only the accessible file systems are the storage volumes.

Anyone else have this problem, or does anyone know how to fix it?
14th June 2013, 01:57 PM   |  #2  
Nut_House's Avatar
Member
Thanks Meter: 9
 
33 posts
Join Date:Joined: Feb 2013
Quote:
Originally Posted by RogueSly

CyanogenMod's file manager seems to be stuck in safe mode, even though I have a rooted device and even have a modified kernel. I've not been able to figure out exactly what's happening. It says that only the accessible file systems are the storage volumes.

Anyone else have this problem, or does anyone know how to fix it?

The default for the CM file manager is for root access to be turned off. With the file manager open go into settings and allow root access. Once you exit settings you'll have full access.
14th June 2013, 09:12 PM   |  #3  
OP Member
Thanks Meter: 16
 
60 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by Nut_House

The default for the CM file manager is for root access to be turned off. With the file manager open go into settings and allow root access. Once you exit settings you'll have full access.

That's the problem. It won't allow root access, even though the phone has root access. The menu for the access mode is disabled.
15th June 2013, 12:02 PM   |  #4  
Nut_House's Avatar
Member
Thanks Meter: 9
 
33 posts
Join Date:Joined: Feb 2013
Quote:
Originally Posted by RogueSly

That's the problem. It won't allow root access, even though the phone has root access. The menu for the access mode is disabled.

Have you tried clearing cache and Dalvik and fixing permissions? The other thing to try, if you haven't already, is downloading the latest nightly and performing a clean install rather than dirty flashing. Good luck.
15th June 2013, 12:25 PM   |  #5  
gharlane00's Avatar
Senior Member
Flag Norwich, CT
Thanks Meter: 98
 
192 posts
Join Date:Joined: Mar 2011
More
If you accidentally refused root access the first time you have to go into the SU app and clear out the File manager permission and start over.
15th June 2013, 05:02 PM   |  #6  
OP Member
Thanks Meter: 16
 
60 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by Nut_House

Have you tried clearing cache and Dalvik and fixing permissions? The other thing to try, if you haven't already, is downloading the latest nightly and performing a clean install rather than dirty flashing. Good luck.

I've already tried installing the latest nightly version and ran a permission fix on it, but end up with the same result. I'll try clearing cache, dalvik, and then fixing again.

Quote:
Originally Posted by gharlane00

If you accidentally refused root access the first time you have to go into the SU app and clear out the File manager permission and start over.

The file manager doesn't have any permissions in SuperSU and never asks for any since it's not in root access mode. :\
Last edited by RogueSly; 15th June 2013 at 05:05 PM.
15th June 2013, 05:09 PM   |  #7  
OP Member
Thanks Meter: 16
 
60 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by Nut_House

Have you tried clearing cache and Dalvik and fixing permissions? The other thing to try, if you haven't already, is downloading the latest nightly and performing a clean install rather than dirty flashing. Good luck.

Yeah, still the same result. Clearing dalvik and cache didn't work.
16th June 2013, 07:38 PM   |  #8  
Senior Member
Thanks Meter: 61
 
438 posts
Join Date:Joined: Jul 2009
Just grab es file explorer.

Sent from my SPH-L720 using xda app-developers app
14th July 2013, 07:20 PM   |  #9  
Senior Member
Thanks Meter: 26
 
272 posts
Join Date:Joined: Feb 2012
Quote:
Originally Posted by RogueSly

Yeah, still the same result. Clearing dalvik and cache didn't work.

same problem.
tried to install supersu, reinstall busy box on bin and xbin, fix permissions, no luck, option still greyed out.
file manager always worked for me as root, both on cm-based ROMs and aosp.
this time it is not working with the combo saberMod and matrix on N4.
(i think this is a device-independent issue)

---------- Post added at 08:20 PM ---------- Previous post was at 08:07 PM ----------

After a lot of tentatives I solved it.
I am not 100% sure of which change made it though
I think it was by using ES root manager and resetting system as R/W.

Sent from my Nexus 4 using xda app-developers app
9th September 2014, 11:24 PM   |  #10  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Sep 2014
Alternate fix
I also had the same issue and resolved it by tapping the menu button on the top left corner. when you do this, another menu button appears in the top right corner. Hit that, then settings, and choose root mode. Took me a while to figure out!!!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes