Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,807,656 Members 52,324 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Odin says "PASS" but root checker says "not rooted"..HELP!

Tip us?
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jul 2014
Default [Q] Odin says "PASS" but root checker says "not rooted"..HELP!


I signed up just to get help because I'm extremely frustrated.I have gotten the Kit Kat update for my t-mobile s4 and now I can't root my phone again. I have tried to root my phone using Chainfire Auto root md5 file (jfltetmo-sghm919.tar.md5) & Odin 3.09. I have follow the simple directions as I'm done several times before to flash the root files onto my phone then Odin tells me that it passed. but when i tested with root checker app, the app along with other apps that request superuser permissions, tells me that my device is not rooted. I have tried to root my phone several times using different computers and I have no clue why my phone will not root. in download mode my device states that the knox void has been tripped & the binary is custom. this leaves me scratching my head please help!
Kriptik210's Avatar
Senior Member
Thanks Meter 111
Posts: 411
Join Date: May 2013
Location: Crystal River
What firmware is on your phone?

Sent from my SGH-M919 using XDA Premium 4 mobile app
.............Sent from an A.I. frequency.............
serio22's Avatar
Senior Member
Thanks Meter 695
Posts: 2,167
Join Date: Jul 2012
Location: Houston
Have you updated the binary? You could also try using towel root
Skipjacks's Avatar
Recognized Contributor
Thanks Meter 3,839
Posts: 4,853
Join Date: Nov 2011
Location: Baltimore
Try downloading a recovery from CWM or TWRP in TAR format and flashing that in Odin.

That will give you a custom recovery.

Then boot into recovery and flash a from there. (If you use TWRP recovery you don't even need the TWRP will tell you that you aren't rooted when you boot it and ask it you want TWRP to root it for you.)
Do you want insanely better battery drain when your phone is idle? Check out this thread!
Have a question about the T Mobile Samsung Galaxy S4? Click here for the Help Thread!
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jul 2014

Thanks for all the responses... I solved it.. somehow my update for kit-kat via kies prevented me from rooting my phone again. But when I flashed the stock kit-kat update onto my phone using odin, the rooting process using the auto root file from chainfire & odin work! So this solution may work for others...
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes