Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,810,194 Members 52,023 Now Online
XDA Developers Android and Mobile Development Forum

SGH-M919. NB4 Stock. No in-call Audio. Please Help!

Tip us?
 
Trigz671
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Jul 2012
Exclamation SGH-M919. NB4 Stock. No in-call Audio. Please Help!

I'm working with a T-Mobile Samsung Galaxy S4 SGH-m919. I am currently on a NB4 Firmware. w NB4 Baseband. Knox Tripped. I went thru a series of Upgrading amd Downgrading via Odin and Kies to get the phone to the status it is now. I have smooth working handheld. The only problem is that I do not have any in call audio. It makes the dialing sound on the dialer and a beep noise to notify that the call goes thru but nothing on the earphone. The call does go thru but silence on both ends. I dont believe its a hardware problem because I ran the test on the Earphone via dialer code. and it made sounds. I managed to make other sounds come out thru the earphone via market apps. Also the microphone does not work using stock apps like google voice, S Voice , Voice Search and Voice Recorder. However, i downloaded a voice recordrr app on Market with the ability to pick which microphone to record from and the bottom mic was recording flawlessly like the camera mic. Is this a software, firmware, rom, radio?, modem? problem. i had no sounds for a while till i flashed the nb4 modem and nonhelos.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-08-14-21-55-48.png
Views:	12
Size:	237.8 KB
ID:	2897659   Click image for larger version

Name:	Screenshot_2014-08-14-21-55-20.png
Views:	8
Size:	224.7 KB
ID:	2897660  
 
Trigz671
Old
(Last edited by Trigz671; 15th August 2014 at 02:04 AM.)
#2  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Jul 2012
Prompt More Info:

heres more phone info.

wait exceeded upload. ima upooad pics somewhere else.

but, yes skype viber fb other voip works
 
lalec
Old
#3  
Senior Member
Thanks Meter 94
Posts: 409
Join Date: Apr 2008
Location: Houston, Texas
Was Kies the most recent thing you did to get to where you are now? If not, use it to repair your phone. You probably inadvertently caused the problem when you tried to downgrade to an older bootloader and LTE radio after the phone already had 4.4.x on it. If you used Odin and flashed the wrong files that would happen.
 
Gizmokid2005
Old
#4  
Member
Thanks Meter 1
Posts: 33
Join Date: Dec 2011
Location: 432′23″N 8555′48″W

 
DONATE TO ME
I was going to start a thread to say largely the same thing. I rooted and flashed TWRP. Made a backup of stock rooted. Flashed some other roms include The Sickness' S5 V3 rom, but ultimately reflashed to stock. My phone audio works for about 2 days and then just...doesn't. Hangouts voice is seriously messed up at that point, I can hear the other end fine, but my mic goes out like a crackly high-pitched & sped up chipmunk voice.
Thread Tools
Display Modes