Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,808,781 Members 48,408 Now Online
XDA Developers Android and Mobile Development Forum

[Q] No Wi-Fi after TWRP restore??

Tip us?
 
OldMage
Old
#1  
OldMage's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Oct 2010
Location: PDX/Vanc,WA area
Exclamation [Q] No Wi-Fi after TWRP restore??

I'll try to boil this down as much as possible... Bought a used M919 on Craigslist, it was an original MDL 4.2.2 build. I rooted, loaded Fenny's 4.4.2 ROM, had it all going great, then it got blacklisted for unpaid device balance...

Just bought a refurb direct from T-Mo, of course it's NB4 4.4.2. I did TowelRoot, installed current TWRP, restored Data & System, got stuck at the T-Mobile animation screen (so long the phone was getting hot). Flashed back to Fenny's fixed original 4.4.2 ROM, it booted fine, had Wi-Fi & LTE signal, did TowelRoot, installed TWRP again, restored ONLY Data...

Phone boots & runs fine, makes/receives calls & SMS/MMS but I have no Wi-Fi (won't successfully turn on). Also, I'm constantly getting a "Security Notice" saying "Unauthorized actions have been detected. Restart your phone to undo any unauthorized changes."

What gives? I've tried re-flashing the separate modem files, but it doesn't help.
Ideas please?
 
lordcheeto03
Old
#2  
lordcheeto03's Avatar
Senior Member
Thanks Meter 536
Posts: 1,530
Join Date: Aug 2012
Location: ( ͡ ͜ʖ ͡)
Quote:
Originally Posted by OldMage View Post
I'll try to boil this down as much as possible... Bought a used M919 on Craigslist, it was an original MDL 4.2.2 build. I rooted, loaded Fenny's 4.4.2 ROM, had it all going great, then it got blacklisted for unpaid device balance...

Just bought a refurb direct from T-Mo, of course it's NB4 4.4.2. I did TowelRoot, installed current TWRP, restored Data & System, got stuck at the T-Mobile animation screen (so long the phone was getting hot). Flashed back to Fenny's fixed original 4.4.2 ROM, it booted fine, had Wi-Fi & LTE signal, did TowelRoot, installed TWRP again, restored ONLY Data...

Phone boots & runs fine, makes/receives calls & SMS/MMS but I have no Wi-Fi (won't successfully turn on). Also, I'm constantly getting a "Security Notice" saying "Unauthorized actions have been detected. Restart your phone to undo any unauthorized changes."

What gives? I've tried re-flashing the separate modem files, but it doesn't help.
Ideas please?
Did you flash the WiFi fix in Fenny's thread? Have you tried a different kernel?
Don't be afraid of the "Thanks" button
The Following User Says Thank You to lordcheeto03 For This Useful Post: [ Click to Expand ]
 
OldMage
Old
#3  
OldMage's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Oct 2010
Location: PDX/Vanc,WA area
Must've missed the Wi-Fi fix somehow. Thought there were only problems when the MDL bootloader was maintained.

Yes, I'm running Fenny's kernel, 1.2 or 1.3.

Sent from my S4 using XDA Free
 
OldMage
Old
#4  
OldMage's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Oct 2010
Location: PDX/Vanc,WA area
BINGO! Wow, makes me feel like a total noob. Haven't seen the Security notice yet either.

Sent from my S4 using XDA Free
 
OldMage
Old
#5  
OldMage's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Oct 2010
Location: PDX/Vanc,WA area
I take that back, there's the security notice... :banghead:

Sent from my S4 using XDA Free
 
lordcheeto03
Old
#6  
lordcheeto03's Avatar
Senior Member
Thanks Meter 536
Posts: 1,530
Join Date: Aug 2012
Location: ( ͡ ͜ʖ ͡)
Quote:
Originally Posted by OldMage View Post
I take that back, there's the security notice... :banghead:

Sent from my S4 using XDA Free
I did a search for "Unauthorized actions have been detected" and it pulled up a couple pages for other Samsung devices. You could try doing what they all say to do; I would assume that because I've read the same solution in both the S5 forum and the Note II forum it should work for all Samsung devices... anyway, open up SuperSU and somewhere in the app there should be an option to disable KNOX. That should get rid of that warning.
Don't be afraid of the "Thanks" button
The Following User Says Thank You to lordcheeto03 For This Useful Post: [ Click to Expand ]
 
OldMage
Old
(Last edited by OldMage; 21st August 2014 at 11:28 PM.)
#7  
OldMage's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Oct 2010
Location: PDX/Vanc,WA area
Quote:
Originally Posted by lordcheeto03 View Post
I did a search for "Unauthorized actions have been detected" and it pulled up a couple pages for other Samsung devices. You could try doing what they all say to do; I would assume that because I've read the same solution in both the S5 forum and the Note II forum it should work for all Samsung devices... anyway, open up SuperSU and somewhere in the app there should be an option to disable KNOX. That should get rid of that warning.
I must be doing something wrong w/ my searches... Thanks for the slap in the right direction
We'll see if it's attitude is improved...
My S3 never gave me this much trouble... LOL! Neither did my 1st S4.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Jair Player with a Major Update–Here’s What’s New!

Back in May, we talked a bit aboutJair Player, a nice looking music … more

Paid Android App Developers Will Soon Have to Provide Physical Address

Google has now changed its policies regarding paid app developers. … more

Windows Developers Rejoice! Dev Program’s $99 Yearly Fee is No More!

Microsoft rule in the mobile market, much like the giant dinosaurs … more

Add the Xperia Z2 Lock Screen to Your Favorite KitKat ROM

Almost every OEM adds its own unique flair to their stock firmwares. While some of … more