Post Reply Subscribe to Thread Email Thread

[MOD][DEV] Enable Insecure modules on NC5 and NC1

15th September 2014, 12:29 AM |#1  
Surge1223's Avatar
OP Recognized Contributor
Flag Iowa
Thanks Meter: 5,273
 
1,949 posts
Join Date:Joined: Nov 2012
Donate to Me
More
Works on VZW and AT&T latest 4.4 kernels

Directions:

1. Flash zip
2. Open terminal and type
Code:
su
modload
Insert a a compiled and compatible module using insmod, confirm it loaded using lsmod


Download

Here's a zip of modules that work with NC5 and NC1 most made by yours truly.


https://www.dropbox.com/s/mpyeju0082...dules.zip?dl=0


Thanks to @jeboo for the original exploit, this is his exploit but using a different method of writing over memory.

If you don't know the purpose of this then don't download.
The Following 16 Users Say Thank You to Surge1223 For This Useful Post: [ View ]
15th September 2014, 01:44 AM |#2  
FordNate's Avatar
Senior Member
Flag Sacramento
Thanks Meter: 313
 
800 posts
Join Date:Joined: Oct 2012
More
Totally dont know the purpose and not too worried, but thanx Surge for not forgetting about us over here.
The Following User Says Thank You to FordNate For This Useful Post: [ View ]
15th September 2014, 02:37 AM |#3  
Member
Thanks Meter: 17
 
70 posts
Join Date:Joined: Apr 2009
Nice work, very useful.
16th September 2014, 12:55 AM |#4  
joshuabg's Avatar
Recognized Contributor
Thanks Meter: 847
 
1,504 posts
Join Date:Joined: May 2012
Donate to Me
More
Nice job! Will the safestrap your working on with kexec be posted here?

Sent from my OtterX using Tapatalk
17th September 2014, 03:11 PM |#5  
ITR218's Avatar
Member
Flag SouthCackalacky
Thanks Meter: 8
 
59 posts
Join Date:Joined: Apr 2010
More
☆☆
Last edited by ITR218; 17th September 2014 at 06:20 PM.
17th September 2014, 04:37 PM |#6  
RandumAccess's Avatar
Senior Member
Thanks Meter: 22
 
410 posts
Join Date:Joined: Jan 2009
More
Quote:
Originally Posted by Surge1223

If you don't know the purpose of this then don't download.

I dont know the purpose of this but I am curious as to what its for anyway lol

Would this allow us to install safestrap? or a real recovery install? or something completely different?
The Following User Says Thank You to RandumAccess For This Useful Post: [ View ]
17th September 2014, 05:02 PM |#7  
ahmed.zubair's Avatar
Member
Flag Karachi
Thanks Meter: 12
 
70 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by RandumAccess

I dont know the purpose of this but I am curious as to what its for anyway lol

Would this allow us to install safestrap? or a real recovery install? or something completely different?

It will allow us to flash insecure modules using safestrap .. I am not a dev but trying to answer what I understand from kexec insecure modules will be compiled with the stock kernel and then flashed so we can flash aosp roms . Correct me I know I am wrong somewhere .. lol
The Following 2 Users Say Thank You to ahmed.zubair For This Useful Post: [ View ]
17th September 2014, 10:50 PM |#8  
Surge1223's Avatar
OP Recognized Contributor
Flag Iowa
Thanks Meter: 5,273
 
1,949 posts
Join Date:Joined: Nov 2012
Donate to Me
More
So I've gotten quite a few messages about this asking what it does and what it's for etc. This does the same thing bypasslkm does (this is a reimplementation of bypasslkm for NC5 and NC1). You guys can read the bypasslkm thread over in AT&T S4 dev thread by jeboo to learn more.

If you have trouble getting wifi to work on a custom rom though this will allow the wifi module to load. I wanted to avoid having to say that so every Tom, Dick and Harry doesn't rush in here to ask why wifi won't work on so and so's rom and why this didnt fix it.

Will this allow AOSP or unlock your bootloader? No, it will not.

Will it allow you to load modules that are compatible? Yes it will. Granted you know how to load modules (if not, Google insmod)
The Following 6 Users Say Thank You to Surge1223 For This Useful Post: [ View ]
18th September 2014, 12:54 AM |#9  
joshuabg's Avatar
Recognized Contributor
Thanks Meter: 847
 
1,504 posts
Join Date:Joined: May 2012
Donate to Me
More
Quote:
Originally Posted by Surge1223

So I've gotten quite a few messages about this asking what it does and what it's for etc. This does the same thing bypasslkm does (this is a reimplementation of bypasslkm for NC5 and NC1). You guys can read the bypasslkm thread over in AT&T S4 dev thread by jeboo to learn more.

If you have trouble getting wifi to work on a custom rom though this will allow the wifi module to load. I wanted to avoid having to say that so every Tom, Dick and Harry doesn't rush in here to ask why wifi won't work on so and so's rom and why this didnt fix it.

Will this allow AOSP or unlock your bootloader? No, it will not.

Will it allow you to load modules that are compatible? Yes it will. Granted you know how to load modules (if not, Google insmod)

So does this mean we will be able to load 4.4.4 Touchwiz Roms, without changing our bootloader?

Sent from my OtterX using Tapatalk
The Following User Says Thank You to joshuabg For This Useful Post: [ View ]
18th September 2014, 08:28 PM |#10  
Surge1223's Avatar
OP Recognized Contributor
Flag Iowa
Thanks Meter: 5,273
 
1,949 posts
Join Date:Joined: Nov 2012
Donate to Me
More
Quote:
Originally Posted by joshuabg

So does this mean we will be able to load 4.4.4 Touchwiz Roms, without changing our bootloader?

Sent from my OtterX using Tapatalk

No, but it also doesn't mean you can't. I haven't tried to boot a 4.4.4 rom so I have no idea if they fail due to module incompatibility.

The Following User Says Thank You to Surge1223 For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes