Post Reply

i9500 - GPS bad signal problems

4th August 2014, 12:20 PM   |  #1  
OP Senior Member
Thanks Meter: 3
 
329 posts
Join Date:Joined: May 2004
More
I have tried several ROM's lately for the i9500 (ROMs like Ozcan, ARROW and more).
Those ROMs runs Android 4.4.2.

In all of those ROMs I have severe GPS signal problem.

Initial GPS fix is very slow - sometimes between 1-2 minutes. While driving the device is loosing the GPS signal every several minutes.
Its seems that even the GPS accuracy, is not at its best.

In settings/location it set to "high accuracy".

I've installed GPS fix with no use.

Currently I'm with Arrow ROM v.15
Basaband - UGNE3

Any ideas how to remedy that problem would be very welcomed.
7th August 2014, 07:23 PM   |  #2  
Junior Member
Thanks Meter: 2
 
25 posts
Join Date:Joined: Jul 2011
Pls try Hassan rom v7.0, I'm running it now on my i9500 and the gps is excellent. You may want to give it a try.

Sent from my GT-I9500 using XDA Free mobile app
8th August 2014, 05:35 PM   |  #3  
OP Senior Member
Thanks Meter: 3
 
329 posts
Join Date:Joined: May 2004
More
Quote:
Originally Posted by ams73

Pls try Hassan rom v7.0, I'm running it now on my i9500 and the gps is excellent. You may want to give it a try.

Sent from my GT-I9500 using XDA Free mobile app

I've tried it, but the problem is there as well.

something is wrong in my device in 4.4.2
14th August 2014, 12:21 AM   |  #4  
OP Senior Member
Thanks Meter: 3
 
329 posts
Join Date:Joined: May 2004
More
Quote:
Originally Posted by amir77a

I've tried it, but the problem is there as well.

something is wrong in my device in 4.4.2

I've tried numerous ROM's, but the problem persists.

Be glad for help in that.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy S 4 Q&A, Help & Troubleshooting by ThreadRank