Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,736,064 Members 41,440 Now Online
XDA Developers Android and Mobile Development Forum

[i9505G] No Call Audio

Tip us?
 
jcreations4637
Old
(Last edited by jcreations4637; 7th July 2014 at 03:00 PM.) Reason: Re-format post for easier reading
#1  
Junior Member - OP
Thanks Meter 3
Posts: 26
Join Date: Dec 2013
Audio [i9505G] No Call Audio

Hello!

My Galaxy S4 Google Edition has randomly stopped connecting audio for calls in either direction. I have already tried all solutions I could find on the internet and this forum, including:
  • Reboot the phone
  • Check audio settings
  • Factory reset
  • Install multiple different stock firmwares
  • Install multiple modem versions for my phone
  • Test calling with other apps
  • Change type of network (GSM/CDMA/Global/etc)
  • Opening and drying the phone
  • New SIM card
  • New carrier

I have determined that:
  • The calls work after leaving the battery out or switching batteries for about 2 calls before it quits again.
  • All speakers are working, but no audio ONLY during cellular calls.
  • Texting/Data works and calls on this SIM card work in other phones.
  • Calling DOES always work ONLY when using a bluetooth headset

Please Note:
  • It appears to NOT be a software issue, but I am not ruling that out.
  • Just replacing the phone would not be optimal, if possible -- I have no warranty or contract.

So, are there any last effort things I can try before I have to sell this phone as a broken device?
Thanks!
One does not simply telnet into Mordor!
 
jcreations4637
Old
(Last edited by jcreations4637; 7th July 2014 at 03:01 PM.) Reason: Remove quote
#2  
Junior Member - OP
Thanks Meter 3
Posts: 26
Join Date: Dec 2013
Would anyone have an idea what piece of hardware could be broken? Any last software suggestions? I will be trying to sell this in a few days if no one knows anything else I can try.
One does not simply telnet into Mordor!
 
Lennyz1988
Old
#3  
Senior Member
Thanks Meter 183
Posts: 1,525
Join Date: May 2009
Location: Netherlands
Well the only thing you didn't try is a different simcard.
Current:

Samsung Galaxy S 4 I9505 | WanamLite v2.6

Retired:

Samsung Galaxy S II I9100 : AOKP 4.2.1
HTC Touch Pro2 | ROM: Valkyrie 6.5.23115TR2.5
HTC HD2 | DarkStone1337 [FroyoStone Sense - V3.2]
HTC Desire : Oxygen v2.1.3
 
jcreations4637
Old
#4  
Junior Member - OP
Thanks Meter 3
Posts: 26
Join Date: Dec 2013
Quote:
Originally Posted by Lennyz1988 View Post
Well the only thing you didn't try is a different simcard.
I just tried it and no difference. By extension, the new SIM was also a new carrier, so it was not related to that either. Thanks for the idea.
One does not simply telnet into Mordor!
 
jessephilip
Old
(Last edited by jessephilip; 5th July 2014 at 05:37 PM.) Reason: More information
#5  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Apr 2013
Default Same EXACT Problem

Not that this helps you at all, but I have the same exact problem. I have tried most of the same "solutions" you have tried as well, also to no avail. I have tried countless ROMs, reboots, Odin flashes, etc. What gets me is that once in a while, after installing a ROM or using Odin to go back to stock, I'll get my call audio back for a day or two. Eventually, and without apparent reason, the call audio goes away, and I'm back where I started.

In fact, I was about to write my own XDA post, but then I saw yours, and figured it would suffice.

Good luck. I hope someone has a solution out there because I'm at my wit's end.

Correction: All the same except that my phone is actually a MetroPCS SGH-M919N. Supposedly its the exact same model as the i9505.
 
jcreations4637
Old
(Last edited by jcreations4637; 7th July 2014 at 03:02 PM.) Reason: Splice quote
#6  
Junior Member - OP
Thanks Meter 3
Posts: 26
Join Date: Dec 2013
Quote:
Originally Posted by jessephilip View Post
Not that this helps you at all, but I have the same exact problem. ... Correction: All the same except that my phone is actually a MetroPCS SGH-M919N. Supposedly its the exact same model as the i9505.
Well, good to know it's not only the Google Edition. I believe the other threads I saw were from other models, too. The S4 must just have a cheaply made/defective part.

I've added one last observation to my list. I will probably make a swappa boneyard listing in a few days if anyone is interested.
One does not simply telnet into Mordor!
 
MAX 404
Old
#7  
MAX 404's Avatar
Senior Member
Thanks Meter 564
Posts: 894
Join Date: Sep 2012
Location: Panama / Spain
Hi ,

Not clear if you guys have custom roms or not...


I seen similar problems like that in I9500 models and most of the time the problem was modem related..did you try to flash/ reflash a modem ( new or same) ?
Read before doing
Search before asking
Don’t just say thanks if the information was useful, hit thanks too……

Omega one of the last good roms for the I9500 keep it alive , DONATE , your phone will thank you ....

 
jcreations4637
Old
#8  
Junior Member - OP
Thanks Meter 3
Posts: 26
Join Date: Dec 2013
Quote:
Originally Posted by MAX 404 View Post
Hi ,

Not clear if you guys have custom roms or not...


I seen similar problems like that in I9500 models and most of the time the problem was modem related..did you try to flash/ reflash a modem ( new or same) ?
I believe both of us have custom roms (and have tried flashing stock), and we have tried flashing a new modem (old and new). Although, since calling partially works, I will try a few more modems and report back.
One does not simply telnet into Mordor!

Tags
no audio
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Automate Your Device with Sfen

Changing the profile of yourdevice manually is now long forgotten. Since the advent of Android automation … more

Galaxy Photo Screen Lock Displays a Photo Slideshow on Your Lock Screen

Being the most often looked at part of our devices UI, the lock … more

Boost the LG G3 Speaker and Headphone Volume

It seems like OEMs are stepping up their game, with regards to thequality of their devices sound … more

Forums Added for the HTC Desire 610 and LG G3 US Carrier Variants

We recently added two new sets of forums here on XDA. The first … more