FORUMS

Swype update broke my phone

194 posts
Thanks Meter: 35
 
By lukair1983, Senior Member on 25th August 2014, 08:12 AM
Post Reply Subscribe to Thread Email Thread
Hi

I updated swype yesterday, which went fine in itself. I restarted the phone couple hours later, and the phone got stuck on the Samsung logo. Tried restarting, pulling out the battery, nothing did the trick.

Clearing the cache's helped, but only to some extend. Immiedietly after going into homescreen, apps started to crash, starting from Nova Launcher.

Loading the nandroid backup that I did in june helped, so much so, that I pinpointed that swype was the one app that messes things up. I loaded the nandroid backup of broken OS that I did, and tried to uninstall swype from adb which went fine, but the problem did not go away, which makes me believe something is deeply broken over here.

Anybody had similar expieriences in the past, and could point me out to how to fix the problem? I really would hate to re-do all the things I did on the phone since june.
 
 
26th August 2014, 04:55 AM |#2  
LancerEvoDrifter's Avatar
Senior Member
Flag Houston
Thanks Meter: 15
 
More
Quote:
Originally Posted by lukair1983

Hi

I updated swype yesterday, which went fine in itself. I restarted the phone couple hours later, and the phone got stuck on the Samsung logo. Tried restarting, pulling out the battery, nothing did the trick.

Clearing the cache's helped, but only to some extend. Immiedietly after going into homescreen, apps started to crash, starting from Nova Launcher.

Loading the nandroid backup that I did in june helped, so much so, that I pinpointed that swype was the one app that messes things up. I loaded the nandroid backup of broken OS that I did, and tried to uninstall swype from adb which went fine, but the problem did not go away, which makes me believe something is deeply broken over here.

Anybody had similar expieriences in the past, and could point me out to how to fix the problem? I really would hate to re-do all the things I did on the phone since june.

so, let me try and understand this, if you don't update swype, there is nothing wrong with your phone?
26th August 2014, 07:58 AM |#3  
OP Senior Member
Thanks Meter: 35
 
More
Correct. For now I'm on my june nandroid backup and everything works as expected.
27th August 2014, 08:29 AM |#4  
OP Senior Member
Thanks Meter: 35
 
More
Solved

It turned out this update made swype be disabled in the OS keyboard settings, and combined with the fact I froze native keyboard apk, it made unnexpected results after every boot.

Once I restored the native keyboard apk in my june image, swype update went fine, and everything is back to normal.

Topic can be closed.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes