Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,807,128 Members 40,352 Now Online
XDA Developers Android and Mobile Development Forum

[SOLVED] WiFi won't turn on - Samsung Galaxy S4 I9505

Tip us?
 
valic1986
Old
(Last edited by valic1986; 15th August 2014 at 05:39 PM.) Reason: solved
#1  
valic1986's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: May 2011
Location: Zagreb
Default [SOLVED] WiFi won't turn on - Samsung Galaxy S4 I9505

Hi,

Recently have rooted my S4 I9505, and have put this ROM (Google customized Edition build - using Ktoonsez kernel - http://forum.xda-developers.com/show....php?t=2557353)
WiFi and other stuff worked perfect.

In one moment have installed this app Pry-Fi (https://play.google.com/store/apps/d...hainfire.pryfi), just to test the app & functionality.
This day WiFi have started not connecting to networks (have connect to some), and day after cannot turn on Wifi

Log shows this error:
08-13 15:18:13.305 823-1038/? E/WifiHW﹕ ##################### set firmware type 0 #####################
08-13 15:18:13.305 823-1038/? E/WifiHW﹕ Cannot open "/data/.cid.info": No such file or directory
08-13 15:18:13.305 823-1038/? E/WifiHW﹕ ==========[WIFI] Station firmware load ===========
08-13 15:18:14.106 823-1038/? E/WifiHW﹕ return of insmod : ret = -1, No such device
08-13 15:18:14.106 823-1038/? E/WifiStateMachine﹕ Failed to load driver
08-13 15:18:14.156 823-1038/? E/WifiStateMachine﹕ sendErrorBroadcast code:10
08-13 15:18:14.156 823-1055/? E/WifiController﹕ Wi-Fi driver is unstable. Received CMD_STATEMACHINE_RESET


Then i have tried to return to stock ROM, trying CM11, but all of them have same error.
(also tried to flash modem and NON-HLOS.bin - also nothing)

Full wipe with TWRP or CMW6 - nothing.

At last have made full wipe with TWRP, and put again same ROM (but this time Pure Nexus edition)
And now i have following in my log (attached)

but from log you can see:
08-14 12:27:58.609 780-1148/system_process E/WifiHW﹕ Supplicant not running, cannot connect
08-14 12:27:58.609 780-1148/system_process E/WifiMonitor﹕ startMonitoring(wlan0) failed!
08-14 12:27:58.609 780-1148/system_process E/WifiStateMachine﹕ Failed to setup control channel, restart supplicant

Have tried fixes with replacing wlan0 in /system/etc/wifi/wpa_supplicant.conf - nothing happens

Any help appreciate

EDIT: After last change (see my third post below, WiFi works without problem, have connected on several places, connection is persistent)
Attached Files
File Type: txt log2.txt - [Click for QR Code] (33.0 KB, 3 views)
 
valic1986
Old
#2  
valic1986's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: May 2011
Location: Zagreb
Default 721

Quote:
Originally Posted by valic1986 View Post
Hi,

Recently have rooted my S4 I9505, and have put this ROM (Google customized Edition build - using Ktoonsez kernel - http://forum.xda-developers.com/show....php?t=2557353)
WiFi and other stuff worked perfect.

In one moment have installed this app Pry-Fi (https://play.google.com/store/apps/d...hainfire.pryfi), just to test the app & functionality.
This day WiFi have started not connecting to networks (have connect to some), and day after cannot turn on Wifi

Log shows this error:
08-13 15:18:13.305 823-1038/? E/WifiHW﹕ ##################### set firmware type 0 #####################
08-13 15:18:13.305 823-1038/? E/WifiHW﹕ Cannot open "/data/.cid.info": No such file or directory
08-13 15:18:13.305 823-1038/? E/WifiHW﹕ ==========[WIFI] Station firmware load ===========
08-13 15:18:14.106 823-1038/? E/WifiHW﹕ return of insmod : ret = -1, No such device
08-13 15:18:14.106 823-1038/? E/WifiStateMachine﹕ Failed to load driver
08-13 15:18:14.156 823-1038/? E/WifiStateMachine﹕ sendErrorBroadcast code:10
08-13 15:18:14.156 823-1055/? E/WifiController﹕ Wi-Fi driver is unstable. Received CMD_STATEMACHINE_RESET


Then i have tried to return to stock ROM, trying CM11, but all of them have same error.
(also tried to flash modem and NON-HLOS.bin - also nothing)

Full wipe with TWRP or CMW6 - nothing.

At last have made full wipe with TWRP, and put again same ROM (but this time Pure Nexus edition)
And now i have following in my log (attached)

but from log you can see:
08-14 12:27:58.609 780-1148/system_process E/WifiHW﹕ Supplicant not running, cannot connect
08-14 12:27:58.609 780-1148/system_process E/WifiMonitor﹕ startMonitoring(wlan0) failed!
08-14 12:27:58.609 780-1148/system_process E/WifiStateMachine﹕ Failed to setup control channel, restart supplicant

Have tried fixes with replacing wlan0 in /system/etc/wifi/wpa_supplicant.conf - nothing happens

Any help appreciate
well, that escalated quickly

Have checking build.prop and seen that ro.wifi.channels was empty.
I have add value 14, restart, and WiFi is finally back, at least temporary

Then is again disconnected, even WiFi signal of previoues connected network is great (but is not turned OFF)
 
valic1986
Old
(Last edited by valic1986; 15th August 2014 at 10:54 AM.) Reason: Moving log to attachment
#3  
valic1986's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: May 2011
Location: Zagreb
Quote:
Originally Posted by valic1986 View Post
well, that escalated quickly

Have checking build.prop and seen that ro.wifi.channels was empty.
I have add value 14, restart, and WiFi is finally back, at least temporary

Then is again disconnected, even WiFi signal of previoues connected network is great (but is not turned OFF)
Quote:
Originally Posted by valic1986 View Post
well, that escalated quickly

Have checking build.prop and seen that ro.wifi.channels was empty.
I have add value 14, restart, and WiFi is finally back, at least temporary

Then is again disconnected, even WiFi signal of previoues connected network is great (but is not turned OFF)
when i have writing this answer, WiFi turned OFF (grey button, not possible to turn ON)
Again value was there after restart but not working, have switched to channel 11 (which is on my router)

Now works, but after several minutes just disconnect, some time stuck on turning ON and go back to position that is not working again



Entire log in attachment
Attached Files
File Type: txt log3.txt - [Click for QR Code] (9.5 KB, 1 views)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes