Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

SM-G906S (S805) -- ACTIVATE LTE on AT&T

OP miscom

31st August 2014, 03:41 PM   |  #21  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Apr 2012
Quote:
Originally Posted by miscom

I am on AT&T and the reason I bought this phone was because, according to the specs in the FCC site, it has LTE Band 17 (which is the most common one for AT&T).

I was only getting 3G (HSPA+) speeds. I followed the following procedure to enable LTE for data and still be able to place/receive phone calls:

Do this at your own risk

  1. Open the dial pad
  2. Type: *#0011# to enter Service Mode (Be very careful with what you do here)
    Note: You need to be rooted for this to work
  3. Once in Service Mode, do the following:
    1. Tap the menu button and tap Back
    2. Tap the menu button again and select "Key Input" and enter an upper case Q and press OK
    3. Tap the menu button again and select "Key Input" and enter 4 zeroes (0000) and press OK
    4. Wait from 5 to 15 seconds. You'll see the Main Menu
  4. Choose option [2]: UE SETTING & INFO
  5. Choose option [1]: SETTING
  6. Choose option [1]: PROTOCOL
  7. Choose option [2]: NAS
  8. Choose option [1]: NETWORK CONTROL
  9. Choose option [4]: BAND SELECTION
  10. Choose option [4]: LTE Band Preference
  11. Choose option [7]: LTE ALL (Or you can choose band 17 instead)
  12. Tap the menu button and choose Back (Don't press the back key)
  13. Tap again the menu button and choose Back
  14. Choose option [6]: LTE/WCDMA Mode Only
  15. Press the back key to exit

And that's it: You now have LTE and calls if using AT&T. This won't work with TMobile.

If you reboot your phone, you may need to repeat the steps.



Are you sure G906S have band 17? I ask 4 person, they dont see the band 17 on G906S.
Attached Images
File Type: jpg ???.jpg - [Click for QR Code] (58.0 KB, 240 views)
File Type: jpg ???1.jpg - [Click for QR Code] (61.8 KB, 235 views)
31st August 2014, 05:48 PM   |  #22  
miscom's Avatar
OP Senior Member
Flag Gallatin, TN
Thanks Meter: 1,244
 
1,284 posts
Join Date:Joined: Oct 2007
Donate to Me
More
Quote:
Originally Posted by wst9344

Are you sure G906S have band 17? I ask 4 person, they dont see the band 17 on G906S.

Yes, it has band 17. Did you follow the procedure in the OP?

Also, try LTE All from the menu you show in your attachment.
31st October 2014, 10:40 AM   |  #23  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Oct 2014
AT&T LLT
*AT&T LTE
I have the 906s. I followed all the steps to activate LTE and the best I get is H+. I've tried B17 and ALL LTE but still can' t get it to work. Even if I'm in a strong LTE area, still not working.
Last edited by DE88; 31st October 2014 at 10:45 AM. Reason: typo
31st October 2014, 01:57 PM   |  #24  
fffft's Avatar
Senior Member
Thanks Meter: 622
 
1,978 posts
Join Date:Joined: Jul 2013
..
Attached Thumbnails
Click image for larger version

Name:	2263.png
Views:	185
Size:	155.1 KB
ID:	2992777  
Last edited by fffft; 10th November 2014 at 02:30 PM.
7th November 2014, 12:11 AM   |  #25  
Senior Member
Thanks Meter: 47
 
306 posts
Join Date:Joined: Dec 2011
@miscom
If I have 900a/900t This can work too?
I'm tring to see whice Bands are active in LTE 1800+2600 and to active it if they inactive.

There is a way just to see whice are active without root? (just enter with the code and see?)
7th November 2014, 03:24 AM   |  #26  
miscom's Avatar
OP Senior Member
Flag Gallatin, TN
Thanks Meter: 1,244
 
1,284 posts
Join Date:Joined: Oct 2007
Donate to Me
More
Quote:
Originally Posted by u1988

@miscom
If I have 900a/900t This can work too?
I'm tring to see whice Bands are active in LTE 1800+2600 and to active it if they inactive.

There is a way just to see whice are active without root? (just enter with the code and see?)

This works without root. I don't have a 900a/900t device but you should not lose anything by trying and following the steps on the OP.
The Following User Says Thank You to miscom For This Useful Post: [ View ]
10th December 2014, 05:38 AM   |  #27  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Dec 2014
Unhappy
NOT WORKING on my G906s

It says Connection problem or invalid mmi code.

I need help please I cant get HDSPA or LTE, only slow 3G.

Side info: my phone is rooted and using at&t. I can make and receive calls. Only problem is data .
11th December 2014, 12:11 PM   |  #28  
Junior Member
Flag Caracas
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jan 2013
More
Quote:
Originally Posted by miscom

This works without root. I don't have a 900a/900t device but you should not lose anything by trying and following the steps on the OP.

Hi man, this work perfect in my G906L... I am in Tenerife, Spain on vacation and i bought a VODAFONE sim card, and i was just getting H/H+, i choose ALL LTE and now i have LTE xD! Excellent! But there is no way to leave this configuration for ever? Use the LTE All even if i reboot the device...??
11th December 2014, 12:21 PM   |  #29  
Audioboxer's Avatar
Senior Member
Thanks Meter: 440
 
2,474 posts
Join Date:Joined: Aug 2010
More
Quote:
Originally Posted by chekole

NOT WORKING on my G906s

It says Connection problem or invalid mmi code.

I need help please I cant get HDSPA or LTE, only slow 3G.

Side info: my phone is rooted and using at&t. I can make and receive calls. Only problem is data .

If rooted try deleting MobileNetworks apk with Titanium Backup.
12th December 2014, 09:02 AM   |  #30  
Senior Member
Thanks Meter: 2
 
240 posts
Join Date:Joined: Jun 2009
Quote:
Originally Posted by wst9344

Are you sure G906S have band 17? I ask 4 person, they dont see the band 17 on G906S.

so the settings dont stick is because of the anti temper mode right? the settings should stick if the phone is rooted AND custom rom.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes