Post Reply

[TUT] root WITHOUT tripping knox

OP mattyyey

23rd September 2014, 09:12 AM   |  #121  
Member
Thanks Meter: 20
 
42 posts
Join Date:Joined: Aug 2014
More
Quote:
Originally Posted by agyawusu2012

it didnt work on my G900H(exynos variant) but it worked for my friends with the snapdragon variant..please help me...it says this device is not supported

not all machine can be pacht with TR
and / or
it depend of your firmware
30th September 2014, 02:45 PM   |  #122  
Member
Thanks Meter: 0
 
30 posts
Join Date:Joined: Jul 2011
Hi everyone,

When trying to run towelroot I get phone not supported. However I have a galaxy s5 g900F.
kernel version is 3.4.0-2089850
30th September 2014, 08:52 PM   |  #123  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Sep 2014
battery stopped charging
Quote:
Originally Posted by mattyyey

Hi everyone.

I'm no-one special, but I have rooted several phones. I usually wait till the ability to revert or not trip a counter (knox in this case, but most stock bootloaders have one these days afaik ). I had some spare time and have been researching for the last few hours getting my facts straight before I attempted anything. I now have root.

I'm only writing this because it wasn't too clear on the forums about rooting without tripping knox, even after some searching and reading the stickies.

I have just rooted my S5 (SM-G900F). I can confirm that the knox counter isnt tripped using a samsung phone info app i found (also double checked in dl mode).

before we start, heres some notes:
- So as far as I understand, towelroot works on more than just the SM-G900F but i suggest you check first.
- Using odin will add to your counter if you flash anything other than stock with it afaik. This was the same for me on the S3 but I had triangle away.
- Installing a custom recovery via odin will add to the knox counter obviously.
- Installing a custom recovery via another method might trip knox.
- Flashing a custom ROM will add to the counter. (couldnt anyway without custom recovery)
- Boot into download mode using VOLDOWN, HOME, POWER and click continue (i suggest un-plugging it) this will show u the counter.
- Quick view the counter with this app: Phone INFO Samsung
-With root access it might be possible to do something that will trip knox, even with it "disabled" by supersu. be careful.
- apparently if you trip knox, you cannot update the radio. quote from alan shore
- OTA updates will probably remove root
- Most places, if you trip the counter, your warranty is void.
- you can fix s health issuses caused by xposed by editing the build.prop (not sure how same that is with knox)


Heres how I did it:
(0. I actually did a OTA and security policy update check before attempting this.)
1. disable security policy updates (security) and automatic updates (about) in the settings. This is just in case. Updates might remove your root.

2. Download tr.apk from towelroot.com/ by clicking the icon. Please note that when i did this Avast AV flagged it up, which i then disabled and re-downloaded the file. Use at your own risk. I had no problems...

3. Enable Unknown Sources (settings->security), copy the apk to your sdcard install. I again got a flag from avast... i clicked ignore

4. Run it. Might take a little while...

5. Install SuperSU from the market.

6. Run super su and let it install the su binaries.

7. Depending on what you want root for, you may wish to disable knox using super su (i intend to use xposed so i did). When I attempted to let it disable knox, it failed. As it instructed, I rebooted and ran it again... all done.

Now I installed root checker and titanium backup and had a play. root works. I rebooted and checked download mode, knox counter : 0x0 root is still there after reboot. all done! Make sure you have read and understand the notes before you go off using root.

I hold no responsibility for any damage or loss of data.
I do not claim to have made anything. a big thanks to all the respective contributing devs, esp chainfire for his never ending development for android, and geohot creator of towelroot for making it all possible.

If you have errors and questions the original thread for towelroot is below:
http://forum.xda-developers.com/show....php?t=2783157

That's all folks!


Hi i made all this stepps but now my s5 do not want to charg. When the battery runs out and i insert the charger to charge my phone it comes a triangel whith exclamation inside. my phone dose not start now.

Please help...

sorry for my bad english...
1st October 2014, 09:14 PM   |  #124  
OP Senior Member
Flag Manchester
Thanks Meter: 60
 
176 posts
Join Date:Joined: Mar 2010
More
can you get to recovery or download mode? did everything go correctly? no error messages? tried another battery?

if you can get to download and recovery mode, I suggest you do a factory reset, then if no improvement, flash a official stock rom using odin
5th October 2014, 01:26 AM   |  #125  
djb77's Avatar
Recognized Contributor
Flag NSW
Thanks Meter: 1,612
 
1,602 posts
Join Date:Joined: Oct 2011
Donate to Me
More
I have a G900I with FW 4.4.2 G900IDVU1ANE1
Should it be OK for me just to install and run the APK?

EDIT: Worked flawlessly
Attached Thumbnails
Click image for larger version

Name:	screenshot.png
Views:	238
Size:	62.2 KB
ID:	2960344  
Last edited by djb77; 5th October 2014 at 06:50 AM.
6th October 2014, 02:45 PM   |  #126  
the_rooter's Avatar
Senior Member
Flag Olean
Thanks Meter: 99
 
426 posts
Join Date:Joined: Aug 2014
More
Hello Guys I just stopped by and wanted to post something maybe can help out.

I am currently on a note 3 for verizon, and I noticed that if anyone took the newest update that towelroot wont work after a certain date. Well for the note 3 you can downgrade the kernel to an earlier date. I guess samsung left this open to be able to do so. For anyone that has an s5 and cant root with towelroot because you took the update can you downgrade the kernel via odin and see if that works? A friend wants to root, and cant right now because of the date after june 3rd. I am just coming up with an idea of doing this because we can with the note 3.
The Following User Says Thank You to the_rooter For This Useful Post: [ View ]
7th October 2014, 03:12 PM   |  #127  
Just installed it on my Canadian S5 G900W8 and works like charm.
8th October 2014, 12:11 PM   |  #128  
Member
Thanks Meter: 2
 
50 posts
Join Date:Joined: Jul 2010
Gutted! Rooted this about a few months ago and loved it all. Had to unroot to take back to the store. Came back to find TR won't work... I'm on NG2 due to recent update.
19th October 2014, 07:59 AM   |  #129  
georgemircea's Avatar
Junior Member
Flag bucharest
Thanks Meter: 0
 
24 posts
Join Date:Joined: Sep 2014
More
please ,can anybody how mod to root my device ? there is a lot of information on xda, and i do not know wich is correct for my device, thank's in advance
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-10-19-09-50-32.png
Views:	69
Size:	244.3 KB
ID:	2976617  

Post Reply Subscribe to Thread

Tags
guide, knox, root, towelroot, tutorial
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy S 5 General by ThreadRank