Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,427 Members 40,687 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Galaxy S5 showing "This SIM Card is from an unknown source."

Tip us?
 
rwestbrookjr
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 6
Join Date: Aug 2014
Default [Q] Galaxy S5 showing "This SIM Card is from an unknown source."

I have a Verizon version of the Galaxy S5 that I recently switched over to the Cricket network. I have been getting the notification in the title ever since switching over. So I rooted the phone in hopes that I would be able to resolve this issue. Below are the specs of my phone as well as things I have tried.
Model Number : SM-G900V
Android Version : 4.4.2
Baseband Version : G900VVRU1ANCG
Kernel Version :3.4.0
dpi@SQDD5814#1
Mon Mar 31 13:30:24 KST 2014
Build Number : KKOT49H.G900VVRU1ANCG
SE For Android Status: Enforcing
SEPF_SM-G900V_4.4.2_0017
Wed Jun 25 17:51:34 2014
Hardware Version : G900V.05
Security Software Version: MDF v1.0 Release 2
VPN v1.4 Release 1

After rooting the phone I have gone through and turned off all Verizon related apps as well as cleared the phone's cache from recovery mode. I also tried searching in the /system, /system/app, and /system/bin directories for the following files to no avail:
vzwphoneservice.apk
vzwphoneservice.odex
VzwController.apk
VzwController.odex

I would like to remove everything Verizon related from the phone, but I'm sure this would be much more involved than I want to get so if we can get the unknown sim card message to go away and hopefully the 'Wi-Fi Detected' screen that keeps prompting me to sign into Verizon, that would be great.
Thank you for your help,
Ron
The Following User Says Thank You to rwestbrookjr For This Useful Post: [ Click to Expand ]
 
fffft
Old
#2  
fffft's Avatar
Senior Member
Thanks Meter 408
Posts: 1,543
Join Date: Jul 2013
Quote:
Originally Posted by rwestbrookjr View Post
I have a Verizon version of the Galaxy S5 that I recently switched over to the Cricket network. I have been getting the notification in the title ever since switching over. So I rooted the phone in hopes that I would be able to resolve this issue. Below are the specs of my phone as well as things I have tried.
Model Number : SM-G900V
Android Version : 4.4.2
Baseband Version : G900VVRU1ANCG
Kernel Version :3.4.0
dpi@SQDD5814#1
Mon Mar 31 13:30:24 KST 2014
Build Number : KKOT49H.G900VVRU1ANCG
SE For Android Status: Enforcing
SEPF_SM-G900V_4.4.2_0017
Wed Jun 25 17:51:34 2014
Hardware Version : G900V.05
Security Software Version: MDF v1.0 Release 2
VPN v1.4 Release 1

After rooting the phone I have gone through and turned off all Verizon related apps as well as cleared the phone's cache from recovery mode. I also tried searching in the /system, /system/app, and /system/bin directories for the following files to no avail:
vzwphoneservice.apk
vzwphoneservice.odex
VzwController.apk
VzwController.odex

I would like to remove everything Verizon related from the phone, but I'm sure this would be much more involved than I want to get so if we can get the unknown sim card message to go away and hopefully the 'Wi-Fi Detected' screen that keeps prompting me to sign into Verizon, that would be great.

Thanks for starting a new thread.

As you have a Verizon phone, I agree that the annoying nag you are seeing is caused by the Verizon setup app. And unless they have renamed their app (which would just mean searching a bit more).. it should be one of the names you listed above.

At a glance, it just appears that you didn't search in all of the places that the app could be located. It's probably located in the /system/priv-app directory.. and you didn't list that as a place that you looked.

Is your phone rooted?
You can use a root aware browser like FX or a terminal emulator app and search these directories:

/data/app or /data/data/app or /userdata/app
/system/app
/system/priv-app

Then rename the file and it's odex counterpart, clear your cache and reboot..
Let us know if that succeeds or not.


--
If you are using the command line, try

Code:
$ su
# find / -name vzwphoneservice.*
et cetera


.
 
rwestbrookjr
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 6
Join Date: Aug 2014
Quote:
Originally Posted by fffft View Post
Thanks for starting a new thread.

As you have a Verizon phone, I agree that the annoying nag you are seeing is caused by the Verizon setup app. And unless they have renamed their app (which would just mean searching a bit more).. it should be one of the names you listed above.

At a glance, it just appears that you didn't search in all of the places that the app could be located. It's probably located in the /system/priv-app directory.. and you didn't list that as a place that you looked.

Is your phone rooted?
You can use a root aware browser like FX or a terminal emulator app and search these directories:

/data/app or /data/data/app or /userdata/app
/system/app
/system/priv-app

Then rename the file and it's odex counterpart, clear your cache and reboot..
Let us know if that succeeds or not.


--
If you are using the command line, try

Code:
$ su
# find / -name vzwphoneservice.*
et cetera


.
I'm comin up snake eyes on this search. FX doesn't seem to be allowing me to use the '*' wildcard in file name searches, and the terminal emulator i installed apparently can't even use the 'find' function. Any other ideas?
 
fffft
Old
#4  
fffft's Avatar
Senior Member
Thanks Meter 408
Posts: 1,543
Join Date: Jul 2013
Quote:
Originally Posted by rwestbrookjr View Post
I'm comin up snake eyes on this search. FX doesn't seem to be allowing me to use the '*' wildcard in file name searches, and the terminal emulator i installed apparently can't even use the 'find' function. Any other ideas?

Is your phone rooted
Are you using the root version of FX?

The wildcard was intended for the command line. Search for an exact file name in FX if you need to (or look up what they use for a wild card).

e.g.
vzwphoneservice.apk
vzwphoneservice.odex
VzwController.apk
VzwController.odex

.
 
rwestbrookjr
Old
#5  
Junior Member - OP
Thanks Meter 1
Posts: 6
Join Date: Aug 2014
Quote:
Originally Posted by fffft View Post
Is your phone rooted
Are you using the root version of FX?

Try using the built in search function in FX root to have the app do the search for you.

Or from the command line, try searching for the exact file name:

find / -name vzwphoneservice.apk
find / -name vzwphoneservice.odex

et cetera

.

---------- Post added at 02:00 PM ---------- Previous post was at 01:59 PM ----------

..
Like I had originally posted, Rooting my phone was one of the first things I did to try to resolve the issue. I did install the root add-on for FX and it prompts me for root permission when I go to a 'protected' directory. As far as command line, using Terminal Emulator that i downloaded from the Play Store. When I run the commands you suggest, it tells me "find: not found". I'm in the process of installing ADB on my computer now to try to use that command line.
 
rwestbrookjr
Old
#6  
Junior Member - OP
Thanks Meter 1
Posts: 6
Join Date: Aug 2014
I haven't forgotten about you guys, I've just been busy as hell. I'll let you know as soon as I can get a command line script to run and we can move forward.

Sent from my SM-G900V using Tapatalk
 
calinormy
Old
#7  
calinormy's Avatar
Senior Member
Thanks Meter 27
Posts: 173
Join Date: Jul 2008
My advice is to go to the Note 3 forums. I had that problem too with an note from verizon and i succesfully deleted an app from note. I don't remember wich one is responsable for that message but it is possible after root. Check first on verizon note 3 forum.
 
THA-REAPER
Old
(Last edited by THA-REAPER; 22nd August 2014 at 09:46 PM.)
#8  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Aug 2014
Quote:
Originally Posted by rwestbrookjr View Post
I have a Verizon version of the Galaxy S5 that I recently switched over to the Cricket network. I have been getting the notification in the title ever since switching over. So I rooted the phone in hopes that I would be able to resolve this issue. Below are the specs of my phone as well as things I have tried.
Model Number : SM-G900V
Android Version : 4.4.2
Baseband Version : G900VVRU1ANCG
Kernel Version :3.4.0
dpi@SQDD5814#1
Mon Mar 31 13:30:24 KST 2014
Build Number : KKOT49H.G900VVRU1ANCG
SE For Android Status: Enforcing
SEPF_SM-G900V_4.4.2_0017
Wed Jun 25 17:51:34 2014
Hardware Version : G900V.05
Security Software Version: MDF v1.0 Release 2
VPN v1.4 Release 1

After rooting the phone I have gone through and turned off all Verizon related apps as well as cleared the phone's cache from recovery mode. I also tried searching in the /system, /system/app, and /system/bin directories for the following files to no avail:
vzwphoneservice.apk
vzwphoneservice.odex
VzwController.apk
VzwController.odex

I would like to remove everything Verizon related from the phone, but I'm sure this would be much more involved than I want to get so if we can get the unknown sim card message to go away and hopefully the 'Wi-Fi Detected' screen that keeps prompting me to sign into Verizon, that would be great.
Thank you for your help,
Ron
A easier way you can stop that notification from coming up is to disable the app "Setup Wizard 1.0" its just called Setup Wizard when looking from you're app drawer. When you long press on the "This SIM Card is from an unknown source" notification and hit app info it points to it as the culprit. You can do it with Titanium Backup Pro, however TouchWiz has a option for you to disable stock apps and it behaves the same way as freezing in Titanium Backup Pro. You will get a disable option if its a stock app and which it is. I'm guessing they don't want you to just uninstall it. If you try to do it in Titanium Backup Pro it will work the same way as you disabling it via TouchWiz it even shows in the disabled apps. It should be a icon with a magic wand and a check symbol.

To disable it just hit apps to the bottom right assuming you are using the TouchWiz launcher then tap the 3 dots to the top right to bring up the menu and choose Uninstall/disable apps and scroll through your apps to find Setup Wizard and hit the - thingy to disable it.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes